locked
Help with ping RRS feed

  • Question

  • Hi all,

    We have servers win2008 SP2 when i ping them localy i get repsonses

    >PING computer1

    Reply from ::1: time<1ms

    Is it supposed to do that? In the host file i dont have

    ::1 COMUPUTER

    We have

    ::1 localhost

    But im not pingnig the local host im ping the computer by its name. I know that i can put the computer IP address in the host file but thats not realy the solution im looking for.

     

    TNX in advance!!!!

     

    Thursday, April 29, 2010 11:10 AM

Answers

All replies

  • hi ,

    can you post us the detailed response of ping ?

     

    Thursday, April 29, 2010 2:52 PM
  • look like an ipv6 address

    have you try " ping -4 <hostname> "?

    Friday, April 30, 2010 2:25 AM
  • Liyn u are right!

    when i do

    C:\Users\user1>ping -4 comuter1

    Pinging computer1.contoso.com [10.1.1.10] with 32 bytes of data:
    Reply from 10.1.1.10: bytes=32 time<1ms TTL=128
    Reply from 10.1.1.10: bytes=32 time<1ms TTL=128
    Reply from 10.1.1.10: bytes=32 time<1ms TTL=128

    I have an exchange CAS server , the IIS server has the OWA web site binded to 10.1.1.10, and not to the host name. So when i try to open the web site localy from the CAS server its not opening as its resolving the owa.contoso.com as ::1.

    How can i overaid it so that when i do PING computer1 i get ipv4 response?

    Tnx!!!

     

    Friday, April 30, 2010 7:05 AM
  •   Server 2008 has both IPv4 and IPv6 enabled by default. If you want ping to use IPv4 you need to use the -4 option.

      ::1 is the IPv6 loopback address. (127.0.0.1 is the IPv4 loopback address). If ping returns ::1 or 127.0.0.1 it means that you are pinging the local host (ie the same machine is sending and responding).

       What does ping have to do with opening a web site? What URL do you use to find the web site?

     


    Bill
    Friday, April 30, 2010 7:30 AM
  • im localy trying to open a web site on a server computer1

    In IIS i have default web site ---> 10.1.1.10 (80,443)

    No name bidinig or anythig like that.

     so when i try from a workstation http://comuputer1/ it opens it, as i have put it in DNS (A and PTR computer1  10.1.1.10 ) .

    But when i try the same thing localy from the IIS server computer1 it doesnt work. I dont have anything in the hosts file. 

    Friday, April 30, 2010 8:39 AM
  • So, is the IIS server's DNS setting as same as the Client setting?

     

    What is the result of "nslookup computer1" from your IIS server?

     

    Make sure the IIS server not assigned any ipv6 address.

     

    I suggest you can try disabling the IPv6 feature and delete the "::1 localhost" recode in HOST file of your IIS server

     

     

     

    How do I disable IPv6 in Windows Vista and Windows Server 2008?

     

    http://technet.microsoft.com/en-us/network/cc987595.aspx

     

    Domain Name System Client Behavior in Windows Vista

     

    http://technet.microsoft.com/en-us/library/bb727035.aspx#ECAA

    • Marked as answer by Karen Ji Thursday, May 6, 2010 7:54 AM
    Tuesday, May 4, 2010 2:07 AM
  • My bad i wasnt clear enought. Im trying to open the site from the IIS server. It wont open it. Im binding the site to the ip address, but i have an A record for that ip address in our DNS servers. When i try to open the site localy its not working, the IIS server (comupter1 in DNS) is resolving it self as ::1 and doesnt want to opent the website that is binded to and IP address. When i try to opent the site from an other computer everything works fine.

     

    Liyin i didnt get the time to read your links, ill read them and see if they answer my question.

    All the best 

    Friday, May 7, 2010 6:54 AM