none
Hyper-V VM Generation 2 - How to boot from .ISO RRS feed

  • Question

  • Hi guys, 

    Server OS: Windows Server 2012 R2

    I have a VM Gen2 with following settings: 

    I can boot fine from the same .iso from a Gen1 VM so the .iso is bootable. 

    I know that the Gen2 VM uses SCSI instead of IDE, but I have no clue regarding how to boot from the .iso..

    Any ideas?

    Thanks in advance!

    Best regards,

    Kenny

    Friday, November 8, 2013 8:31 AM

Answers

  • If you happen to respond to the select any key prompt quickly enough and you still get,this error I would probably recommend re-downloading the 64-bit OS image.

    in the past have seen issues with ISO images having very small, before t enough corruption that they fail in the boot process.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, November 21, 2013 3:52 PM
    Moderator

All replies

  • you have everything attached.  Your boot order is right.

    open the console of the VM, power it on, notice the dialog and kit a key to begin the ISO booting.

    If you power on the VM and go back later, you will find that it didn't boot to the ISO due to a dialog that must be responded to.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    • Proposed as answer by Tim CerlingMVP Friday, November 8, 2013 11:56 PM
    Friday, November 8, 2013 3:42 PM
    Moderator
  • Some questions -

    What version of Windows Server is the .ISO?
    Have you modified the .ISO in any way (for example to inject drivers) such that it is possible the resulting .ISO doesn't have the EFI boot loader present?
    It it simply a case of you not pressing a key when prompted quick enough? (Generation 2 is fairly fast going through possible boot entries)

    ________________________

    John Howard, Senior Program Manager, Hyper-V Team, Microsoft Corporation.
     This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.

    Thursday, November 14, 2013 6:42 PM
  • Hello Brian, 

    When I hit a key to confirm boot from ISO, i get this message: 

    The ISO file is a standard Windows Server 2012 R2 from VLSC and is not modified.

    Best regards,

    Kenny

    Wednesday, November 20, 2013 10:50 AM
  • If you happen to respond to the select any key prompt quickly enough and you still get,this error I would probably recommend re-downloading the 64-bit OS image.

    in the past have seen issues with ISO images having very small, before t enough corruption that they fail in the boot process.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, November 21, 2013 3:52 PM
    Moderator
  • What was the result of this thread? I am having the same problem with a Gen 2 VM of Server 2012 R2. I also downloaded the ISO of 2012 Essentials R2 and it came up OK.

    The same ISO for 2012 Standard R2 was used to burn a DVD which created the host that the system is running on.

    I am re-downloading the ISO, but I doubt that is the problem.

    Randy


    MCP SBSC

    Tuesday, February 4, 2014 7:07 PM
  • I am assuming that you have the boot order set properly, and that you have the console of the VM open to quickly (very quickly) respond to the boot from ISO prompt.

    Another option is to produce a VHDX using the very latest version of Convert-WindowsImage as it now includes the UEFI boot support option.

    Using your ISO, you create a VHDX that is essentially ready to go in a sysprep'd state.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, February 4, 2014 7:11 PM
    Moderator
  • Generation 2 is CRAP.  I have been doing virtualization Administrator for 8 years now.  This Hyper-V is the WORST implementation I have EVER seen.

    I have Generation 1 VM.  I have ISO, WIN8.ISO.  I boot from IDE CD.  It boots FINE.  OS installs FINE, nothing wrong with the ISO, my machine or the install of Hyper-V.

    Now I want to test Generation 2.  Doesn't work.  No IDE

    WTF did they remove IDE?!?!?  STUPID.  I have to boot SCSI DVD, totally ridiculous.

    I used the *SAME* ISO that worked on a GEN1, SAME HOST OS, nothing is changed, just using MS crappy Generation 2 VM (which fully supports Windows 8 and windows 2012) and I can't even install the OS.  I get an error, 

    

    What does that even mean? why does this have to be complicated?

    Because someone in their infinite wisdom decided to change something.  MS is dying a slow and painful death, they don't support Linux (integration included with Hyper-v?  No you have to download separately).

    I cannot get Generation 2 to boot a SIMPLE ISO (which confirmed works) ALL because some dimwit at MS thought it would be a good idea.. to change something, we don't know.  But it's NOT working.

    WE use VMware at work, can anyone guess why?  I use VirtualBox at home.. again why?  MS SUCKS that's why.



    • Edited by VMTech Sunday, February 9, 2014 12:53 AM
    Sunday, February 9, 2014 12:47 AM
  • I have the same problem as you.  Hyper-V doesn't recognize ISO with Generation 2, apparently.  I downloaded a genuine ISO from MS site, which as you state also works fine on ANY other virtual host platform.  *ANY*.

    The problem is Generation 2 version, why would simply optimizing a VM disable ISO functionality that's been standing for 25 years.

    Doesn't make ANY sense what-so-ever.

    I can recreate this, Name a Generation 1 VM 1234.  Use the wizard, tell it to boot from ISO it works.

    SAME EXACT Steps used to create a Generation 1, now we name a Generation 2 VM 5678, SAME ISO does NOT work.  What gives??!?!?!?!?

    ONLY difference is going from Generation 1 to Generation 2, it DOES NOT BOOT! Frustrating.


    • Edited by VMTech Sunday, February 9, 2014 1:00 AM
    Sunday, February 9, 2014 1:00 AM
  • Try not to patronize us.. it's not the boot order.  Boot order doesn't matter for initial setup.  If there is no boot sector on the disk it will automatically choose the DVD....

    Some of us are techs.. we know how to set a boot order, the problem is the Hyper-V Generation 2 VM's.

    • Edited by VMTech Sunday, February 9, 2014 1:03 AM
    Sunday, February 9, 2014 1:02 AM
  • you need to place the ISO file on local host drive and make sure the parent folder is NOT shared. that's what I found out.

    it won't work if you link to ISO placed on network OR in any shared folder on local host drive.

    • Proposed as answer by abcdwerty Monday, March 12, 2018 3:44 PM
    Friday, February 14, 2014 7:19 PM
  • I had the exact same issue, in an identical environnement and was able to find the soluton.

    In the VM settings, under firmware section, you must Uncheck Enable Secure Boot. If it is checked, it can't boot on any of the ISO I tried. But as soon as it is unchecked, it works.

    Hope it helps.

    Nicolas

    • Proposed as answer by Scarps25 Monday, December 7, 2015 1:47 PM
    Friday, February 21, 2014 4:26 PM
  • I had the exact same issue, in an identical environnement and was able to find the soluton.

    In the VM settings, under firmware section, you must Uncheck Enable Secure Boot. If it is checked, it can't boot on any of the ISO I tried. But as soon as it is unchecked, it works.

    Hope it helps.

    Nicolas


    that didn't work for me, I tried it as well. no matter if Secure Boot was checked or unchecked I couldn't avoid the error message when trying to boot Gen2 VM from ISO placed either on network share placed remotely or locally.
    • Proposed as answer by Cloudrocket Tuesday, March 18, 2014 1:49 AM
    Friday, February 21, 2014 8:11 PM
  • The ISO must be local to the Hyper-V Server.

    It cannot be through. UNC path or referenced via a share.  It must be on local storage.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Friday, February 21, 2014 8:46 PM
    Moderator
  • The ISO must be local to the Hyper-V Server.

    It cannot be through. UNC path or referenced via a share.  It must be on local storage.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    true, but not enough. for me it worked only AFTER I disabled sharing on parent folder (talking about local hard drive to hyper-v host). so it must be local to host AND mustn't be shared.
    Friday, February 21, 2014 8:57 PM
  • You rock!

    Todd


    Todd Shelton

    Tuesday, March 18, 2014 1:49 AM
  • yep that was it Nicolas, I know it's an older post but +1 from me and thanks for posting the answer.
    Tuesday, October 7, 2014 5:05 PM
  • The ISO must be local to the Hyper-V Server.

    It cannot be through. UNC path or referenced via a share.  It must be on local storage.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    This is correct.

    If in a domain setting then one can set up Constrained Delegation for CIFS (Hyper-V host properties set ISO host CIFS in ADUC).

    I've not had any issues with getting any version of 2012 RTM/R2 or now WinServTP to boot into a Gen2 VM whether on a standalone 2012 R2 host, clustered 2012 R2 host, or on Hyper-V in Windows 8.1.

    Note that the first two ISO downloads, especially from the non-TechNet/MSDN source, were corrupt. Start there.

    The MSDN WinServ version pulled down clean and clear and is now a DC in Hyper-V on Win8.1.


    Philip Elder Microsoft Cluster MVP Blog: http://blog.mpecsinc.ca

    • Proposed as answer by TheBoozer Tuesday, November 18, 2014 5:30 PM
    • Unproposed as answer by TheBoozer Tuesday, November 18, 2014 5:31 PM
    Tuesday, October 7, 2014 5:54 PM
  • Hi,

    I am sorry to open this subject again, but I spent several and many hours on Gen 2 issue. My ISO is on the local Windows 8.1 host and it is not shared and none of the parent folders are shared. Secured boot is ticked off. I am trying to install XP Pro as VM with Hyper 2 Generation, it will NOT boot. With Generation 1, no problem. After reading everywhere, I found a comment indicating that Gen 2 will only work on Windows 8 and above and will not work on Windows 7 or XP. So I tried installing a Windows 8 ISO as VM using Generation 2, and it booted without any problem. Your comments would be appreciated and SHAME on you Microsoft for this stupid blunder!

    Mike 

    Tuesday, November 18, 2014 5:37 PM
  • You are right.  Windows XP does not have the Integration Components (virtual synthetic device drivers) built in.

    Therefore XP won't install.

    Generation 2 is a new type of VM.  It is not simply an enhancement of an old way of running VMs.

    All of the devices are synthetic, zero emulation.  This immediately reduces the operating systems that can be installed on it.

    Generation 2 is not for all VMs and was never intended to be.  It is is baby step in new features and capabilities.

    And I don't blame MSFT at all for doing it.  Generation 1 VMs are not going away any time soon.  And there are now performance differences between Generation 2 and Generation 1.  Except that UEFI boot is simply faster (just like it is on hardware).


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Tuesday, November 18, 2014 9:14 PM
    Moderator
  • THIS WORKED FOR ME.

    Incidentally, I was attempting to boot from a server 2008 R2 ISO due to some legacy apps that require SQL 2005, which won't run on 2012 unfortunately.

    I was using an ISO file which was stored locally on the hyper-v host; IS SHARED on the network (I cannot fathom why THAT would make a difference, but hey, weirder things have been known to happen), and the people saying "Press the button real fast".. well, the "Press any key to boot from CD..." prompt is a good 3 seconds long, and is part of the ISO boot image, not the VM's bios or scsi controller or otherwise. Those people are barking up the wrong tree.

    CAMOHAT

    Tuesday, June 30, 2015 6:35 PM
  • This worked for me!

    Thanks.


    Jorg Gaubmann

    Monday, December 14, 2015 2:51 AM
  • Anyone still having this issue?
    I solved it by adding a second SCSI Adaptor and putting the CD on it
    Thursday, January 21, 2016 10:07 PM
  • Makes sense and this totally worked for me.  Thanks!
    Sunday, January 31, 2016 6:57 AM
  • I know its an old thread but i wanted to share that uncheck the mark secure boot in settings boot order solved this..

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Thursday, May 19, 2016 8:24 AM
  • Hallo,

    its sill not solved! 

    I have a Hyper V Cluster, but for testing purposes i only create VMs at one Node. 

    I have tried everything. 

    - ISO redownloading

    - ISO on the localhost 

    - switching Secure Boot on/off 

    - additional SCSI Controller 

    Hyper V Hosts: 2012 R2 latest Patch Level: End may 2016

    ISO:

    en_windows_server_2012_r2_with_update_x64_dvd_4065220.iso

    de_windows_server_2012_r2_with_update_x64_dvd_4048497.iso 

    Gen 1 works perfectly with both images even if the images are on local disks or CSV oder SMB! 

    Wednesday, June 1, 2016 9:14 PM
  • Just to clear up a potential confusion here, it's NOT under 'Firmware', it's under 'Security' which is right below 'Firmware'.

    Unchecking this secure boot will resolve your problem.

    Monday, August 15, 2016 6:30 AM
  • Just to clear up a potential confusion here, it's NOT under 'Firmware', it's under 'Security' which is right below 'Firmware'.

    Unchecking this secure boot will resolve your problem.

    Sadly: No, not necessarily.

    Besides, there is no "Secure boot" boolean on the Firmware settings ;-)

    I suspect its an UEFI boot issue, but I haven't been able to solve it on my local machine yet. Tried all solutions listed in this thread:
    - Disabling secure boot (makes sense)
    - changing boot order (should be irrelevant with an empty HDD file)
    - creating new SCSI controller with DVD drive

    In addition I also tried removing virtual network adapters, to ensure they do not interfere with the boot process.

    Still doesn't work.

    I work as a BI consultant, so I just don't have time to mess more with this. I'll have to go with a Gen1 VM and get on wit my job. But it's pretty annoying that there are no clear instructions on how to RELIABLY get a normal MS-provided ISO file to do a proper UEFI boot on a Gen2 machine.

    Wednesday, September 14, 2016 1:01 PM
  • You are right.  Windows XP does not have the Integration Components (virtual synthetic device drivers) built in.

    Therefore XP won't install.

    Generation 2 is a new type of VM.  It is not simply an enhancement of an old way of running VMs.

    All of the devices are synthetic, zero emulation.  This immediately reduces the operating systems that can be installed on it.

    Generation 2 is not for all VMs and was never intended to be.  It is is baby step in new features and capabilities.

    And I don't blame MSFT at all for doing it.  Generation 1 VMs are not going away any time soon.  And there are now performance differences between Generation 2 and Generation 1.  Except that UEFI boot is simply faster (just like it is on hardware).


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Does this means that Generation 2 Hyper-V VMs are PVH or HVMLite VMs in the terminology of Xen hypervisor? While previous implementation is comparable to PVHVM?
    Monday, September 26, 2016 12:19 AM
  • No, generation 2 VMs are still HVM (in xen vernacular) they are simply true UEFI.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Monday, September 26, 2016 5:01 PM
    Moderator
  • What the heck?  Started using Gen2 today and I couldn't get the ISO boot at all.  The ONLY thing that got it working was moving the ISO from it's shared folder into the root of the same drive (not shared).  Then it booted.  What kind of nonsense is this?

    Server 2016.
    Thursday, October 13, 2016 6:49 PM
  • For anyone trying on a Windows 10 host

    Check out this article and patch = https://support.microsoft.com/en-us/kb/3172729

    If you are running Windows 10 Version 1607 (Anniversary Edition), the Hyper-V firmware will already have the Windows Server 2016 TP5 boot manager blacklisted.

    For example, when you set up Hyper-V on a Windows 10 Version 1607-based system, if you then create a Windows Server 2016 TP5-based virtual machine (VM), the VM does not start.

    To resolve this issue, follow these steps:

    1. Open the Hyper-V Manager, right-click the VM, and then select Settings.
    2. In the navigation pane, select Security.
    3. In the details pane, select Microsoft UEFI Certificate Authority in the Template list.
    4. In the details pane, click to clear the Enable Secure Boot check box, and then click OK.

      SecBoot

    After you have installed TP5 on the VM and installed security update 3172729, re-enable secure boot. To do this, follow these steps:

    1. Open the Hyper-V Manager, right-click the VM, and then select Settings.
    2. In the navigation pane, select Security.
    3. In the details pane, click to select the Enable Secure Boot check box.
    4. In the details pane, select Microsoft Windows in the Template list, and then click OK.

    Additional articles to review: Should I create a generation 1 or 2 virtual machine in Hyper-V? = https://technet.microsoft.com/windows-server-docs/compute/hyper-v/plan/should-i-create-a-generation-1-or-2-virtual-machine-in-hyper-v 


    Monday, October 31, 2016 4:43 PM
  • I am assuming that you have the boot order set properly, and that you have the console of the VM open to quickly (very quickly) respond to the boot from ISO prompt.

    Another option is to produce a VHDX using the very latest version of Convert-WindowsImage as it now includes the UEFI boot support option.

    Using your ISO, you create a VHDX that is essentially ready to go in a sysprep'd state.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Old thread, but I was pulling my hair out trying to build a Gen2 Windows 10 VM from WSE2016.

    After around 2-3 hours of reading many a technet article, independent websites, plus threads similar to this, I will say that the ISO to VHDX was the only way I was able to have success.

    First things first - kudos to you for this approach, however, let me amplify the approach, since I just finally now have a working VM.

    1. Download the proper ConvertWindowsImage.ps1 file - assuming this is it's home. https://gallery.technet.microsoft.com/scriptcenter/Convert-WindowsImageps1-0fe23a8f
    2. I ran WindowsPowerShell ISE with Administrator privileges
    3. After many a permutation attempt, the successful combo was the following:
    4. (a) ensure the ISO file and the VHDX file you wish to create are in the same path as the .PS1 file
    5. (b) ensure you use the -Edition switch to get the right version
    6. (c) super important - the VHDX file that you are creating is going to be used to both BOOT and will also BECOME your VM file!!!! this was something I was not expecting
    7. (d) ensure you run the Convert-WindowsImage.ps1 ONCE and then when you enter your command line, run it without the .ps1 when you enter your arguments. I know the TechNet link indicates that it had been converted to a function, but anyone else reading MANY posts gets to the point where they are scanning to figure out which step they muffed up, so you might miss this caveat
    8. I learned about 6(c) because I had a brand new Gen2 VM with a new Virtual Disk that I assumed was going to be the destination target for the new OS install didn't get written to at all during the install portion. I had completed installing Win10, detached the convertedISOtoVHDX file and poof! had lost access to a booting OS and knew something was wrong, because Hyper-V was trying to perform a PxEBoot (LOL)

    So some tweaks based on some thinking.

    1-Create VHDX file from ISO as per above

    2-Once complete, create Gen 2 VM with no virtual disk option

    3-Configure newly created VM to boot from your VHDX that you just created (probably have to copy it over to the folder where your VHDs are stored ;) )

    4-Enjoy!

    Now some feedback for Microsoft - I had wanted to wean myself off Vmware Workstation because of all the promise of better integration, SR-IOV potential benefits (running on a Xeon D), and additional management, and the fact that I wanted to run a cleaner WSE2016 box (vs. my WSE2012 R1 box). Let's tie all the different feedbacks and approaches into one comprehensive checklist please, because this took longer than I wanted it to, even though I did learn a ton in the process. (PowerShell newbie)

    Hope this helps others!

    Thanks,

    Alex


    Alex T.

    • Proposed as answer by heykevin007 Wednesday, December 14, 2016 8:07 PM
    • Unproposed as answer by heykevin007 Wednesday, December 14, 2016 8:08 PM
    Sunday, December 4, 2016 1:02 AM
  • I have two local hard disks.  They are mapped as C and F.  The F drive is shared, while the C drive is not.  I moved the ISO image from F:\Temp to C:\Temp and it now works.  Not sure if the drive being shared was the issue, but moving it to a drive that is not did fix the issue.
    Wednesday, December 14, 2016 8:10 PM
  • Hey,

    I recall trying this and I didn't have any luck.

    I had tried the same operation with another freshly downloaded ISO from MSDN and still experienced the same issue. Maybe it's my drive configuration or something else, but it's great that it worked for you.

    Cheers,

    Alex


    Alex T.

    Thursday, December 15, 2016 10:52 AM
  • What kind of an idiot has designed Generation2 boot procedure?!

    IT DOES NOT BOOT from an ISO file, if the file is located within a folder that is being shared! I have not enough words to express all of my anger of wasting more than 2 hours of my life on this stupid bug.


    • Edited by OLAFIDZE Wednesday, March 1, 2017 12:23 PM
    Wednesday, March 1, 2017 12:22 PM
  • I boot from ISO all the time.  If you are trying to boot from a network file share, you need to configure constrained delegation.  It has nothing to do with Generation 1 or 2, but all with the permissions necessary to access the shared resource.

    . : | : . : | : . tim

    Wednesday, March 1, 2017 1:44 PM
  • Same problem here trying to install a Windows 2016 Server on a Gen2 VM. I am running Hyper-V Server 2016, not facing issue on Windows 10 Hyper-V. After starting up VM, screen shows the black screen  "Hyper-V" , then getting error - STOP Code CRITICAL PROCESS DIED... been looking for hours, tried almost everything everyone suggested, nothing working so far...

    I tried: increased the RAM to 2500GB, turned off secure boot, placed iso image at root of C:\ on VM host, on a C:\VM folder, I gave everyone Full control and placed in iso in their but still not work, removed vNIC fro vm guest setting, enabled all Integration Services,enabled NUMA spanning, changed DVD scisi controller from #1 to #2, tried different ISO files, tried from a share.

    If I try using Gen1 VM booting from Physical DVD to exact same ISO, it works no problem...

    I used MagicISO to make my ISO file from TechNet eval downloaded Windows server 2016.



    Saturday, March 25, 2017 8:30 PM
  • Blew through too many hours trying to fix this.... I found a work-around.

    decided to export VMs from my Win10 Hyper-V into my Hyper-V 2016 Server. Despite having a 128GB USB flash drive, the exported VHDX file was 14GB, which was too big and not supported. so I had to transfer the exported VM files over the network.

    For Gen2 on 2016, looks like VHDX is the new ISO...

    Saturday, March 25, 2017 11:43 PM
  • RESOLVED

    Initial procedure : Uncheck Enable Secure Boot form Security in Setting and put ISO

    1. Delete existing SCSI DVD, or create new one if not created;
    2. Wait for the DHCP Negotiation to fail (be patient);
    3. The DVD boot screen will show, press rapidly space bar.

    That is it.




    • Edited by Bhastian Monday, April 24, 2017 8:35 PM
    Monday, April 24, 2017 8:34 PM
  • I turned off secure boot in the boot options when I checked my boot order. Once I changed that started back up and boom it saw the disk.
    Sunday, July 16, 2017 4:49 AM
  • If you use VMM you can use powershell command

    Set-SCVirtualMachine -VM "<VM Machine Name>" –FirstBootDevice "SCSI,0,1"

    the following formats: "SCSI,BusId(integer),LunId(integer)" or "NIC,SlotId(integer)"

    "SCSI,0,1" - is my connected DVD device

    Thursday, October 5, 2017 6:36 PM
  • THIS is the answer!  This worked for me.  Got a Linux ISO to boot in UEFI mode on a Gen 2 VM.
    Thanks mate!!
    Wednesday, October 18, 2017 2:03 PM
  • This worked fine
    Friday, October 27, 2017 4:46 AM
  • I had the exact same issue, in an identical environnement and was able to find the soluton.

    In the VM settings, under firmware section, you must Uncheck Enable Secure Boot. If it is checked, it can't boot on any of the ISO I tried. But as soon as it is unchecked, it works.

    Hope it helps.

    Nicolas

    This worked for me.  I was trying to boot from a CentOS 7 ISO and it wouldn't work until I disabled Secure Boot.  Good Post Nicolas!

    Sam


    • Edited by Cash1945 Saturday, October 28, 2017 4:27 AM
    Saturday, October 28, 2017 4:26 AM
  • ...this is a good tech story that sums up a bunch of issues one can run into.  It's light on the detailed "How to", but great on identifying the issues and solutions.  http://wiki.terrabase.info/index.php/Convert-WindowsImage.ps1

    Thursday, January 25, 2018 6:41 PM
  • Settings>security>Enable Secure Boot , uncheck.
    Thursday, March 28, 2019 1:40 PM
  • Yup, this worked for me too...Hope this works for everybody else as well
    Tuesday, April 30, 2019 5:57 AM
  • For me it was the adding the CD as a separate SCSI controller and also going under firmware and setting the boot order with the CD first.
    Wednesday, July 17, 2019 6:24 PM
  • We re-create the Hyper-V Gen 2 using the "Microsoft Windows" template instead of the "Microsoft UEFI Certificate Authority" for Secure boot and it works without unchecking "Enable Secure Boot"

    
    Thursday, August 1, 2019 8:28 AM
  • I have the same issue as everyone here. But i have no lucky. 
    Hyper-V doesn't recognize ISO with Generation 2.  I downloaded a genuine Windows 2019 Server ISO from MS site that works fine on VMware virtual host platform. 
    With generation 1 everything goes good, but with generation 2 no matter what i do its impossible to boot.
    Of course i unchecked secure boot...
    Changed boot order with many SCSI variations.

    Curiosity:
    Windows 10 host can boot a GEN2 .ISO of Windows 10, but cannot boot a Windows Server .ISO?

    I also tryed https://support.microsoft.com/en-us/kb/3172729 
    =(
    Sunday, September 8, 2019 7:26 AM
  • You posted to an entry that was marked as answered six years ago.  If you are having a similar issue, you should open a question post with a full explanation of the steps you went through.

    tim

    Monday, September 9, 2019 1:34 PM
  • Why does your non answer link back to this same thread??
    Thursday, September 12, 2019 5:29 PM