locked
Windows 8 installation has failed

    Question

  • Hi, when my win8 installation hits 100% it goes on to say it will restart in a few moments, but then a window with the message "windows 8 installation has failed" shows up, anybody else have a similar problem? 
    Tuesday, June 05, 2012 8:36 AM

Answers

  • When the issue occurs, press SHIFT+F10 to topen CMD, and next copy the folder C:\Windows\Panther to an external drive, zip it and upload it.

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, June 06, 2012 8:42 AM
    Answerer

All replies

  • Are you using Windows Installer or you use USB/DVD to boot for install Windows 8.

    What is the model and manufacturer of your PC?

    Tuesday, June 05, 2012 12:17 PM
  • I built it myself a couple a years ago. I had the consumer preview installed on it a couple months ago, and this was never a problem. I have now win7 32bit pro. 

    I tried everythin(installer,usb,dvd), except for booting it from start in the boot menu. i also tried unplugging all of my usb devices. 

    Tuesday, June 05, 2012 12:54 PM
  • When the issue occurs, press SHIFT+F10 to topen CMD, and next copy the folder C:\Windows\Panther to an external drive, zip it and upload it.

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, June 06, 2012 8:42 AM
    Answerer
  • I had this issue. MS said to install using media (no-saving my programs or settings). Not super helpful, but when I tried the media (fresh) install, it also would not work. This time the error was more detailed. It had to do with my primary drives formatting of MSR vs GPT and my UEFI bios. I had the wrong format to go with UEFI. I deleted the partition, created a new one, and everything went fine.

    Bottom line, if you have a UEFI bios, you might not be able to do a in-line upgrade from Win 7 depending on your partition type.

    Just my experience here.

    • Proposed as answer by bxwatso Friday, October 26, 2012 9:37 PM
    Friday, October 26, 2012 9:37 PM
  • Seems to have various causes.  It took me four tries to finally install it.  The last time I removed an extraneous account, closed down all the little updaters and device drivers that were running, shut off all of my security (Webroot), and restarted the install by right clicking and selecting run as administrator.  I'm not sure what in those actions fixed it, but it's in and working perfectly on my Toshiba laptop. 64 bit installation.  I have to admit that I was disgusted that something like this made it to market.  I've installed everything Microsoft since Dos 2.0 and never had this kind of problem.  This was the slowest most frustrating install of anything in the MS line. A simple sign that this thing was rushed out too soon.  I hate to know what else is wrong with it.  I really thought that they had learned something from ME and Vista but apparently not.  So far it has been no problem to use.  You just have to think of the start page as a gigantic start menu (that's why you don't need a start button, the start menu is already open) The Win key gets a lot of use and search is the easiest way to find functions.  I already had my main programs pinned to the taskbar and seldom found in use for the start button or menu anyway.  I'm fine with the interface.  Just disgusted with an installation that took all day and for which there seemed to be no help.  I wish I could tell you what finally fixed it.  I found all of the ideas on the internet except cut off the antivirus and run it as administrator. Those were my own ideas.
    Saturday, October 27, 2012 4:32 AM
  • Hi, I have the same problem as Andre Verheugen and still no solutions until now :(
    Friday, November 02, 2012 2:45 AM
  • I knew it may be your memory(ram) problem. try to check your ram. it mostly happens when you have two banks of memory installed on your computer and one of them doesn't function correctly. Its worth give it a try^_^ my friend
    Saturday, November 03, 2012 11:03 AM

  • After a numerous search for all these  installation issues , i was finally able to find a solution to upgrade my OS from windows 7 home premium to windows8 pro.
    since i'm seeing lot many people struggling to find a solution, i created a microsoft account and posting the solution here  :)
    following were some of the errors set up has thrown while installation.

    1. when i tried to install from USB,suddenly a messsage popped up saying "Something has happened".
    2. when tried to install through the desktop shortcut after the installation has become 100% and before the first reboot a really disappointing message "Windows 8 installation has failed" is appeared.
    3. And sometime while trying to install fro DVD or USB message 'STARTUP FOLDER NOT INITIALIZED' appeared.

    Following were the few errors  that logged( in the path C:\$WINDOWS.~BT\Sources\Panther\setuperr.log) during installation.

    1. Error CONX ConX::Compatibility::CSystemAbstraction::
    GetDiskFreeSpaceW: Failed to retrieve disk space info for G.[gle=0x00000015]
    2. CONX   ConX::Setup::Media::CWorkerProc::SetupThreadProc: An error occurred while servicing the boot files from [C:\$WINDOWS.~BT\Windows\BOOT]; status = [0x8007007B][gle=0x0000007b

    Now the solution part...

    Solution is so simple.
    1.Go to the disk management in windows 7.(right clickon my computer -> manage-> disk management.)
    2.there will be a drive called "system reserved" to which there won't be any drive letter assigned.
    3. Assign a drive letter for that drive.

    that's it.... .

    Now all the above mentioned errors will go off, and setup will work as expected...  But I'm really surprised why microsoft was able to identify a system reserved drive they configured for windows 7 installation.

    Anyway i hope that above mentioned solution may solve the problem for many. If found useful, please share it in all forums you are registered to.
    Saturday, December 08, 2012 8:30 AM