none
Start Menu and Taskbar Polices not working after last weeks Microsoft Security Patches Applied

    Question

  • So we lock down our 2008 R2 Terminal servers for users in our company.  We lock down the Start Menu and Taskbar via group policies. Basically, when they click start all they see is Devices and Printers and Windows Security.  This has been working fine until we applied the latest patches to our server on Friday.  Now when the users login, they are seeing the "All Programs" and "Run..." menu.  I checked our group policy and the (2) policies that control these are set to "Enabled"

    1.  "Remove Run menu from Start Menu"

    2.  "Remove All Programs list from Start Menu"

    We also remove the Server Manger icon for our users and that appears to be showing up again on another set of Terminal servers.  This has happened in the past with Microsoft Security Updates. 

    I know these changes can be made via the registry, I just want to know why these options quit working. 


    ......Update..... After running gpresult /r, I'm not seeing that group policy being applied which is very scary.  It was working fine before the updates.  Any ideas on what I should do?  Other group policies are being applied just fine. 
    • Edited by PPIbrad Monday, June 20, 2016 1:27 PM
    Monday, June 20, 2016 1:06 PM

Answers

  • And you can use the following powershell script to fix the broken GPOs:

    Set-GPPermission -all -TargetName "Authenticated Users" -TargetType User -PermissionLevel GpoRead


    If my answer helped you, check out my blog: Deploy Happiness

    • Marked as answer by PPIbrad Monday, June 20, 2016 2:31 PM
    Monday, June 20, 2016 2:00 PM

All replies

  • Turns out this is the issue. 

    https://social.technet.microsoft.com/Forums/en-US/e2ebead9-b30d-4789-a151-5c7783dbbe34/patch-tuesday-kb3159398?forum=winserverGP

    Monday, June 20, 2016 1:57 PM
  • And you can use the following powershell script to fix the broken GPOs:

    Set-GPPermission -all -TargetName "Authenticated Users" -TargetType User -PermissionLevel GpoRead


    If my answer helped you, check out my blog: Deploy Happiness

    • Marked as answer by PPIbrad Monday, June 20, 2016 2:31 PM
    Monday, June 20, 2016 2:00 PM