none
Workflow publishing error in SharePoint Designer 2013 for Project Server 2013 On-Premises Environment. RRS feed

  • Question

  • Hi,

    I am creating a workflow in SharePoint Designer 2013 for Project Server 2013 On-Premises Environment.

    It is showing an error while publishing. The following error is showing:

    "Errors were found when compiling the Workflow. The Workflow files were saved but cannot be run."

    "System.InvalidOperationException: Operation failed with error Microsoft.Workflow.Client.WorkflowEndpointNotFoundException: Unable to connect to the remote service at "URL". See InnerException for more details. Client ActivityId : "Id" System.Net.WebException: Unable to connect to the remote server System.Net.Sockets.SocketException: No connection could be made because the target machine."

    For fixing that error I used the following command to Re-register services:

    Register-SPWorkflowService -SPSite 'https://my-host/mysite' -WorkflowHostUri 'https://workflowhost' -AllowOAuthHttp -Force

    Now the same error showing in SharePoint 2013 Management Shell:

    Unable to connect to the remote service at "URL".

    Workflow Publish Error

    Thanks and Regards,

    Friday, July 19, 2013 2:10 PM

All replies

  • Do you see exception errors in Event log from App Management service?


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Friday, July 19, 2013 4:55 PM
    Moderator
  • Probabilty your URL is wrong. Check if you are using SLL protocol, if you are not using, use HTTP only, and not HTTPS.

    Your URL should look something like this "http://workflowhost:12291"

    Good Luck,
    Vinicius Chaves

    Friday, August 9, 2013 4:42 PM