locked
What does it take for a Win64 driver to work in Vista? RRS feed

  • Question

  • I'd like to see if I can get my TV card working in Vista RC1 x86-64.

    There's an XP-64 driver (beta) available at http://supportuk.terratec.net/modules.php?op=modload&name=Downloads&file=index&req=viewsdownload&sid=436 .

    However, if I try to use it in Vista, though it installs OK it doesn't load.  If I look at the properties for the device, it suggests that the driver hasn't been signed (which would explain why it won't load, as of course driver signing is by default required).

    What's not clear to me is exactly why it won't load.  There is a catalog with the driver set (so someone has certainly *tried* to sign the drivers), but it seems that it doesn't match up with the drivers themselves.

    Is there any way to find out what the exact issue is?

    Friday, October 6, 2006 11:44 PM

All replies

  • Hi,

    reading some of the info about Vista it states that the 64-bit version has to have signed drivers although there is a setting to turn it off when booting.

     

    Easiest way is to download VistaBootPRO_3.1.0.exe and when you goto the Advanced Settings you can

    "Allow use of unsigned drivers (x64 only)"...i think its a boot setting, so once changed you need to reboot your machine.

     

    You can download it from...www.start64.com here...

    http://www.start64.com/index.php?option=com_content&task=view&id=199&Itemid=73

    regards,

    Tohmmm

    Sunday, October 8, 2006 6:19 PM
  • That isn't what I want to do at all.  I know vista 64 requires signed drivers, and I know how to disable that requirement.  But I don't want to.  I want to know why the signatures for this driver set are being ignored, with a view to fixing them (or having Terratec fix them) so that they work properly.

     

    Monday, October 9, 2006 1:02 PM
  •  

    Hi,

    I tryed this VistaBoot with Vista x64 RTM Enterprise and while the Adanced Settings show an

    option to Ignore  Unsigned Drivers, --> It doesn't appear to work.

     

    I still have to  press F8 menu to select the  ignore  function.

     

    Thursday, March 27, 2008 4:55 PM