locked
Form Based Authentication on Proclarity Dashboard RRS feed

  • Question

  • Hi Gurus,

    I am configuring Proclarity dashboard for Microsoft GPG to publish GPG sadhboards. I am having an issue with Proclarity dashboard server to configure it for Form Based authentication.

    I followed these Steps,

     

     

    Deployment Scenario 1
    ProClarity Dashboard Server: Forms-based authentication
    PAS: Basic authentication

    Steps

    1. Configure IIS on ProClarity Dashboard Server with SSL.

    2. Configure Forms-based authentication on ProClarity Dashboard Server.

    3. Configure Basic authentication on PAS.

    Forms/Basic deployment step 1
    Configure IIS on ProClarity Dashboard Server with SSL

    Notes

    • This procedure establishes HTTPS connectivity. It you use HTTP connectivity, user names and passwords are sent in clear text.

    • To configure IIS to use SSL, you must first acquire a security certificate.

     

    1. In IIS Manager, right-click the dashboard virtual directory and select Properties.

    2. Click the Directory Security tab, and under Communications (or Secure Communications), click Edit.

    3. In the Secure Communications window, select the Require secure channel (SSL) check box.

    part of the Secure Communications window

    Forms/Basic deployment step 2
    Configure Forms-based authentication on ProClarity Dashboard Server

    To configure Forms-based authentication, do both of the following:

    Configure IIS for Anonymous access

    1. In IIS Manager, right-click the ProClarity Dashboard virtual directory and select Properties.

    2. On the Directory Security tab under Anonymous access and authentication control (or Authentication and access control), click Edit.

    3. On the Authentication Methods dialog box, select the Anonymous access check box. If desired, also select Allow IIS to control password.
      Important:
      Ensure that all other check boxes on the dialog box are cleared.

    Authentication Methods dialog box

    Configure web.config for Forms-based authentication

    Note Forms-based authentication is the default configuration in web.config.

    1. Open the ProClarity Dashboard Server web.config file. The default directory is C:\Program Files\ProClarity\ProClarity Dashboard Server.

    2. Locate the following:

    <!-- To enable forms based authentication enable this block of xml. Requires enabling anonymous authentication on the virtual directory. -->

    1. Remove commenting to enable the following block:

    <authentication mode="Forms">

    <forms loginUrl="Login.aspx" protection="All" timeout="5" name="DBAuthCookie" path="/" requireSSL="false" slidingExpiration="false" defaultUrl="default.aspx" cookieless="UseCookies" enableCrossAppRedirects="true"/>

    </authentication>

    <authorization>

    <deny users="?"/>

    <allow users="*"/>

    </authorization>

    1. Locate the following:

    <!-- To enable windows authentication enable this block of xml. Requires enabling integrated authentication on the virtual directory. -->

    1. Insert commenting to disable the following block:

    <authentication mode="Windows"></authentication>

    <identity impersonate="true"/>

    1. Save the changes to web.config.

    Forms/Basic deployment step 3
    Configure Basic authentication on PAS

    1. In IIS Manager, right-click the PAS virtual directory and select Properties.

    2. On the Directory Security tab under Anonymous access and authentication control (or Authentication and access control), click Edit.

    3. On the Authentication Methods dialog box, select the Basic authentication check box. Ensure that all other check boxes on the dialog box are cleared.

    Authentication Methods dialog box

    But Still it did not worked for me. I can login to dashboard server but cannot see any proclaritu view.

     

    Thanks,

    Ashish Tambe

    Thursday, April 14, 2011 9:49 AM