locked
Unable to book meeting rooms from trusted forest, rooms are tentative RRS feed

  • Question

  • My organisation has 2 forests that have a two-way external trust between them.  An exchange federated trust has also been setup between the two businesses.  We use GalSync to sync contacts and our GAL.

    In most cases operations within Exchange/outlook seem to work well.  Users in forest 1 can view Free/busy information from forest 2 and vice-versa.

    When a user from one forest tries to book a meeting room in the other forest the meeting room stays as tentative and they do not receive confirmation email.

    I have the rooms set to AutoAccept replies:

    Set-CalendarProcessing " Room 1" -AutomateProcessing AutoAccept

    Questions:

    1) Is this caused by having an 'External' domain forest trust?  Would this be resolved by making the trust an Internal one?

    2) Is there a way this can work without changing the domain trusts?  As this might take a while for the other business to put in place.

    Please help?

    Kind Regards

    Fooksey

    Thursday, October 9, 2014 12:21 PM

Answers

  • Thanks for you replies Winnie and Mark.  A little further digging and it looks like an amendment of out trust to be Internal should resolve this.  I reckon Mark's suggestion of the "Externally Secured" Send connector will resolve this too.

    Kind regards

    Fooksey


    Hi,
    Changing the trust type will NOT make it work for you. The meeting request would still be sent from a different exchange org (=external message).

    A Receive Connector configured with the authentication method "Externally Secured" will do the trick.

    PS. Who is Mark :)


    Martina Miskovic


    • Edited by Martina_Miskovic Thursday, October 16, 2014 4:25 AM
    • Marked as answer by Fooksey Monday, October 20, 2014 11:51 AM
    Thursday, October 16, 2014 4:25 AM

All replies

  • Hi Fooksey,

    Please confirm if the issue happens to all external users between two forests. What's the Exchange version used in two forest respectively? Please check whether the internal users can receive the confirmation mail properly.

    Please make sure the ProcessExternalMeetingMessages parameter is set to True for the resource mailbox:

    Set-CalendarProcessing "Room 1" -ProcessExternalMeetingMessages $true

    Regards,


    Winnie Liang
    TechNet Community Support

    Friday, October 10, 2014 9:06 AM
  • Winnie,

    Thanks for your reply.  This is an issue for all external users in both forests.  Both organisations have Exchange 2010 SP 3.  Forest 1 has rollup 6 and forest 2 is on the latest rollup.

    The ProcessExternalMeetingMessages is also set on all rooms.  However the tests are still negative.  Rooms stay tentative and the meeting organiser doesn't receive a email confirmation.

    Kind Regards
    Fooksey

    Monday, October 13, 2014 7:40 AM
  • Hi Fooksey,

    How about sending the meeting request to this room by the internal domain users? Can they receive the confirmation message?

    Also confirm if the issue happens to all rooms. Genarally, Exchange need to look up the GAL and need to see the email address present in AD and send the response message. Please make sure the external users can be resolved in your local Exchange GAL.

    Regards,


    Winnie Liang
    TechNet Community Support

    Tuesday, October 14, 2014 11:11 AM
  • Exchange 2010 does not process meeting requests sent by an unauthenticated connection. It doesn't matter if Mailcontacts for them has been created or not.
    You can get it to work if you create a Receive Connector configured with the authentication method "Externally Secured" for the sending server.


    Martina Miskovic

    Tuesday, October 14, 2014 11:20 AM
  • Thanks for you replies Winnie and Mark.  A little further digging and it looks like an amendment of out trust to be Internal should resolve this.  I reckon Mark's suggestion of the "Externally Secured" Send connector will resolve this too.

    Kind regards

    Fooksey

    Wednesday, October 15, 2014 8:59 AM
  • Thanks for you replies Winnie and Mark.  A little further digging and it looks like an amendment of out trust to be Internal should resolve this.  I reckon Mark's suggestion of the "Externally Secured" Send connector will resolve this too.

    Kind regards

    Fooksey


    Hi,
    Changing the trust type will NOT make it work for you. The meeting request would still be sent from a different exchange org (=external message).

    A Receive Connector configured with the authentication method "Externally Secured" will do the trick.

    PS. Who is Mark :)


    Martina Miskovic


    • Edited by Martina_Miskovic Thursday, October 16, 2014 4:25 AM
    • Marked as answer by Fooksey Monday, October 20, 2014 11:51 AM
    Thursday, October 16, 2014 4:25 AM
  • Martina,

    Apologies not sure where I got Mark from.  Thank you for you clarification.  I will try the receive connector.

    Kind Regards

    Fooksey

    Monday, October 20, 2014 11:50 AM