locked
How to sequence and packaging application for RDS (Remote Desktop Service) RRS feed

  • Question

  • Can anyone point me to a step-by-step document to sequence and packaging application to publish on Windows 2008 R2 Remote Desktop Service? Thanks.
    Tuesday, June 29, 2010 8:23 PM

Answers

All replies

    • Proposed as answer by znack Tuesday, June 29, 2010 9:18 PM
    Tuesday, June 29, 2010 8:43 PM
  • Thanks, Znack. These docs are very helpful.
    Tuesday, June 29, 2010 8:59 PM
  • Znack,

    I followed the instruction on RDS whitepaper on page 33 running the command sfttray.exe /exe cmd.exe /launch "Adobe Acrobat 9 Pro 9.0.0.332" and it failed with error message "The Application Virtualization Client could not launch the application you requested.....Error code: 4604EE8-0B211004-00000A09. I tired both on Application Virtualization Manager Server and on RDS server where I have App-V Client for RDS installed. Did I miss something? Thanks.

    Wednesday, June 30, 2010 4:14 PM
  • I ran the command on my workstation, it did behave as said on page 33, that is "Once the command prompt is open, copy the EXE or DLL for the application that has embedded icons in it..." Where can I locate such EXE or DLL files mentioned there? Anyone did this before? Thanks.
    Wednesday, June 30, 2010 4:33 PM
  • Is the application published to the RDS box? Run SFTMIME QUERY OBJ:APP /SHORT to see the list of applications.
    Wednesday, June 30, 2010 5:06 PM
    Moderator
  • The RDS white paper has 24 pages. Which document are you talking about?
    Wednesday, June 30, 2010 5:08 PM
    Moderator
  • Aaron,

    The RDS white page here http://blogs.technet.com/b/appv/archive/2010/05/27/the-app-v-4-6-for-rds-whitepaper-is-now-available.aspx has more than 33 pages.

    I ran SFTMIME QUERY OBJ:APP /SHORT  and it came back with nothing. I already have App-V server and deploy app-v to end users. Now, we bring up a RDS server and I want RDS server to publish existing app-v. I installed AppV Client for RDS on RDS server but it did not list any application! yes, it talked to App-V server. Maybe I don't know how to publish App-V! I followed the instruction on page 33 but the command did not come back with any result! I don't know where to copy EXE or DLL for the application as said on that page. Any idea? thanks.

    Thursday, July 1, 2010 2:25 PM
  • I first would try to publish a whole RDS Desktop (with the app-V apps on in), and if that works, proceed with the RemoteApp Feature to (RDS) publish individual applications.

     

    In that "Full Desktop" scenario, you initially don't need the application's EXE or DLLs.

    I suppose you have

    1. an App-V Management Server up and running,
    2. "imported" some applications there
    3. and the App-V Management Server service is running on that machine.

    When you open the App-V Client management Console on the RDS server, you should see the App-V Management Server configured as a "Publishing Server". You can select the server in the details pane, right-click and "Refresh". Does this work without any error, do you see any apps in the "Applications" node of that MMC?

    If you don't get any applications: can you post the last (let's say) 25 lines of the "sftlog.txt" file located on the RDS server?

     


    Falko
    Monday, July 5, 2010 1:22 PM
    Moderator
  • All,

    I re-pack an application and select Windows 2008 R2 Terminal Server in "Deployment" section and the application showing up in my RDS server. My next question is how do I add another support operating system to my current application package? Say, I have Office Word 2007 virtual app and I only selected Windows XP and Windows 7 when packaging the application. Now, how do I add Windows 2008 R2 Terminal Server without repackaging the application? Thanks.

    Tuesday, July 6, 2010 7:46 PM
  • Tuesday, July 6, 2010 7:57 PM
  • Wednesday, July 7, 2010 12:50 AM