none
500.19 error on page with Error code 0x80070021

    Question

  • Getting the following error

    Module IIS Web Core

    Notification BeginRequest

    Handler Not yet determined

    Error Code 0x80070021

    Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false". 

    Config File \\?\C:\Program Files\Windows Small Business Server\Bin\WebApp\SBS Web Applications\web.config

    Requested URL http://sites:80/

    Physical Path C:\Program Files\Windows Small Business Server\Bin\WebApp\SBS Web Applications

    Logon Method Not yet determined

    Logon User Not yet determined

    config source

    17: <system.webServer>

    18: <modules>

    19: <add name="HttptoHttpsRedir" type="Microsoft.WindowsServerSolutions.IWorker.IIS.Modules.HttpToHttpsRedir,HttpToHttpsRedir,Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

     

    My web.Config file is

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>

      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="IISConfigLib" publicKeyToken="31bf3856ad364e35" culture="neutral"/>
            <codeBase version="6.0.0.0" href="file:///C:\Program Files\Windows Small Business Server\Bin\IISConfigLib.dll"/>
          </dependentAssembly>
          <dependentAssembly>
            <assemblyIdentity name="WSSG.Support" publicKeyToken="31bf3856ad364e35" culture="neutral"/>
            <codeBase version="6.0.0.0" href="file:///C:\Program Files\Windows Small Business Server\Bin\WSSG.Support.dll"/>
          </dependentAssembly>
        </assemblyBinding>
      </runtime>

      <system.webServer>
        <modules>
          <add name="HttptoHttpsRedir" type="Microsoft.WindowsServerSolutions.IWorker.IIS.Modules.HttpToHttpsRedir,HttpToHttpsRedir,Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </modules>
      </system.webServer>
    </configuration>

     

    Can anyone tell me what is wrong with the Module section.

    Everything I read talks about unlocking the element or section.  windowsAuthentication enabled="true"

    What would I add and where would I add the appropriate code to this config.

     

    Help Much appreciated

     

    regards

     

    James

     

     

     

     

     

     


    Sunday, July 03, 2011 2:28 PM

Answers

  • Hi James, have you checked the following KB article regarding the error?

    Error message when you visit a Web site that is hosted on IIS 7.0: "HTTP Error 500.19 – Internal Server Error"
    http://support.microsoft.com/kb/942055/

    You can also try the following solution to register .NET Framework and see if that resolves the issue:

    Run cmd As Administrator 

    cd C:\Windows\Microsoft.NET\Framework64\v4.0.30319
    aspnet_regiis -i

    Since this issue can be related to IIS, you can post it to IIS forum:

    http://forums.iis.net/

     

    Hope this helps!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 06, 2011 8:45 AM
    Moderator

All replies

  • Hi James:

    Might be helpful if you said what version of what program gave that error under what circumstances.  Hard to tell from here.


    Larry Struckmeyer

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sunday, July 03, 2011 3:15 PM
    Moderator
  •  

    Sorry Larry,

    That is a obvious over site on my part

    It is happens on an SBS2008 server..

    This error occures when trying to view any of the internal web pages.

     

    Also here is the applicationHost.config file

    https://skydrive.live.com/?cid=5f9a443250c86ee4&sc=documents&uc=1&id=5F9A443250C86EE4%21108#

    I hope this helps

    Regards

    James


    Monday, July 04, 2011 1:04 AM
  • Hi James, have you checked the following KB article regarding the error?

    Error message when you visit a Web site that is hosted on IIS 7.0: "HTTP Error 500.19 – Internal Server Error"
    http://support.microsoft.com/kb/942055/

    You can also try the following solution to register .NET Framework and see if that resolves the issue:

    Run cmd As Administrator 

    cd C:\Windows\Microsoft.NET\Framework64\v4.0.30319
    aspnet_regiis -i

    Since this issue can be related to IIS, you can post it to IIS forum:

    http://forums.iis.net/

     

    Hope this helps!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 06, 2011 8:45 AM
    Moderator
  • Not help at all dude!!!
    Wednesday, October 02, 2013 2:57 PM