locked
Sharepoint Search Error when trying to start RRS feed

  • Question

  • For some reason the search option on my Sharepoint Service 3.0 site was not working. So after doing some research I went into the SharePoint Central Administration/Operations/Services on server/Windows SharePoint Services search.  I stopped this service, and then when I try to start it again I receive this error.

    Some or all identity references could not be translated.   at Microsoft.SharePoint.Search.Internal.UI.SPSearchServiceInstanceSettings.BtnSubmit_Click(Object sender, EventArgs args)
       at System.Web.UI.WebControls.Button.OnClick(EventArgs e)
       at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    I have tried to run the stsadm –o updatefarmcredentials –userlogin <domain\name> -password <newpassword> and then waited for the timer to stop and then ran the iisreset /noforce.  after attempting to restart the search service again I still receive the same error. 

    After having no luck with that I then attempted to start the service using the stsadmin utility.  Using the following command. stsadm -o spsearch -action start After I ran this i receive the following error.

     'start' action failed. Additional information: Some or all identity references could not be translated.

    I have tried to set the identities for all of the settings both through the stsadm and also through the Central Administration options. 

    In the middle of all of this I found a few other option to check out the 'Component Services' where I set it to allow remote connections. 

    I am also receiving the following errors in my Application Even viewer.

    1.
    Event Type: Error
    Event Source: Windows SharePoint Services 3 Search
    Event Category: Gatherer
    Event ID: 2406
    Date:  3/12/2009
    Time:  2:36:18 PM
    User:  N/A
    Description:
    Performance monitoring cannot be initialized for the gatherer service, because the counters are not loaded or the shared memory object cannot be opened. This only affects availability of the perfmon counters. Restart the computer.

    2.
    Event Type: Error
    Event Source: Windows SharePoint Services 3 Search
    Event Category: Plug-in
    Event ID: 9501
    Date:  3/12/2009
    Time:  2:36:18 PM
    User:  N/A
    Description:
    Performance monitoring for the plug-in cannot be initialized, because the counters are not loaded or the shared memory object cannot be opened. This only affects availability of the perfmon counters. Restart your computer to fix this problem.

    3.
    Event Type: Error
    Event Source: Windows SharePoint Services 3 Search
    Event Category: Plug-in
    Event ID: 9501
    Date:  3/12/2009
    Time:  2:36:18 PM
    User:  N/A
    Description:
    Performance monitoring for the plug-in cannot be initialized, because the counters are not loaded or the shared memory object cannot be opened. This only affects availability of the perfmon counters. Restart your computer to fix this problem.

    4.
    Event Type: Error
    Event Source: VSS
    Event Category: None
    Event ID: 8193
    Date:  3/12/2009
    Time:  2:46:02 PM
    User:  N/A
    Description:
    Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x800401f0.

    5.
    Event Type: Error
    Event Source: VSS
    Event Category: None
    Event ID: 11
    Date:  3/12/2009
    Time:  2:46:02 PM
    User:  N/A
    Description:
    Volume Shadow Copy Service information: The COM Server with CLSID {4e14fba2-2e22-11d1-9964-00c04fbbb345} and name CEventSystem cannot be started. [0x800401f0]

    After looking around the internet for errors 4&5 I found a solution to re-run the SharePoint Configuration Wizard.  While running this it came up with an error:

    An exception of type System.Security.Principal.IdentityNotMappedException was thrown.  Additional exception information: Some or all identity referenced could not be translated.

    When I look in the Log file this is what is shown:

    An exception of type System.Security.Principal.IdentityNotMappedException was thrown.  Additional exception information: Some or all identity references could not be translated.
    System.Security.Principal.IdentityNotMappedException: Some or all identity references could not be translated.
       at System.Security.Principal.NTAccount.Translate(IdentityReferenceCollection sourceAccounts, Type targetType, Boolean forceSuccess)
       at System.Security.Principal.NTAccount.Translate(Type targetType)
       at System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
       at System.Security.AccessControl.CommonObjectSecurity.AddAccessRule(AccessRule rule)
       at System.Security.AccessControl.RegistrySecurity.AddAccessRule(RegistryAccessRule rule)
       at Microsoft.SharePoint.PostSetupConfiguration.ResourceAccess.SetRegistryAccessRule()
       at Microsoft.SharePoint.PostSetupConfiguration.ResourceAccess.Secure()
       at Microsoft.SharePoint.PostSetupConfiguration.SecurityTask.SecureResources()
       at Microsoft.SharePoint.PostSetupConfiguration.SecurityTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    I have come across the command "PSCONFIG -CMD UPGRADE -INPLACE B2B -FORCE -WAIT" but honestly I am concerned that running this command will cause other problems on the other parts of the site that are working correctly.   

    I am able to start the "Windows SharePoint Services Search" in the Computer Manager and it appears to start correctly. Once I just started it, and looked in the 'Applications' Event Viewer, just now received two new Error Messages.

    1.
    Event Type: Error
    Event Source: SharePoint Products and Technologies Configuration Wizard
    Event Category: None
    Event ID: 104
    Date:  3/12/2009
    Time:  3:18:02 PM
    User:  N/A
    Computer: WEB
    Description:
    Failed to secure the SharePoint resources.
    An exception of type System.Security.Principal.IdentityNotMappedException was thrown.  Additional exception information: Some or all identity references could not be translated.
    System.Security.Principal.IdentityNotMappedException: Some or all identity references could not be translated.
       at System.Security.Principal.NTAccount.Translate(IdentityReferenceCollection sourceAccounts, Type targetType, Boolean forceSuccess)
       at System.Security.Principal.NTAccount.Translate(Type targetType)
       at System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
       at System.Security.AccessControl.CommonObjectSecurity.AddAccessRule(AccessRule rule)
       at System.Security.AccessControl.RegistrySecurity.AddAccessRule(RegistryAccessRule rule)
       at Microsoft.SharePoint.PostSetupConfiguration.ResourceAccess.SetRegistryAccessRule()
       at Microsoft.SharePoint.PostSetupConfiguration.ResourceAccess.Secure()
       at Microsoft.SharePoint.PostSetupConfiguration.SecurityTask.SecureResources()
       at Microsoft.SharePoint.PostSetupConfiguration.SecurityTask.Run()
       at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

    2.
    Event Type: Error
    Event Source: SharePoint Products and Technologies Configuration Wizard
    Event Category: None
    Event ID: 100
    Date:  3/12/2009
    Time:  3:18:03 PM
    User:  N/A
    Computer: WEB
    Description:
    Configuration of SharePoint Products and Technologies failed.  Configuration must be performed in order for this product to operate properly.  To diagnose the problem, review the extended error information located at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS\PSCDiagnostics_3_12_2009_15_17_18_689_1409887669.log, fix the problem, and run this configuration wizard again.


    Any help with this would be much appreciated.

    Thank you.


    John
    Thursday, March 12, 2009 8:35 PM

All replies

  • I have no solution but am getting the exact same problem and went through similar steps before reading your post.

    Microsoft?  Help on this please.
    Monday, March 30, 2009 10:38 AM
  •  Hi,

     To fix it you need to run following command:

      stsadm.exe -o updatefarmcredentials -userlogin <domain\user> -password <password>



     Regards,
     Sunil
    • Edited by Mike Walsh FIN Tuesday, March 31, 2009 7:37 AM If you like my post mark it as ANSWER. removed
    • Proposed as answer by Kiran T Tuesday, January 12, 2010 10:41 AM
    Monday, March 30, 2009 12:06 PM