locked
MAPI over HTTP connection test issue RRS feed

  • Question

  • Hi all

    I'm a total newbie to this all.

    Basically I've run the remote connectivity tester "outlook connectivity" and it's failing at the last section on MAPI over HTTP.

    This is the error that i'm getting:

     


    Testing HTTP Authentication Methods for URL https://mail.exchangesrver.me/mapi/emsmdb/?MailboxId=b7218b28-c482-44b9-9ca2-7496fae1ce11@xxxxxxxx.com.
      The HTTP authentication test failed.
      Tell me more about this issue and how to resolve it
     
    Additional Details
     
    A 401 error was received from the server, but no authentication methods are supported.
    HTTP Response Headers:
    request-id: 9cbf8909-cad3-4659-97d4-77f2fd169850
    X-FEServer: EXCHANGESERVER
    Content-Length: 0
    Date: Mon, 07 Nov 2016 18:32:15 GMT
    Server: Microsoft-IIS/10.0
    X-Powered-By: ASP.NET
    Elapsed Time: 67 ms.

    I've tried on the server to run:

    Test-OutlookConnectivity -RunFromServerId exchangeserver -ProbeIdentity OutlookMapiHttpSelfTestProbe

    the test came back successful.

    I've also checked that the external and internal connections for MAPI are the same, which they are.

    I'm all out of options at the moment.

    Any help appreciated

    Thanks

    A 401 error was received from the server, but no authentication methods are supported.
    HTTP Response Headers:
    request-id: 9cbf8909-cad3-4659-97d4-77f2fd169850
    X-FEServer: EXCHANGESERVER
    Content-Length: 0
    Date: Mon, 07 Nov 2016 18:32:15 GMT
    Server: Microsoft-IIS/10.0
    X-Powered-By: ASP.NET
    Elapsed Time: 67 ms.
    A 401 error was received from the server, but no authentication methods are supported.
    HTTP Response Headers:
    request-id: 9cbf8909-cad3-4659-97d4-77f2fd169850
    X-FEServer: EXCHANGESERVER
    Content-Length: 0
    Date: Mon, 07 Nov 2016 18:32:15 GMT
    Server: Microsoft-IIS/10.0
    X-Powered-By: ASP.NET
    Elapsed Time: 67 ms.
    Monday, November 7, 2016 6:53 PM

Answers

  • Hi Edward

    Yes it is exchange server 2016 cu3.

    I'm not sure how to check MAPI/HTTP is enabled at the org level? (i'm a newbie still learning)

    I configured the MAPI virtual directory through the ECP, both the internal and external are sitting as https://mail.ex2016.com.

    I've checked the authentication and non are ticked,. Which ones should be ticked as standard?

    

    Thanks

    Yep.  That's the same issue I saw on a deployment.  Go ahead and check NTLM and try an IISreset.  That should take care of it.  

    If it's Exchange 2016 MAPI/HTTP is enabled by default.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    • Marked as answer by Tim Antlittle Tuesday, November 8, 2016 7:04 PM
    Tuesday, November 8, 2016 6:49 PM

All replies

  • Hi all

    I'm a total newbie to this all.

    Basically I've run the remote connectivity tester "outlook connectivity" and it's failing at the last section on MAPI over HTTP.

    This is the error that i'm getting:

     


    Testing HTTP Authentication Methods for URL https://mail.exchangesrver.me/mapi/emsmdb/?MailboxId=b7218b28-c482-44b9-9ca2-7496fae1ce11@xxxxxxxx.com.
      The HTTP authentication test failed.
      Tell me more about this issue and how to resolve it
     
    Additional Details
     
    A 401 error was received from the server, but no authentication methods are supported.
    HTTP Response Headers:
    request-id: 9cbf8909-cad3-4659-97d4-77f2fd169850
    X-FEServer: EXCHANGESERVER
    Content-Length: 0
    Date: Mon, 07 Nov 2016 18:32:15 GMT
    Server: Microsoft-IIS/10.0
    X-Powered-By: ASP.NET
    Elapsed Time: 67 ms.

    I've tried on the server to run:

    Test-OutlookConnectivity -RunFromServerId exchangeserver -ProbeIdentity OutlookMapiHttpSelfTestProbe

    the test came back successful.

    I've also checked that the external and internal connections for MAPI are the same, which they are.

    I'm all out of options at the moment.

    Any help appreciated

    Thanks

    A 401 error was received from the server, but no authentication methods are supported.
    HTTP Response Headers:
    request-id: 9cbf8909-cad3-4659-97d4-77f2fd169850
    X-FEServer: EXCHANGESERVER
    Content-Length: 0
    Date: Mon, 07 Nov 2016 18:32:15 GMT
    Server: Microsoft-IIS/10.0
    X-Powered-By: ASP.NET
    Elapsed Time: 67 ms.
    A 401 error was received from the server, but no authentication methods are supported.
    HTTP Response Headers:
    request-id: 9cbf8909-cad3-4659-97d4-77f2fd169850
    X-FEServer: EXCHANGESERVER
    Content-Length: 0
    Date: Mon, 07 Nov 2016 18:32:15 GMT
    Server: Microsoft-IIS/10.0
    X-Powered-By: ASP.NET
    Elapsed Time: 67 ms.

    Is this Exchange 2016? Is MAPI/HTTP enabled at the Org Level? 

    How did you configure the MAPI Virtual Directory?  If you did it via the ECP, go in and check the auth settings.  I've seem issues with those getting set.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Monday, November 7, 2016 9:29 PM
  • Hi Edward

    Yes it is exchange server 2016 cu3.

    I'm not sure how to check MAPI/HTTP is enabled at the org level? (i'm a newbie still learning)

    I configured the MAPI virtual directory through the ECP, both the internal and external are sitting as https://mail.ex2016.com.

    I've checked the authentication and non are ticked,. Which ones should be ticked as standard?

    

    Thanks

    Tuesday, November 8, 2016 6:44 PM
  • Hi Edward

    Yes it is exchange server 2016 cu3.

    I'm not sure how to check MAPI/HTTP is enabled at the org level? (i'm a newbie still learning)

    I configured the MAPI virtual directory through the ECP, both the internal and external are sitting as https://mail.ex2016.com.

    I've checked the authentication and non are ticked,. Which ones should be ticked as standard?

    

    Thanks

    Yep.  That's the same issue I saw on a deployment.  Go ahead and check NTLM and try an IISreset.  That should take care of it.  

    If it's Exchange 2016 MAPI/HTTP is enabled by default.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    • Marked as answer by Tim Antlittle Tuesday, November 8, 2016 7:04 PM
    Tuesday, November 8, 2016 6:49 PM

  • Yep.  That's the same issue I saw on a deployment.  Go ahead and check NTLM and try an IISreset.  That should take care of it.  

    If it's Exchange 2016 MAPI/HTTP is enabled by default.


    Its definitely Exchange 2016, not sure why it wasn't ticked. I've only changed the internal and external connector addresses. 

    I will give it a go and let you know.

    Tuesday, November 8, 2016 6:56 PM
  • It works! thank you.

    Is NTLM the most secure, or can we choose an alternative?

    Tuesday, November 8, 2016 7:04 PM
  • It works! thank you.

    Is NTLM the most secure, or can we choose an alternative?

    Glad to have helped :)  I usually do the virtual directory configuration in the shell bc i find it quicker, but this last deployment I did it via the EAC and spent a few hours banging my head on my desk trying to figure it out.

    NTLM is Windows Authentication and is typically the one most clients I have worked with use.  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Tuesday, November 8, 2016 7:11 PM
  • Tks!!! Work for me!

    Cristian Nobrega

    Friday, March 3, 2017 8:24 PM