locked
SharePoint 2010 Workflow Email Excludes User/Recipient RRS feed

  • Question

  • I have a very simple SharePoint 2010 list workflow which simply sends an email when a new item is created. The email is sent to two fixed AD users in the workflow, as well as one or more AD users from a field in the list item. The workflow seems to work fine in that the email gets sent. The only problem is that one of users does not get the email. I don't think it's a spam filtering issue because they are on the same Exchange server, and their name is not listed in the To box when I open the email in Outlook, etc, but all of the other users are.

    I've tried a few different things, from placing that user in the Cc field, to typing out their full email address rather than selecting from the user list. They also don't get the email if they are listed in the list field which contains additional users to email. Somehow they just get taken off of the To list.

    Is it possible that this user has somehow unsubscribed or disabled all email coming from a particular SharePoint site or installation?

    Thanks!

    Wednesday, August 13, 2014 7:36 PM

Answers

  • Hi Jeremy,

    As I understand, there is an AD account cannot receive email generated from workflow.

    Please test the issue as below:

    1. Go to workflow history and log to find if there is related error.
    2. Create a new workflow and send email to this specific user.
    3. If he receives the email, then there might be something wrong in the workflow email settings. Please capture a screenshot for email structure.
    4. If he cannot receive the email, then please confirm the user could receive the normal email and there is no Inbox rule that might remove the received email. You could also execute command in Exchange server and see if he exists in receiver:
    Get-TransportServer | Get-MessageTrackingLog -Start "14/08/2014 00:00:00" -End "14/08/2014 23:59:59"-ResultSize unlimited | Select-Object Snder,Recipients,MessageSubject,TimeStamp | fl

    Regards,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .


    Rebecca Tu
    TechNet Community Support

    • Marked as answer by Rebecca Tu Friday, August 22, 2014 2:27 AM
    Thursday, August 14, 2014 8:29 AM