none
Slow PDP response RRS feed

  • Question

  • We have created Farm with 2 virtual servers (each 16 GB ram, 4 core CPU, 100 GB disk, network 1Gb)

    On first is SQLSERVER 2012 Enteprise
    On second is Sharepoint 2013 and Projectserver 2013
    All updates are on latest level

    SQL
    1. MAXDOP = 1
    2. Transaction log has 4 Log files
    3. For all databases auto growth is set to MB and according to current statistics so 70% of database files is empty, log files are  70% empty

    Problem

    When only one user opens any Project Detail Page response is cca 7-10 sec. (Avery time, not just first time)
    Any suggestion are welcome
    I'll send more details just have to prepare statistics.

    Thanks,
    D



    Tuesday, January 19, 2016 9:11 AM

Answers

  • We solved the problem

    on both servers changed following things:
    1. Setting NIC Card configuration property named "Link Speed & Duplex" to 1000 Mbps,
    2. Check with your network administrator for TCP Chimney Offload http://support.microsoft.com/kb/951037. By Default in Wind 2008 Servers, this setting is "Automatic", we need to disable it if it's not. "netsh int tcp set global chimney=disabled"

    3. Moved windows swap file to another disk and set it to 2x RAM

    Thanks,

    D

    • Marked as answer by MR - D Monday, January 25, 2016 8:31 AM
    Wednesday, January 20, 2016 7:13 AM

All replies

  • MR-D,

    Couple of questions:

    1) How many Custom Fields you have being displayed on the PDP?

    2) Do you have any "Scripts" running on the PDP. For one of my clients, there was a script that prevented special characters in project name, which was causing very slow performance, until we optimized the code. Do you have anything similar?

    3) Do you have any "Content Query" or "Content Search" webparts on the PDPs? Both of them cause slow performance.

    4) and finally, did you configure TempDBs on SQL Server per recommendation?


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   


    Tuesday, January 19, 2016 3:01 PM
    Moderator
  • We solved the problem

    on both servers changed following things:
    1. Setting NIC Card configuration property named "Link Speed & Duplex" to 1000 Mbps,
    2. Check with your network administrator for TCP Chimney Offload http://support.microsoft.com/kb/951037. By Default in Wind 2008 Servers, this setting is "Automatic", we need to disable it if it's not. "netsh int tcp set global chimney=disabled"

    3. Moved windows swap file to another disk and set it to 2x RAM

    Thanks,

    D

    • Marked as answer by MR - D Monday, January 25, 2016 8:31 AM
    Wednesday, January 20, 2016 7:13 AM