locked
Hide MetaData Column RRS feed

  • Question

  • Hello All

    I have requirement to Hide the MetaData Column .I have attached the Screen Shot

     

    Now i want to Hide only the First Column(Content Type is it possible)??Please help me on this.

     

    Thanks

    Ashik

    • Moved by Xue-Mei Chang-MSFTModerator Tuesday, February 7, 2012 9:14 AM sharepoint 2007 issue (From:SharePoint 2010 - General Questions and Answers)
    Saturday, February 4, 2012 6:04 AM

Answers

All replies

  • You will have to customize the form to hide the column.

    You can do so either in SharePoitn designer or create custom form and change the content type forms.

    http://weblogs.asp.net/gunnarpeipman/archive/2009/06/05/sharepoint-customizing-dispform-aspx-and-editform-aspx-through-browser.aspx


    Varun Malhotra
    =================
    Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you.
    Saturday, February 4, 2012 8:39 AM
  • Hi.

    I'll try and help on this as well :-)

    Do the dropdown show up even if you only have one content type in your library? And it is set to be default?

    (B.t.w. is this SharePoint 2010?)

     

    Regards


    Thomas Balkeståhl - Technical Specialist - SharePoint - http://blksthl.wordpress.com
    Sunday, February 5, 2012 1:21 PM
  • Hello Thomas

      I have many content type almost 16.And it is Sharepoint 2007 .For example the screen shot below shows the different content type when you click on new in documnet Library.Then after you select any content type and the meta data properties pop up.There you get the screen shot as shown above in the thread.So since i hav already select content type in new we dont want the dropdown in metadata to select again.Either i wanna hide it or remove it.

    Monday, February 6, 2012 5:59 AM
  •  

    Hi Ashik,

    You can hide or remove that column by going to Settings>Document Library Settings. Under Content Types section(if you can’t see content types section, please go to Advanced settings to enable Allow management of content types), select the content type that you want edit its metadata. Then click the column you want edit. Here you can make this column Hidden or remove it.

    Thanks.


    Pengyu Zhao

    TechNet Community Support

    Wednesday, February 8, 2012 1:58 AM
  • Hello Zhao

      First of all thanks for the reply.I had already tried that option and only for that Content Type MetaData i dont get the Hide  or edit Column i get it for the remaining meta data.I am not sure y??Is there any other option please dont let me .I heard we can do it with Jquery but i am not sure.

    Wednesday, February 8, 2012 5:56 PM
  • Varun thanks a lot for your reply but i am unable to solve it
    Wednesday, February 8, 2012 5:57 PM
  •  

    Hi Ashik,

    You can refer to the following two articles. They are about hiding fields in SharePoint form through code:

    https://www.nothingbutsharepoint.com/sites/eusp/Pages/quick-and-easy-use-jquery-to-hide-a-text-field-on-a-sharepoint-form.aspx

    http://blog.qumsieh.ca/2010/02/16/hide-columns-in-sharepoint-new-edit-and-disp-forms/

    Thanks.


    Pengyu Zhao

    TechNet Community Support

    • Marked as answer by Pengyu Zhao Wednesday, February 15, 2012 1:26 AM
    Thursday, February 9, 2012 1:35 AM
  • Zhao thanks for your Link.But that did not solve my problem.

    My actuall problem is there are 16 Content types and randomly at times if i have selected the Content Type as Dutch it would have automatically change to spanish so i was plannin to hide the content type column thinking its the users who are doing error while entering the metadata.But actually its not users who are doing it automatically chnages .And this problem happens randomly.Do you have any idea what could be the issue.

    Kindly help .Thanks in advance

    Wednesday, February 22, 2012 12:40 PM