none
New router blocks ONLY Win7 Internet access, linux and iOS connect to the Internet fine RRS feed

  • Question

  • I have a new router connected to my internet from FIOS. I was sick of the ActionTec router requiring a reboot every few days in order to get it to hand out ip addresses again, so I purchased a Ubiquiti edgmax router. After changing the MAC address of the router to match the MAC address of the actiontec router, I was able to get it functioning. Sadly, that's when the weirdness began. I am able to connect to the internet fine on almost all my devices. I have two Roku streaming media players and an Ooma Ip phone box that connect to the internet fine with the new router. All my iOS devices connect fine to the internet. I have a dual boot desktop connected via Ethernet and when I boot to Linux, it connects to the internet fine. If I reboot to Win7 (same exact hardware!), there is no internet connection. I can see the other devices in the network map (I see the Brother printer and the Roku boxes) that are on this side of the firewall, but Internet access past the firewall is not available (red X between router and Internet).

    I have done a virus scan using both MalwareBytes and AVG (in safe mode), and there are no virus found by either. I can reconnect the crappy Actiontec router and everything is fine. I also tried bringing the router, wifi access point and Win7 laptop (that was NOT connecting to the internet at my home) to my office and connected it all here, and it works fine!

    WTF!!!

    To say that I am frustrated would be an understatement.

    I tried contacting Ubiquiti tech support, they are unable to help me. I spoke with Verizon Tech support, but they do not have networking competent people available, and simply told me that using a non-actiontec router will not work and is not supported. That is not true, because it works fine EXCEPT for Win7 machines.

    What does Windows 7 do to decide if there is an internet connection? Why is Win7 the ONLY thing that fails in my new network?

    Wednesday, December 2, 2015 4:52 PM

Answers

  • I have solved the problem, and it is obviously a Windows silliness. The solution  is to disable IPv6 support in the router. Apparently, even though I had disabled IPv6 support in the Windows driver for the network adapter, Windows was still using IPv6! Other operating systems are apparently able to decide that, if IPv6 does not work, try IPv4. But not Win7! It is dumb, and disappointing, since it took me three weeks and allot of aggravation to find and resolve the issue on my own.

    So, why does Win7 use IPv6 when the driver has been told not to use it? And, why does Win7 not try to use an IPv4 address to access the internet if an IPv6 address fails to connect?

    Tisk, tisk, tisk...

    • Marked as answer by webzurd Thursday, December 3, 2015 3:06 PM
    Thursday, December 3, 2015 3:06 PM

All replies

  • It is absolutely impossible to tell you why you having the problem you have without the capability to physically look at your system.

    The first thing to do is reset you router back to factory settings and then follow the instructions from the user manual configuring it for use with Windows.  I suspect you injected the problem when you decided to change the MAC address.  For normal setup and operation it is not necessary to play with the MAC address at all.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, December 2, 2015 5:10 PM
  • Hi Rick,

    Actually, that is not true. Verizon FIOS will not allow a non-recognized router on it's network.If I do not change the MAC address of the new router to the MAC address of the old router, I will not get an IP address from Verizon. I could have called Verizon and had them change the "allowed" router MAC address to the new routers MAC address, but then I would have had to call them again to change it back if something happened.

    The reason that I chose to spoof the MAC address from the actiontec router onto the Ubiquiti router is that I wanted to be able to put back the actiontec if things failed (which they sort of did).

    The router that does not allow internet access on any Win7 system is essentially in a factory reset state. There is NO customization of the router, it's firewall, or NAT.

    Please re-read my initial report: The router functions flawlessly with non Win7 machines, including a WinXP machine.

    Wednesday, December 2, 2015 6:21 PM
  • Hi webzurd,

    Please try to ping the router gateway to have a troubleshoot.
    If it is available to ping the router gateway, it indicates the issue is caused by the router. We should concentrate on troubleshooting the router issue. Reset the router is the first step we could try.
    If it is not available to ping the gateway, it indicates the connection between the router and the Windows 7 machine is corrupted. We could try to reinstall the network adapter driver from the device manager.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, December 3, 2015 8:26 AM
    Moderator
  • I have solved the problem, and it is obviously a Windows silliness. The solution  is to disable IPv6 support in the router. Apparently, even though I had disabled IPv6 support in the Windows driver for the network adapter, Windows was still using IPv6! Other operating systems are apparently able to decide that, if IPv6 does not work, try IPv4. But not Win7! It is dumb, and disappointing, since it took me three weeks and allot of aggravation to find and resolve the issue on my own.

    So, why does Win7 use IPv6 when the driver has been told not to use it? And, why does Win7 not try to use an IPv4 address to access the internet if an IPv6 address fails to connect?

    Tisk, tisk, tisk...

    • Marked as answer by webzurd Thursday, December 3, 2015 3:06 PM
    Thursday, December 3, 2015 3:06 PM