locked
What is 'Thumbnail Handler Extraction Host' RRS feed

  • Question

  • I was helping someone set up their new Windows 8 PC. They already had Office 2013, Skype, SkyDrive, some HP software for their printer, and a few other software items, such as 'Classic Start 8' start button installed. We started a Windows Remote Assistance session, so I could help them install Adobe Acrobat XI Standard. We were nearly through the install when the screen started flashing every few seconds.

    Although the flashing made the Windows Desktop UI very hard to use, I was eventually able to bring up the task manager to see that each flash seemed to correspond to a new process being created for 'Thumbnail Handler Extraction Host'. There must have been a hundred or more of the processes running before we rebooted. After the reboot the PC would seem fine when we stayed in the modern interface, but as soon as the desktop was entered the flashing would start. Subsequent reboots would have the same behavior.

    I eventually had them do the 'Refresh your PC without affecting your files' procedure through the modern interface, but when they were reinstalling their desktop software eventually the flashing came back.

    Would someone know what the 'Thumbnail Handler Extraction Host' process does, and if there might be a way to avoid it? I saw some other posts where Skype was mentioned with a 'Thumbnail Handler Extraction Host' error.

    Sunday, February 10, 2013 7:24 PM

Answers

  • this looks like a Windows program which generates the thumbnails you see in the Explorer for video, music and picture files.

    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by Juke Chou Sunday, March 3, 2013 1:17 PM
    Sunday, February 10, 2013 8:17 PM
    Answerer

All replies

  • this looks like a Windows program which generates the thumbnails you see in the Explorer for video, music and picture files.

    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by Juke Chou Sunday, March 3, 2013 1:17 PM
    Sunday, February 10, 2013 8:17 PM
    Answerer
  • Hi.

    This reply is to not only help 'JasonDragon', but also to help anyone else who has encountered this problem. This solution may not work on a brand new machine.

    I purchased a HP laptop with Windows 8 on it in November 2012, and apart from the odd lock-up, it has worked relatively okay. To be honest I'm still getting used to the interface. Last night I had the same problem with the Start menu and desktop flashing.

    First off, I started my laptop up and after entering my log-in details I was informed that my profile could not be loaded, and a temporal one was being opened in its place. Because that was inconvenient, I restarted the computer. When it rebooted it took ages and ages and once the Start menu was displayed, it kept flashing between that and the deskop. After restarting several times, the problem kept happening. Eventually I got into the task manager, and found the same thing, Windows kept opening the 'Thumbnail Handler Extraction Host' over and over again. I read up on some of the forums about the problem and they recommended a 'clean boot', which I couldn't do as I couldn't access 'msconfig' or whatever it's called. The computer didn't recognise me as a user as it was still loading through the temporal one, so I couldn't get into much as it wasn't an administrator account. The forum also suggested downloading a Microsoft scanner to check for viruses, but that wouldn't run as the 'Thumbnail Handler' eventually crashed the computer and stopped the scan, probably because it was using up a lot of memory over time.

    Just a quick note, if you want to back any of your files up, you can get into them by going through the task manager. I simply opened the file location of a program in the list, and it opened a new window, giving me access to my C-drive and let me access my files without credentials. USB devices work too. Just be prepared for the flashing screen in the background which can be really annoying.

    The next thing I tried was a system restore. The first time I tried it was when I was logged in to Windows 8. This restore was set for the 7th of July 2013 and it failed. The flashing was still there and because Windows was opening my account as a temporal account, all of my apps had disappeared. However, I then decided to have another go at the system restore, but this time outside of the Windows 8 platform to see if that made a difference. So when booting my computer up I pressed F11 which opened 'system recovery' and allowed me to do another restore. This time it included a box with a progress bar instead of the Windows 8 screen with the little circle thing going round, making you wonder if it was actually doing anything. I set it for the 1st of July 2013. At the end it told me it failed which was really annoying. However, when I logged back in again I noticed my computer password had changed back to the one I used on the 1st of July, so I entered that and it started to log me in. And once it did everything was back to normal, and a box came up saying that the restore was successful. My apps were back and the flashing had stopped.

    If you have this problem, I recommend sticking to using the system restores as they do eventually work. My computer is now running incredibly slow at the moment, but the main thing is I can get into it. I'm just hoping the speed issue isn't a permanent thing as it is an i5.

    I hope this helps anyone who has struggled with this very bizarre issue. :)

    Monday, July 15, 2013 9:16 AM
  • Now im sure it is unlikely you will ever check this again, but your post has saved me!
    - my partners 'fairly new' windows 8 laptop worked fine one day, but upon startup the next day it gave us some profile errors and then the nightmare began. After searching the interwebs for a large amount of time, your post is the only one that ran parallel with my situation. (:
    With this information, i just had to find a way to start the computer in recovery mode: the shift f8 and f11 keys didnt work for me, so heres the steps for anyone els: 

    1. Startup your computer, and login.
    2. amidst the flashing, press ctrl + alt + delete.
    3. launch task manager
    4. click on the show more info arrow in the bottom left.
    5. press file, run new task.
    6. type : shutdown /r /o (method 3 here:http://pcsupport.about.com/od/windows-8/a/open-advanced-startup-options-windows-8.htm)
    7. hit enter, and your computer will tell you its restarting.

    8. after the restart, hit troubleshoot.
    9. now hit advanced options and find the restore point one.
    10. open that, and it will give you an automatic restore point (a few days ago), there is a tick box to show more points if you want to.
    11. restore to any point that was made a few days prior; it wont hurt your files.
    12. wait for it to do all its jam. 
    13. yahtta yahtta yahtta.
    14. restart and hey presto:

    My only real problem was finding the recovery area, but your post was a great confidence boost and lifesaver!(: good luck!
    Wednesday, October 9, 2013 11:15 AM
  • I ran into similar issue as well.   After a windows update the issue was gone. 

    Thursday, October 17, 2013 4:21 AM
  • I have similar problems with Explorer Application Error and multiple a Thumbnail Handler Exception processes. I'm using 8.1 and have restored to previous point when everything ok but that has not sorted it. Suspect it has something to do with profiles. A day later and I'm still trying options. Isn't Windows wonderful even after all these releases.
    Wednesday, February 19, 2014 1:34 PM
  • I've had this issue occur several times now.  For whatever reason, something occurs while I'm working which causes the desktop to start loading, then the purple background, desktop, loop.  I get the same experience via the task manager - multiple thumbnail handler exception processes.

    My first pass at resolving this issue was similar to what was listed above: 'Refresh your PC without affecting your files', which seemed to work.  The 2nd time this issue occurred, the refresh tactic did not work, which forced me to do a system restore.  That also worked.  The 3rd time this occurred neither option worked.  When trying to perform a system restore I got a message that no restore point was available - great!

    So, in the normal boot mode, I ran msconfig via the task manager.  I switched my settings to boot into safe mode with networking and I disabled all services.  After making those changes in safe mode, I switched back (with all services off - a few were left on as I couldn't disable them within msconfig) into the normal boot up process, which seemed to stop the desktop loop.  

    So now that the loop stopped, I tried configuring my services exactly as suggested by some dude online referred to as black viper.  His configuration changes to my services didnt work.  After making those changes, I restarted and the loop was back.  

    So I ran msconfig again, and randomly disabled the 'Windows Driver Foundation - User-mode Driver Framework service'.  I rebooted and that seemed to do the trick.

    Since then I've ran cccleaner and malwarebytes but havent turned that service back on.  I'm not sure why disabling that service seemed to stop my loop issue, and I'm not sure if I can do anything to "fix" this issue beyond my attempts so far.

    I have noticed that when loading windows explorer and I change my view to large icons, the explorer window crashes..  So, as stated above 'this looks like a Windows program which generates the thumbnails you see in the Explorer for video, music and picture files.', I'm guessing I have multiple issues occurring here.

    Does anyone know what steps I can take to resolve my current situation?

    Thanks for reading!

    P.S. - I'm using a desktop, not a laptop.


    Saturday, March 8, 2014 1:38 PM
  • I have similar problems with Explorer Application Error and multiple a Thumbnail Handler Exception processes. I'm using 8.1 and have restored to previous point when everything ok but that has not sorted it. Suspect it has something to do with profiles. A day later and I'm still trying options. Isn't Windows wonderful even after all these releases.
    Have you learned anything new about this issue?
    Saturday, March 8, 2014 1:50 PM
  • If anyone else comes here... I was able to stop this from happening by renaming/deleting the AppData\Roaming\ClassicShell folder.

    I adwise everyone here to:

    1. Create a new user and see if the issue remains (continue if no)
    2. Copy the AppData folder of the "broken" user into the working one (from another new profile); keeping the freshly created Appdata folder (continue if issue reappears)
    3. Swapping out folders from the old, broken profile against the new ones, starting at the Local/LocalLow/Roaming Level, then working your way down the structure. Prioritize the testing of utilitys like ClassicShell, that fiddle around with Windows Explorer.
    Thursday, March 27, 2014 4:24 PM
  • Thanks a million for this post! Worked like a charm! :)
    Saturday, March 29, 2014 10:10 PM
  • My relatively new Dell laptop is doing the "Thumbnail Handler Exception" dance like described above in Windows 8.1. The fix described by Paremo sounds great but could someone explain this fix "Dummies" version? I'm not a computer wiz. I can get to the Task Manager well enough but what's an AppData / Create new user? etc etc
    Monday, March 31, 2014 3:51 AM
  • No idea how to do this.  I was able to create a new user, but I can't copy certain folder in my admin account.  Can you give step by step please?
    Friday, April 11, 2014 2:38 AM
  • Hello. Had the same issue on a Gateway machine. I was searching on another forum and found that the answer was to disable the Windows Error Reporting Service.

    A link to that blog:

    • http://www.bleepingcomputer.com/forums/t/515273/home-screen-and-desktop-switch-to-each-other-in-a-continuous-loop/


    ME

    Monday, April 14, 2014 4:11 AM
  • Yesterday I spent the entire evening fixing the same problem my laptop.  

    First thing I noticed a few days ago is that my Google Chrome stopped working.  I thought it was just my wifi so I did a reset of my wifi which did not help.  I noticed however that my Internet Explorer did work.  I am not sure if this problem is related or not to what happened next but thought I'd mention it.

    Then my computer was telling me that I needed to do some Windows updates so I clicked on the button to allow the updates to proceed.

    After the updates finished and the computer did it’s restart, everything was screwy.  My start screen was flashing on and off and it wasn’t letting me click on anything.  I could however pull up the task manager by doing a control/alt/delete. 

    I noticed that there was a message that was repeating itself over and over again in the processes tab.  The item that was repeating was labeled:  “thumbnail handler extraction host”.  I googled that and found this forum.  People were giving instructions on how to fix it but the instructions were  advanced stuff that I didn’t understand and therefore didn’t want to attempt.

    I wanted to do a system restore but couldn't click on the control panel as it was flashing on and off.  I was able to get to the control panel through the task manager by typing "control panel" in the search bar in the upper right of the task manager screen.  Then when I went to the restore screen, it was telling me I didn't have any restore points set up.  I went into the updates section and was able to find a way to do a restore to a point where I had done a previous update. 

    Since all of this happened when I did the windows updates, I am assuming it has something to do with the update, so for now, I have gone into my update settings and set it to not update.  Today, I spoke to one of the IT guys at work and he agrees I should not attempt another update at this time but to wait a few weeks and then set up a restore point prior to trying to update again.

    Tuesday, April 15, 2014 5:23 PM
  • Dont know if this helps anyone, but i found that Nortons 360 was causing this issue.  Removed Nortons, restarted and all back to normal.  Believe this happened when upgrading to 8.1 from 8.

    Hope this helps.


    Tuesday, May 13, 2014 3:27 AM
  • Muchas gracias. Efectivamente di de baja de mi Computadora el Norton 360 y mi Computadora Trabajo normalmente.


    Nuevamente muchas gracias.



    • Edited by jaqbreco Friday, May 23, 2014 7:02 AM
    Friday, May 23, 2014 6:59 AM
  • Many thanks JaredHearn. I removed Norton 360, which fixed the flashing screen and have now re-installed without any recurrence.
    Saturday, May 24, 2014 4:55 PM
  • JaredHearn man that shit really works... I uninstalled Norton 360 and voilá!, Windows back to normal operation... Thank you man!
    Wednesday, May 28, 2014 6:40 AM
  • JaredHearn solution really Works... Uninstall Norton 360 (if you have it install)... I had the same issue with Windows 8. Now is full working!
    Wednesday, May 28, 2014 6:43 AM
  • OMG OMG OMG!!!! I've been trying to fix this whole problem with the flashing screen on Windows 8 all night. Finally got to the bottom of this particular blog and found the quick fix from Jared Hearn's post!!! You just have to Uninstall Norton 360!!

    For those of you that are having trouble getting to the the point where you can even begin to uninstall it, all you have to do is.... Ctrl Alt dlt and open up the task manager.... Click file-->Run program, click okay. Then type cmd and click okay. Once the command prompt window is open type in " control appwiz.cpl " and press enter, which opens up the control panel/Add&Remove hardware window. From there you just select Norton 360 and Uninstall

    (I had a ton of trouble trying to type anything with the flashing screen making my cursor unlock in the text box, but if you just keep clicking and typing 1 key at a time you'll get there)


    /edit, I accidentally clicked up voted on Andre Ziegler's answer when I was trying to figure out how to down vote him in hopes to boost Jared Hearn's post up to the top for people to see as it actually solves the problem. 
    • Edited by Skoopies Saturday, May 31, 2014 7:02 AM
    • Proposed as answer by DaphneScooby Wednesday, August 6, 2014 11:15 AM
    Saturday, May 31, 2014 6:54 AM
  • Wow!!! Thank you didn't think I would find answer to this issue before my day at work tomorrow with the flashing laptop. Uninstalled norton 360 and problem solved. It has been working fine on windows 8.1 for two months and then just got the high CPU usage, flashing screen and thumbnail handler exception thingy. Cheers skoopies for your step by step instructions of how to get to the control panel and how to uninstall norton. I needed that.
    Tuesday, August 5, 2014 2:17 PM
  • I have investigated for half a year now in many many forums and found out the following:

    The issue seems always starting on mobile devices as laptops regardless of the manufacturer.

    With me, the issue starts after installing Update 1 to Windows 8.1 on a Lenovo Netbook/Tablet with Intel Atom. Others have just said the issue starts after any update. Maybe they just don’t know which update it was and maybe it was the big Update 1 too (if automatic update is activated you don’t recocnise which update is installed in background). But in one case I remember the problem was not in connection to an update. If I remember right (and the person described correctly). (But, sorry, it was a long time an many storys)

    In all cases it seems a connection with

    Thumbnail Handler Extraction Host

    And many could solve the problem with deactivating the

    Windows error reporting Service

    Some could solve the problem with deinstalling Norton 360.

     

    BUT, - I have nothing on my machine from Norton (Symantec) AND I had deactivated the Windows error reporting Service and it made a change: The desktop-flashing was gone but the taskbar-flashing still resists AND a new error starts which pop up any 3 seconds a messagebox with an “explorer – error” like “reading from Adress 0x000000000000000).

    Starting the machine in recovery-mode brings no reform.

    I also have reinstalled the most important original drivers (downloaded from Lenovo-Website), which I already had installed before updating to Update 1.

     

    I’m really distressed about this issue as it costs me sooo many time already and Microsoft seems not to be able to find out what the problem is and solve it although there are soo many people with that issue.

    Tuesday, August 12, 2014 12:54 PM
  • I found it !!!!!!!!!!!!!!!!

    In the windows-8-forum.net a user named HABENICHT reported that the problem is maybe the 20 years old file called "ODBCCP32.cpl".

    After renaming this in ODBCCP32.OLD the issue is gone and my netbook works fine.

    I guess that this file is maybe a part of Norton 360 and as it is not used anywhere else it got deleted with the deinstallation. Thats why other's got this issue solved with deinstallating Norton.

    Microsoft should pay Habenicht at least 1000 US$ and give him a Job!

    Tuesday, August 12, 2014 7:59 PM
  • After a windows 8.1 update a little over a week ago I started having the same issue.  When windows would successfully load (it didn't always since the update), the screen would begin flashing after 10 seconds and flash progressively faster and faster as time went on.  Fortunately I could access Task Manager and noticed more and more Thumbnail Handler Extraction Host processes opening up.  

    The only thing that worked for me was going in to my bios, selecting the drive that windows was installed on and boot it out of the bios with the installation disk in my DVD drive.  The load would fail which would trigger the troubleshooter.  I would then be able to access all the troubleshooting options, and the only one that worked was system refresh.  

    I tried doing this originally by booting from the DVD with no success.  This only worked by booting through bios.  

    I hope that helped someone because this has been one of the most annoying issues to troubleshoot. 

    This last bit will be a bit of a rant so feel free to ignore it - Windows 8 has been by far the absolute worst OS i have ever used.  I've been using PCs since Windows 95 and I have never once considered migrating to Mac because of their prices and some of the limitations.  After all the problems I have experienced with Windows 8, most noticeably the ridiculous structure where you can't access options/preferences as straight forwardly as in previous OSs, to say nothing of the endless glitches that crop up in every update (this last one almost completely bricking my desktop), I will be moving to Linux or Mac with m next purchase.  I'm done with windows.  They simply can not make functional OSs anymore.  
    Monday, January 26, 2015 5:24 PM
  • Thanks !!!! Worked like a charm in Windows 10 too.
    Saturday, November 12, 2016 2:09 PM
  • This one solve my problem on a ASUS tablet with windows 8 

    Thank you very mucho Feyre

    Thursday, September 7, 2017 4:06 AM