locked
Problems with changing editing language in Word 2010 RRS feed

  • Question

  • Hello,

    I have a problem with creating text with two languages in Word 2010. I usually write and edit documents with Hebrew and English inside it, but recently I can't change the typing language to English using Alt+Shift (both sides of the keyboard), though if I'm already in English I can change it back to Hebrew. The only way to change the editing language to English is by using the Caps Lock/(Shift+typing) or by Left-Ctrl+Shift, which also force me to edit the text LTR, while my documents are mostly RTL with some English combined in it.

    I tried to disable all the COM add-ons on Word but it didn't help. 

    Just to mention that I didn't noticed this problem in any other MS Office application, even with creating Emails in Outlook, which uses Word editing capabilities. 

    I'm running Windows 7 64-bit with 32-bit Office Professional Plus.

    Any suggestions will be appreciated.

     

    Regards,

    Elad

    Monday, October 31, 2011 9:44 PM

Answers

  • Hi,

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, the issue might be caused by the advanced key setting of input language. Please determine if the following steps can fix it:

     

    1.Click Start > Control Panel > Change keyboards or other input methods under Clock, Language, and Region

    2.Click Change keyboards…

    3.Click Advanced Key Settings tab> highlight Between input languages under Hot keys for input languages section.

    4.Click Change Key Sequence…, set the Switch Input Language as Left Alt + Shift, Click Ok.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

     

    Sincerely

    Rex Zhang

    --------------------------------------------------------------------------------

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Rex Zhang Sunday, November 6, 2011 2:28 AM
    Wednesday, November 2, 2011 7:53 AM