locked
Access Denied error during remote agent install RRS feed

  • Question

  • On some of the systems on which I am trying to perform a remote agent install the following error appears...

    The MOM Server could not execute WMI Query "Select * from Win32_OperatingSystem" on computer ctlg03.lehmans.lan.
    Operation: Agent Install
    Install account: LEHMANS\Scheduler
    Error Code: 80070005
    Error Description: Access is denied.

    The Install Account has worked fine for most of our systems. (over 90%)

    None of my Internet searches have been fruitful in regards to this error.

    Is there any way I can do a remote agent install on systems that experience this error?  I would prefer to not perform a manual install if at all possible.  I'm concerned that a manual install will require doing any further agent updates (such as SCE service packs) manually.

    The SCE server is in the same subnet and has SP1 for SCE installed.
    Friday, March 28, 2008 6:03 PM

Answers

  • Hi,

     

    To correct the script issue we needed to reregister vbscript.dll by issuing the following commands on problematic clients:

    %systemdrive%
    cd %windir%\system32
    regsvr32 vbscript.dll

    Then, restart WMI service.


    Additionally, in order to correct the WMI connection issue, we needed to make sure that DCOM was enabled on both machines. This can be done by going into DCOMCNFG, component services, computers and right-click my computer. Then go to properties and click on the default properties. Make sure that “Enable Distributed COM on this computer” is checked.

    Hope this helps.

    Monday, March 31, 2008 5:33 AM

All replies

  • Hi,

     

    To correct the script issue we needed to reregister vbscript.dll by issuing the following commands on problematic clients:

    %systemdrive%
    cd %windir%\system32
    regsvr32 vbscript.dll

    Then, restart WMI service.


    Additionally, in order to correct the WMI connection issue, we needed to make sure that DCOM was enabled on both machines. This can be done by going into DCOMCNFG, component services, computers and right-click my computer. Then go to properties and click on the default properties. Make sure that “Enable Distributed COM on this computer” is checked.

    Hope this helps.

    Monday, March 31, 2008 5:33 AM
  • Thank you very much for the reply.  Enabling DCOM did the trick.  Not sure why it was disabled on just a few machines.

    Maybe MSFT could add that suggestion to the results window in SCE when this particular error occurs during agent deployment?
    Monday, March 31, 2008 6:10 PM