locked
Lync 2010 Patching RRS feed

  • Question

  • Hi, Guys.

    Need your assistance on this.

    Could you please let me know any processes/procedures on how to patching your Lync 2010 servers [FE and Edge] up to the latest patch level? 

    Also, how do you identify the current patch level of your Lync environment, and determine on what latest patch level your Lync environment needs to be updated to? Please advise.

    Thank you.

    Monday, May 2, 2016 10:13 AM

Answers

  • Hi,

    Below link has multiple ways to find the correct patching level on your lync environment.

    https://msunified.net/2014/04/06/finding-the-correct-patch-verson-of-a-lync-server/

    There is a simple script which can be used to fetch the data from all server to a centralized location. Make sure you execute in test environment before run in PROD. 

    http://www.ehloworld.com/2641


    - Muralidharan. Please mark as answer/useful if my contribution helps you.

    • Proposed as answer by Greg Seeber Monday, May 2, 2016 6:30 PM
    • Marked as answer by Eason Huang Sunday, May 15, 2016 12:12 PM
    Monday, May 2, 2016 11:06 AM
  • Hi,

    patching varies from CU to CU. Sometime you will need to install CSdatabase (central management,monitoring and so on), but sometime it only requires update.

    What they have in common is steps to do before you apply CU:

    Get-CsPoolUpgradeReadinsessState

    Get-csmanagementstorereplicationstatusGet-CsPoolFabricState -PoolFqdn "your frontend pool fqdn"

    Then on the frontend you want to patch:

    Stop-CsWindowsService
    net stop w3svc

    I always to windows update before I patch my Lync/skype servers, but this is entirely up to you.

    At same page you download CU update, you have install instruction referred to a KB article.

    Ex latest CU update for Skype is : https://support.microsoft.com/en-us/kb/3061064

    Latest CU upgrade guide for Lync server 2010 is this: https://support.microsoft.com/en-us/kb/2493736


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    • Proposed as answer by Greg Seeber Monday, May 2, 2016 6:30 PM
    • Marked as answer by Eason Huang Sunday, May 15, 2016 12:12 PM
    Monday, May 2, 2016 11:37 AM

All replies

  • Hi,

    Below link has multiple ways to find the correct patching level on your lync environment.

    https://msunified.net/2014/04/06/finding-the-correct-patch-verson-of-a-lync-server/

    There is a simple script which can be used to fetch the data from all server to a centralized location. Make sure you execute in test environment before run in PROD. 

    http://www.ehloworld.com/2641


    - Muralidharan. Please mark as answer/useful if my contribution helps you.

    • Proposed as answer by Greg Seeber Monday, May 2, 2016 6:30 PM
    • Marked as answer by Eason Huang Sunday, May 15, 2016 12:12 PM
    Monday, May 2, 2016 11:06 AM
  • Hi,

    patching varies from CU to CU. Sometime you will need to install CSdatabase (central management,monitoring and so on), but sometime it only requires update.

    What they have in common is steps to do before you apply CU:

    Get-CsPoolUpgradeReadinsessState

    Get-csmanagementstorereplicationstatusGet-CsPoolFabricState -PoolFqdn "your frontend pool fqdn"

    Then on the frontend you want to patch:

    Stop-CsWindowsService
    net stop w3svc

    I always to windows update before I patch my Lync/skype servers, but this is entirely up to you.

    At same page you download CU update, you have install instruction referred to a KB article.

    Ex latest CU update for Skype is : https://support.microsoft.com/en-us/kb/3061064

    Latest CU upgrade guide for Lync server 2010 is this: https://support.microsoft.com/en-us/kb/2493736


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    • Proposed as answer by Greg Seeber Monday, May 2, 2016 6:30 PM
    • Marked as answer by Eason Huang Sunday, May 15, 2016 12:12 PM
    Monday, May 2, 2016 11:37 AM
  • Hi, Guys.

    Need to identify on which Cumulative Update Level our Lync environment are currently sitting into?

    Further, once we have identified the current CU patch level for our Lync environment, what latest CU level this needs to be patched to? Is it okay to patch our Lync environment with the latest CU version/patch level directly? If so, are there any pre-requisites/considerations prior doing this? Please advise.

    Thank you.

    Tuesday, May 17, 2016 4:18 AM
  • Hi,

    It is ok to patch the latest CU directly. 

    Just follow the installation method in the link below:

    https://support.microsoft.com/en-us/kb/2493736

    Best Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Tuesday, May 17, 2016 2:47 PM
  • Hi, Guys. 1. When do you apply the cmdlet to update the backend databases? Is it after you apply the CU updates to all Lync Frontend and Lync Edge servers? 2. If so, where do you run the cmdlet? Is it either of the two Lync FEs? What about for Lync Edge? Where do you run the cmdlet there? So basically, the cmdlet will be run on either one of the Lync FEs, and one for Lync Edge? Please advise. CMDLET: Install-CsDatabase -Update -ConfiguredDatabases -SqlServerFqdn <EEBE.Fqdn> -UseDefaultSqlPaths Thank you.
    Wednesday, May 25, 2016 2:07 AM