locked
Problems to delete big *.tif files RRS feed

  • Question

  • I have problems to delete big *.tif filese.

    At first Windows delete it, but if i pressed F5 then the files are not deleted. I have tryed to delete it with and without Shift + Del its always the same.

    When i delete this file many times then it would be deleted.

    A other Problem with this big files is that windows open a dialogbox and calculate the time that needed to delete the tif file.

    But i can wait 2 hours and more, nothing is done by windows. In the dialogbox dosn`t change anything.

    Have anyone an Idea?

    Thank you in advanced.

     

    Daniel

    Monday, August 30, 2010 5:07 AM

All replies

  • Hi.

    1) Would you try to del these files from command line?
    2) Would you try to check a disk for logical errors using chkdsk? (chkdsk disk_with_big_tif_files: /f (e.g. chkdsk d: /f)

    M. 

    Monday, August 30, 2010 10:22 AM
  • 1) Yes i have tryed to delet this files from command line. But the commandline promt doesn`t come back after start deleteing files. Sometimes i have the problem  to delete one File sometimes with many. The files are not locked by a Process. But sometimes you can delete files without any problems.

    2) no i haven`t tryed chkdsk because i have more than one computer with this problem.

    We use Windows 7 Enterpries 64 bit.

     

    Daniel

    Monday, August 30, 2010 10:45 AM
  • Would you specify a size of these files? I would like to try it on my PC, too :)
    Tuesday, August 31, 2010 9:17 AM
  • The files are 1.7 GB.

     

    Daniel

    Tuesday, August 31, 2010 10:15 AM
  • Hi,

     

    Does it happen to other files, just *.tif files? Generally speaking, When deleting a folder, the calculation time depends on not only the file size but the file numbers of the folder. So you can delete sub-folders separately.

     

    Also, you can try to use a popular methods to fix the issue. Here is the steps:

     

       1.  Right click on the file. 

       2.  Click Properties

       3.  Click Advanced

       4.  Under File Attributes uncheck Allow this file to have contents indexed in addition to file.

     

    Also, you can take the following steps to fix this issue:

     

    Step 1:

    You may try creating a new user profile to see if the same problem occurs. If not then it could be a corruption/permissions problem of the old user profile.

    To create a new user account

    http://windows.microsoft.com/en-us/Windows7/Create-a-user-account

     

    Step 2:

    If the new user account works fine then the previous account was corrupt, you may follow the link given below to fix the corrupt user profile.

    Fix a corrupted user profile

    http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile

     

    In addition, the issue can be related to third-party components, especially file system filter drivers, such as anti-virus drivers. In this situation, I suggest you can delete the files on Safe Mode. If on Safe Mode It works fine, you could perform clean boot to check the result.

     

     

    Hope it helps.

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by MStoppl Wednesday, July 8, 2015 1:55 PM
    Wednesday, September 1, 2010 7:16 AM
  • Hello Alex,

    i think the Useraccount isn`t the Problem.

    I have tryed it with 3 Useraccounts, one of them was administrator and the other tow are normal Domain Users.

    All Files have checked Properties --> Advanced --> Allow this File to have contents indexed in addition to file.

    I would try to uncheck the option and then delete the file.

    The *.tif files would be created automaticly. Can i configure Windows that this option is unchecked by creation?

    To change the option "Allow this file to have contents indexed in addition to file" doesn`t take a effect.

    Today i could delete the File with and without this option and i dont get a error.

    Wednesday, September 1, 2010 10:01 AM
  • Hi,

     

    Does this issue still persists? What’s the meaning of Today i could delete the File with and without this option and i dont get a error? Do you still wait for a long time when you delete the files?

    If the issue persists, did you test the result on Safe Mode? I suggest you perform Clean Boot, just like I mentioned above, it would relate to certain third-party software.

     

     

     

     

    Regards,

     

    Alex zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, September 3, 2010 6:23 AM
  • Hi Alex,

    the problem still persists.

    But some times i can delete the files without wainting or and error, but somtimes the files couldn`t delete or i must wait a very long time.

    I have tryed the Safe mode and it`s the same result.

    The Files are GeoTIFF`s and they have project informations in the header.
    I don`t think thats a problem of third-party software, because we use 3 diffrent Tools (ArcGIS, ERDAS, OrthoVista) and 3 tools with the same bug?

    Friday, September 3, 2010 8:17 AM
  • Hi,

     

    You could try to use SFC to check  how it works. You can refer to the following steps:

     

     

    1.    Open a command prompt by administrator privilege.

         2.  Type the following command and then press Enter.

    sfc /scannow

    3.    Restart your computer to check the result.

     

    Hope it helps.

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, September 9, 2010 9:18 AM
  • same issue - scanner creates huge TIFF files that cannot be deleted or moved (but can be copied). They can be opened and read, and appear normal.

    have run sfc /scannow

    have tried another account

    have tried command line

    cannot delete them or move them

    cannot uncheck "allow files to have contents indexed" as Explorer sometimes crashes then reboots to a "blank desktop" if I right click on any of them, 

    Monday, December 8, 2014 11:30 PM
  • the files are in the default \user\Downloads folder

    Bonus: if I RIGHT CLICK and select "properties" on any one of the files what I get is the file name is "Downloads" and if I uncheck a box I get the "apply to all files and folders" dialog. I tried it 3 times - each time the same. It is not possible to select a single file, and Explorer thinks I have selected the whole folder.

    does that help?

    Monday, December 8, 2014 11:39 PM
  • double bonus:

    OK - if I right click on files under 3Mb, i can select them and remove the check on "allow contents to be indexed". if I then right click again, I get the single file dialog and it shows "this file is blocked because it came from another computer" and I can unblock it AND I CAN DELETE IT (joy!)

    if the file is over 5Mb, none of that works, Explorer hangs and I get crashes or infinite delays.

    So it looks like a combo of files received from another computer AND indexing woes for large TIFFS

    That must help :-)
    Monday, December 8, 2014 11:45 PM