none
Removing old GPO settings RRS feed

  • Question

  • My old work computer has been removed from its previous domain, and should now work as my private computer. The problem is that some old GPO settings are reemerging when I restart the computer. The way I can tell that it’s still there is that I’m unable to change startup page in Internet Explorer.

    I’ve tried removing the following from the registry:

    • HKLM\Software\Policies\Microsoft Key (looks like a folder).
    • HKCU\Software\Policies\Microsoft Key.
    • HKCU\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects Key.
    • HKCU\Software\Microsoft\Windows\CurrentVersion\Policiess Key.

    This allows me to change the startup page, but after restarting my machine all these settings are back.

    I’m not using a domain user to log on to the machine, but a new local account.

    Thursday, September 11, 2014 3:57 PM

Answers

  • Hi,

    Please run following commands to reset GPO:

    RD /S /Q "%WinDir%\System32\GroupPolicyUsers"
    RD /S /Q "%WinDir%\System32\GroupPolicy"
    gpupdate /force

    If the issue perisits, please try to delete all group policy registry keys.
    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Start Search” box and press Enter.
    2. Locate the following key:
     
    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]
     
    Right click on "Microsoft", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.
     
    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.
    3. Highlight Microsoft and click "Delete".
    4. Please repeat the above steps for the following registry keys.
     
    [HKEY_CURRENT_USER\Software\Policies\Microsoft]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    Note: if some keys do not exist, please ignore them.

    5. Exit the Registry Editor.


    Kate Li
    TechNet Community Support

    Friday, September 12, 2014 8:04 AM
    Moderator

All replies

  • Hi,

    Issue GPRESULT /R > result.html or use rsop.msc. If the settings are re-inforced even if the computer is not part of AD anymore then probably there is local GPO which does this.

    Hope this helps.

    Regards,

    Calin

    Friday, September 12, 2014 8:01 AM
  • Hi,

    Please run following commands to reset GPO:

    RD /S /Q "%WinDir%\System32\GroupPolicyUsers"
    RD /S /Q "%WinDir%\System32\GroupPolicy"
    gpupdate /force

    If the issue perisits, please try to delete all group policy registry keys.
    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Start Search” box and press Enter.
    2. Locate the following key:
     
    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]
     
    Right click on "Microsoft", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.
     
    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.
    3. Highlight Microsoft and click "Delete".
    4. Please repeat the above steps for the following registry keys.
     
    [HKEY_CURRENT_USER\Software\Policies\Microsoft]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
    Note: if some keys do not exist, please ignore them.

    5. Exit the Registry Editor.


    Kate Li
    TechNet Community Support

    Friday, September 12, 2014 8:04 AM
    Moderator