none
Open, Save, Save As Plus the pop up at the bottom of the page RRS feed

  • Question

  • When opening an .mdb file on our intranet home page (medium security) while in IE 8, the link activates the access database within the link and opens access in a new window (as intended). 

    We have been testing with IE 10 and the link now wants to open the older style "OPEN, SAVE, SAVE AS" pop-up (3x5 card with white background).

    After selecting OPEN, we also get the new style of pop-up at the bottom saying "couldn't be loaded" RETRY, CANCEL, VIEW DOWNLOADS.

    Regardless of what I select the access db still opens as intended.

    The big question is,

    HOW do I make it so no one will see the first or second pop-ups.  I don't want the user to have an option to OPEN, SAVE, or SAVE AS, and I don't want the bottom pop-up either.

    I just want it to open like it did under IE 8.

    Friday, February 7, 2014 8:19 PM

Answers

  • Hi,

    the default security slider value for the Intranet zone is Medium-low... and Medium on server versions of windows. mdb files are 'unsafe'. Check your registry for any 'unsafe files' whitelists..

    look in these keys.

    Const HKEY_Include = "SOFTWARE\Microsoft\Internet Explorer\UnsafeFiles\Include"
    Const HKEY_Exclude = "SOFTWARE\Microsoft\Internet Explorer\UnsafeFiles\Exclude"

    Use GPO to customize your security zone settings and prevent users from changing your customizations.

    file downloads are controlled by the IE Download manager, that checks the mime-type returned from the server with the extension on the file....

    mdb==application/x-msaccess

    Inspect the value of this registry key

    HKEY_CLASSES_ROOT\.mdb

    I suspect that you will need to have a open sub-command that points to your access.exe file location in your Office folder.


    Rob^_^

    Friday, February 7, 2014 11:34 PM