none
CopyProfile not working for me MDT 2013 deploying Windows 10 RRS feed

  • Question

  • Hi Folks,

    I'm a relative newbie to MDT technology, having used ghost for my whole career.  I've been using a couple of technet articles on , first, creating a windows 10 reference image using MDT 2013, and then , second, deploying that image to a computer.  I'm happy with the results so far except I'm confused about copyprofile .  I can't get it to work and the articles/tutorials I'm using don't cover this.

    These are my current steps:

    1. Create a deployment share called MDTBuildlab to create a reference image.  As part of this process, I accessed the unattend.xml through Task Sequence -> OS Info tab and followed the steps to enable CopyProfile.  As i added a suspend action in the Task Sequence, I customized the Administrator profile to my liking and resumed the successful creation of the reference image. 

    2. I created a 2nd deployment share called MDTProduction  and imported the image file I created earlier.  I didn't do anything in Task Sequences except enable Microsoft updates and I disabled "Restore user States and "Restore user groups."  However, i did modify the boot.ini and customsettings.ini files to add the computer to a domain.  This step works fine.

    When I deployed the image to a computer and logged on with a domain user account, none of the desktop shortcuts and other default user profile modifications seem to have took.  I'm wondering if I should have edited the unattend.xml file in the Production share as opposed to the reference build image creation? 

    Any suggestions?

    Many thanks Adrian

    Tuesday, April 26, 2016 10:03 PM

Answers

All replies

  • Great question. Tons of useful detail and you even have your answer at the very end. Add copy profile to your unattend you use to deploy.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it.

    • Marked as answer by Adrian.Roe Tuesday, April 26, 2016 11:45 PM
    Tuesday, April 26, 2016 10:52 PM
    Moderator
  • Holy cow, it worked! You're right Ty !
    Tuesday, April 26, 2016 11:45 PM
  • Adrian, may I ask what version and build of Windows 10 you are deploying?
    Wednesday, April 27, 2016 11:44 AM
  • Sure.  I'm using Windows 10 Professional  10.0.10240.16384

    Wednesday, April 27, 2016 3:47 PM
  • I was wondering - do you only use copyprofile during deployment or both capture and deployment. I am also trying to get this working using MDT 2013 to create and capture my reference image and then deploy using SCCM 2012 R2 using a MDT Task Sequence.

    OS I am working with: Win10 - 10.0.10586.0

    Any thoughts would be appreciated.

    Friday, February 10, 2017 12:58 AM
  • Hi

    I am also a newbie experiencing the exact same issue as Adrian has described. However, when I enable the CopyProfile in the Unattend.xml I use to deploy (as well as the one for my reference build) it makes no difference.

    What I can't work out is that my reference image all works fine when I boot it up after the capture to a .WIM but as soon as I deploy it in MDT using a standard Task Sequence, everything goes back to default or an older layout I no longer want. I'm at my wits end trying to figure this out. I've read dozens of guides and they are all slightly different but I just can't seem to find the answer!

    Can anyone help please?

    Wednesday, April 19, 2017 3:22 PM
  • What version of windows are you deploying? I have been able to deploy it with no problem. What layout is reverting back? Are you talking about the start menu? Taskbar items? desktop icons?
    Wednesday, April 19, 2017 3:24 PM
  • Hi

    I'm using Windows 10 x64 Enterprise (build 1607). I'm only really trying to change the Start Menu tiles at the moment but it looks like the Taskbar is also defaulting back too. It almost seems like MDT is using an old .WIM file even though I've recaptured about 5 times now.

    Wednesday, April 19, 2017 3:38 PM
  • There are known issues with pinning to taskbar which have not been resolved yet.. Last time I checked...

    I started a thread regarding the start menu. Please take a look here

    https://social.technet.microsoft.com/Forums/windows/en-US/b9070b8c-54f7-4cf4-8cd2-487960e8d392/windows-10-1607-ltsb-2016-layoutmodificationxml-being-ignored?forum=win10itprosetup

    When I do sysprep and capture I run this command line

    Sysprep.exe /generalize /oobe /shutdown /unattend:c:\windows\system32\sysprep\unattend.xml

    I place my unattend file in the sysprep folder in system32. I also make sure the unattend file is the same in my deployment share under CONTROL folder...

    Hopefully this helps... I have been able to retain my start menu customizations!

    Wednesday, April 19, 2017 3:41 PM
  • Thanks for the advice.

    I am using MDT so I am relying on the Task Sequence default Sysprep when building and capturing the reference image. It seems to me using the Export \ Import .XML or .BIN is a different method? I was hoping to stick to one method i.e. CopyProfile = true in the unattend.xml. I did start off using the Export \ Import method but when I realised I was mixing methods I removed these actions fro my deployment Task Sequence.

    Can anyone tell me if I should stick with the CopyProfile only or should I switch to Exporting \ Importing the layout?

    Thursday, April 20, 2017 9:32 AM
  • The Copyprofile value has limitations. It is not working as it did in Windows 7. You will have to use copyprofile AND some other methods such as importing the start menu. It is a rather simple process and add virtually no time to your deployment. I can provide steps if needed!
    Thursday, April 20, 2017 1:22 PM
  • OK I'm going to give the Export \ Import method another go. If you can provide the steps you used that would be great.

    Thank You.

    Friday, April 21, 2017 8:02 AM
  • Hey Prince,

    Can you please provide steps?   I have having problems with Windows 10 build 1803 to copy my wallpaper and desktop icons as the standard for my reference image created with MDT.

    Thanks.

    Tuesday, August 7, 2018 2:05 PM
  • Hi, I'm having the same issue, I've created a VM with all modifications and software installed, set up the desktop and theme required, edited unattend.xml and included copyprofile=true, captured the image but when I deploy it the desktop, theme and other settings are back to the Windows 10 default, I'm also using W10 Enterprise 1803 and have just started playing with MDT as I'm getting so many issues using sysprep as I would in Windows 7 or older versions of Windows 10.

    Any help on getting Windows deployed with the custom settings I have included in the original profile.

    Cheers

    Thursday, August 30, 2018 12:56 PM