none
IE 11 pre-approve Browser Helper Objects / add-ons RRS feed

  • General discussion

  • Hello,

    I'm preparing Win 8.1 preview image with MDT 2013 beta and I have a problem making Internet Explorer 11 pre-approve Browser Helper Objects.

    I'm installing MS Office 2013, Adobe Acrobat XI, Java 1.6 in the State Restore state (so after the Windows first boots up).

    When I start IE 11 for the first time on every user I have a popup to enable the following addons:

    Java(tm) Plug-In 2 SSV Helper - ClassID {DBC80044-A445-435B-BC74-9C25C1C588A9}

    Microsoft SkyDrive Pro Browser Helper - ClassID {D0498E0A-45B7-42AE-A9AA-ABA463DBD3BF}

    Office Document Cache Handler - ClassID {B4F3A835-0E21-4959-BA22-42B3008E02FF}

    Lync Browser Helper - ClassID {31D09BA0-12F5-4CCE-BE8A-2923E76605DA}

    Adobe PDF Link Helper - ClassID {18DF081C-E8AD-4283-A596-FA578C2EBDC3}

    I've tried to add those ClassIDs to Win8.1 unattend.xml into PreApprovedAddons, InstalledBrowserExtensions, InstalledBHOLIst in Specialize phase but without any luck.

    I also tried to add them using GPO "Add-on list" in Administrative Templates for Machine and User - still no luck

    I've added them manualy under HKCU / HKLM \Software\Microsoft\Windows\CurrentVersion\Ext\PreApproved

    as well as HKCU / HKLM \Software\Microsoft\Internet Explorer\Approved Extensions

    no luck

    All of those methods doesn't work and I'm still getting "Several add-ons are ready for use." prompt each time IE is started on a new profile.

    Can you please share any ideas about it?

    Best Regards,

    Bartek


    • Edited by Bartek Krol Friday, July 12, 2013 8:24 PM typo
    Friday, July 12, 2013 8:24 PM

All replies

  • Hi,

    those extensions probably need to be applied under the WOW64 node also. Have you installed the x64 versions of those BHO's.... Some don't have one.

    send feedback to the IE Team at http://connect.microsoft.com/ie


    Rob^_^

    Saturday, July 13, 2013 1:02 AM
  • Hey doctoroftype,



    I've added the entries under Wow6432Node in registry under HKCU / HKLM and it's still not working.

    The Java and Adobe BHO's are 32bit only, the rest are "32bit and 64bit"



    I've opened a ticket at Microsoft Connect, ID: 793809 (can't paste hyperlinks)



    Best Regards,

    Bartek
    Sunday, July 14, 2013 11:48 AM
  • I am running into this same issue.  What was Microsoft's Suggestion?

    Regards,

    Brian

    Wednesday, October 23, 2013 3:47 PM
  • Same issue with Win8.1 RTM.
    Sunday, October 27, 2013 5:21 PM
  • "PreApproved Add-ons" -

    "This setting has been deprecated in Windows 8.1. The information about this deprecated setting is provided for reference only. Add-ons can still be installed but they will be disabled, by default. Users will be able to choose the add-ons to enable."

    http://technet.microsoft.com/en-us/library/ff715963.aspx

    Wednesday, February 19, 2014 4:19 PM
  • Hi Bartek,

    I have found this to work, load the default user hive to HKEY_USERS\temp then the following.. The first key is for approved extensions (javas), second key has the newinstallprompt count for the addon lync so it wont popup and it gets disabled, not sure how well this will work with future addons.

    Windows Registry Editor Version 5.00

    [HKEY_USERS\temp\Software\Microsoft\Internet Explorer\Approved Extensions]
    "{761497BB-D6F0-462C-B6EB-D4DAF1D92D43}"=hex:51,66,7a,6c,4c,1d,3b,1b,ab,80,02,\
      67,c0,80,45,09,ae,e3,8b,80,f2,9e,6f,58
    "{DBC80044-A445-435B-BC74-9C25C1C588A9}"=hex:51,66,7a,6c,4c,1d,3b,1b,54,17,de,\
      ca,75,f2,32,0c,a4,7c,c3,7f,c2,82,ca,b2

    [HKEY_USERS\temp\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{31D09BA0-12F5-4CCE-BE8A-2923E76605DA}]
    "NewInstallPromptCount"=dword:00000002
    "VerCache"=hex:00,01,a9,61,36,60,cf,01,00,01,a9,61,36,60,cf,01,00,00,00,00,a0,\
      56,03,00,00,00,0f,00,e8,03,07,12,00,00,0f,00,00,00,07,12,00,00,00,00
    "Flags"=dword:00000040

    Monday, June 9, 2014 1:00 AM