locked
CIFS: Win98 to 2008 file copy issues RRS feed

  • Question

  •  

    When trying to copy files from a Win98 client to Server 2008 I get a INT24 failure (remote resource is unavailable) on the 98 client.  I am able to access \\server2008 and map a drive, however, even looking at the mapped drive for too long will hang explorer.

     

    Does anyone know if this is a known issue?

    Friday, May 16, 2008 2:20 PM

Answers

  • Hi,
     
    Please verify that you have the proper permission to copy and write files on the target folder of Windows Server 2008.
     
    According to the captured file that you sent to me, it seems that it is not Netmon capture file, would you please follow my previous suggestion and save capture file to cap type and send me again?
     
    Thanks for your co-operation.
    Tuesday, May 20, 2008 10:24 AM
  •  

    Hey David,

     

    I got an Unknown Error when I tried to run a capture in NetMon3 on 2008 so I had to use Wireshark.

     

    Just rename the .NM2 file to .CAP and you'll be all set.

     

    The .WS file was from Wireshark.

     

    Thanks for your help,

    Chris

    Tuesday, May 20, 2008 1:39 PM
  • Hi,
     
    I have checked and compared the network monitor traces carefully.  Unfortunately, the network traces show that there are no behavior differences even after we manually configured Windows Server 2008 SMB 1.0. At this time, I am afraid that I have to say that Windows 98 is incompatible with Windows Server 2008 SMB. Thank you for your understanding.
     
    Considering that Windows 98 has been out of support boundary, if it is possible, I would like to suggest that you upgrade these legacy clients to newer operating system in order to get better support and performance.
    Monday, May 26, 2008 10:45 AM
  • Windows 98 does not support the SMB 2.0 protocol; however Windows Server 2008 does support the previous versions of SMB.  Basically the client and server will negotiate what is the highest version of the protocol that they both support and then use that version.  In the case of Win98 and Windows Server 2008 I believe these should work although Win98 is no longer officially supported. 

    Let me check with the test folks to see if Win98 was tested with Server 2008 and if yes, what configuration settings may need to be modified.  In some cases we change the defaults on the newer OS versions to disable features that are known security attack surfaces.  For these cases you may need to change something on the server to enable a feature that is needed to allow Win98 clients.
    Messages posted to this forum are provided "AS IS" with no warranties
    • Marked as answer by David Shen Monday, June 2, 2008 1:32 AM
    Friday, May 30, 2008 11:54 PM

All replies

  • Hi,
     
    1. Are the Windows 98 client and the Windows Server 2008 in the same subnet? If no, could you please test whether this issue happens on clients that are in the same subnet?
     
    2. Also, please verify they belong to same domain or the same workgroup.
     
    3. Afterwards, please try copy a file from Windows Server 2008 computer to the Windows 98 client to check if the issue also exists.
     
    4. If possible, please try to collect the network trace log for our further investigation:
     
    Download the NetMon3.1 from the following link:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=18b1d59d-f4d8-4213-8d17-2f6dde7d7aac&DisplayLang=en
     
    a. Install the NetMon on Windows Server 2008.
     
    b. In the Microsoft Network Monitor 3.1 window, click Create a new capture tab…
     
    c. In the new tab, select all the Network Adapter in the Select Networks window.
     
    d. After that, press F10 to start NetMon.
     
    e. Try to verify the trust to reproduce the issue, please copy a file from Windows 98 to Windows Server 2008 computer.
     
    f. After that, go back to the Netmon window and press F11 to stop the Netmon on the Windows Server 2008 computer.
     
    g. Press Ctrl+S to save the Netmon files.
     
    You may send the Netmon files to tfwst@microsoft.com
     
    Hope it helps.
    Monday, May 19, 2008 11:19 AM
  •  

    1. Yes, same subnet

    2. Yes, same domain

    3. Copy from 2008 to 98 works ok

    4. See email

     

     

    pc045 = windows98

    fs1 = windows2008

     

    packet 27-79 - opening explorer \\fs1\bup
    packet 80-128 - drag ape.jpg from pc045 desktop to \\fs1\bup
                            error: Cannot create or replace ape: the specified resource or device is no longer available.
    packet 129-131 - clicked OK on above error message box
    packet 132-210 - opened \\pc045\c from fs1

    packet 211-740 - copy setlac.pdf from fs1to \\pc045\c
    packet 860-917 - create folder \\fs1\userdata\newfolder from pc045 and renamed to 'test folder'
    packet 918-946 - open 'test folder' from pc045
    packet 947-997 - attempt to copy ape.jpg from pc045 to fs1
                     same message box pops up,  while the message box stays up, i can see ape.jpg on fs1, however I can not open the JPG file
                     once I click ok on message box, ape.jpg is removed from fs1

     

    -chris

    Monday, May 19, 2008 2:31 PM
  • Hi,
     
    Please verify that you have the proper permission to copy and write files on the target folder of Windows Server 2008.
     
    According to the captured file that you sent to me, it seems that it is not Netmon capture file, would you please follow my previous suggestion and save capture file to cap type and send me again?
     
    Thanks for your co-operation.
    Tuesday, May 20, 2008 10:24 AM
  •  

    Hey David,

     

    I got an Unknown Error when I tried to run a capture in NetMon3 on 2008 so I had to use Wireshark.

     

    Just rename the .NM2 file to .CAP and you'll be all set.

     

    The .WS file was from Wireshark.

     

    Thanks for your help,

    Chris

    Tuesday, May 20, 2008 1:39 PM
  • Hi Chris,
     
    According to the network monitor trace, we find that Windows 98 clients use "Write Raw" SMB command to try to write to file share on the Windows Server 2008 based computer. This command is used in Windows prior to Windows 2000 when the amount of data requested is >= 2* server reqbuf. As of Windows 2000, the redirector no longer uses Raw mode write, but uses Large Write. When SMB 2.0 is designed, it mainly focuses on support to Windows 2000 and above windows clients. However, both Vista and Windows Server 2008 use SMB 2.0 to copy files by default. It seems that Windows 98 is not compatible with SMB 2.0
     
    Based on the research, here is a registry key on Windows Server 2008 system to control the behavior of SMB 2.0, you may manually create the registry key on the server and set it to 0 to disable the SMB 2.0 to check if it helps.
     
    Steps:
     
    1. Run "regedit" on Windows Server 2008 based computer.
     
    2. Expand and locate the sub tree as follow.
     
    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters
     
    3. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)
     
    Value name: Smb2
    Value type: REG_DWORD
    0 = disabled
    1 = enabled
     
    4. Set the value to 0 to disable SMB 2.0
     
    5. Reboot the server.
     
    Afterwards, you may check if the issue will re-occur.
     
    Hope it helps.
    Thursday, May 22, 2008 9:50 AM
  • Excellent,  I will try this and let you know how it goes.

     

    What impact will disabling SMB2 have on my XP clients?

     

    -Chris

    Thursday, May 22, 2008 12:27 PM
  • Hi,
     
    It should be no impact to the Windows XP clients because they originally copy the file to Windows Server 2008 by using SMB 1.0 protocol.
     
    Hope it helps.
    Friday, May 23, 2008 6:03 AM
  •  

    Hello David,

     

    I made the suggested change by adding SMB2=0 to LanmanServer Parameters, rebooted the Server.  This did not help.

     

    Please check your email for capture (packet 79-128 is the file copy attempt).

     

    -chris

    Friday, May 23, 2008 1:16 PM
  • Hi,
     
    I have checked and compared the network monitor traces carefully.  Unfortunately, the network traces show that there are no behavior differences even after we manually configured Windows Server 2008 SMB 1.0. At this time, I am afraid that I have to say that Windows 98 is incompatible with Windows Server 2008 SMB. Thank you for your understanding.
     
    Considering that Windows 98 has been out of support boundary, if it is possible, I would like to suggest that you upgrade these legacy clients to newer operating system in order to get better support and performance.
    Monday, May 26, 2008 10:45 AM
  • Windows 98 does not support the SMB 2.0 protocol; however Windows Server 2008 does support the previous versions of SMB.  Basically the client and server will negotiate what is the highest version of the protocol that they both support and then use that version.  In the case of Win98 and Windows Server 2008 I believe these should work although Win98 is no longer officially supported. 

    Let me check with the test folks to see if Win98 was tested with Server 2008 and if yes, what configuration settings may need to be modified.  In some cases we change the defaults on the newer OS versions to disable features that are known security attack surfaces.  For these cases you may need to change something on the server to enable a feature that is needed to allow Win98 clients.
    Messages posted to this forum are provided "AS IS" with no warranties
    • Marked as answer by David Shen Monday, June 2, 2008 1:32 AM
    Friday, May 30, 2008 11:54 PM
  • Hi,

    I also face same problem with fixitchris, is it any solution?

    Thank you.
    Monday, August 25, 2008 10:00 AM
  • I am on the road, but I believe I know what is happening

    The first SMB sent is a Negotiate SMB and as part of the Negotiate and SessionSetup SMBs, the client and server exchange some capabilities. I do believe that the 2k8 server indicates it does NOT support Raw SMBs

    First thing to check would be the Ethereal/Wiresharks traces to see if the 2k8 server did in fact, indicate it did not support raw SMBs. If it did not, there is a regkey on 2k8 to change that behavior 

    To Disable Raw SMBs on the server in the Registry:

    1. Run Registry Editor (REGEDT32.EXE).
    2. From the HKEY_LOCAL_MACHINE subtree, go to the following key:
    \SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    3. From the Edit menu choose Add Value.
    4. Add the following:

     Value Name: EnableRaw Data Type: REG_DWORD Data: 0 
    If the 2k8 server did indicate it does not support raw SMBs, this is a bug in the Win98 client.

    Of course, this may simply take you to the next problem and not complete success

    Dilip
    www.msftmvp.com

    www.msftmvp.com
    Tuesday, August 26, 2008 1:53 AM
  • Hi,

    Thanks for ur reply. But i still facing same problem after change the registry. when i copy and paste a simple text file from Server 2008 to windows 98, the error "Cannot copy testing:The specified network resource or device is no longer available" occur.

    Thanks.
    Tuesday, August 26, 2008 4:29 AM
  • I'm having this problem too. This is seriously affecting me as some decoder cards from Toshiba were made for Windows 98 only. They worked fine up until I installed Server 200. You may not support 98 anymore but you definitely need to support legacy traffic. Have you come up with a solution for this yet?
    Tuesday, September 2, 2008 7:59 PM
  • Can you capture an ethereal or wiretrace and email it to dilipn at niriva dot com

    I need that info to get any further - I am also looking around for a Win98 client to repro this
    www.msftmvp.com
    Wednesday, September 3, 2008 12:50 AM
  • Hi,
    I just setup my first 2008 server and I have this very same problem. All 98 clients freeze up more or less whenever I access a share on the 2008 server. Has anyone found a solution for this and if so would you please share it with me?
    Many Thanks.
    Wednesday, October 8, 2008 2:01 PM
  • Hello all .
    Is there a solution ? I have the same problem and I'm looking around for weeks to resolve it.

    It's not clear if it's working at the end or not. If You can tell me that You can open files based on the server from the win98 client so it's a good message for me that there is the possibility and I have to check out why it doesn't work on my system.

    Thanks



    Thursday, October 30, 2008 8:51 PM
  • Hi,

    me too. I am experiencing the same problem as all others. Tried all suggestions, nothing helped. Unfortunately we cannot get rid of some remaining Win98 clients, because there is old important software on it that cannot be upgraded to newer Windows.

    Any suggestions are highly welcome.
    Monday, December 1, 2008 2:55 PM
  • Hi,

    i solved it with following configuration.

    On Windows 98 Client:

    1. Install IE6 SP1 on Win98.
    2. Install DSClient on Win98.
    On Windows Server 2008:

    1. SET SMB2 to "0"
    2. SET EnableRaw to "0"
    3. Check local Policy or if configured Domain Policy:
      Microsoft network client: Digitally sign communications (if server agrees) to "enabled"
      Microsoft network client: Digitally sign communications (always) to "disabled"
      Microsoft network server: Digitally sign communications (if server agrees) to "enabled"
      Microsoft network server: Digitally sign communications (always) to "disabled"
    4. Check the LMcompatibilitylevel on the Windows Server 2008. I set it to "2" --> only NTLM Response and everything is fine.
    mfg

    Thomas Helbig
    -----------------------------
    WEKO INFORMATIK GmbH
    • Proposed as answer by T.Helbig Thursday, April 22, 2010 5:34 AM
    Tuesday, December 30, 2008 1:06 PM
  • Hi,

    correction, testet on 04-21-2010, with Windows 2008R2 Workgroup no Domain:

    On Windows 98 Client:

    1. Install IE6 SP1 on Win98.
    2. Install DSClient on Win98.
    3. HKLM\System\CurrentControlSet\Control\LSA
      New DWORD: LMCompatibility   VALUE: 3
    On Windows Server 2008:

    1. SET SMB2 to "0"
    2. SET EnableRaw to "0"
    3. Check local Policy or if configured Domain Policy:
      Microsoft network client: Digitally sign communications (if server agrees) to "enabled"
      Microsoft network client: Digitally sign communications (always) to "disabled"
      Microsoft network server: Digitally sign communications (if server agrees) to "enabled"
      Microsoft network server: Digitally sign communications (always) to "disabled"
    4. Check the LMcompatibilitylevel on the Windows Server 2008. I set it to "2" --> only NTLM Response and everything is fine.
    mfg

    Thomas Helbig
    -----------------------------
    WEKO INFORMATIK GmbH
    Thursday, April 22, 2010 5:39 AM
  • The "SMB2" to zero step is not required

    Its just the part about disabling raw that is required -- step 2 Set EnableRaw to "0"


    www.msftmvp.com and VHD tools at www.VMUtil.com
    Friday, April 23, 2010 5:02 AM
  • Thank You.
    Tuesday, May 4, 2010 4:00 PM
  • I am having the same problem as everyone above.

     

    I have the following

    (2) Windows 2003 DCs running 2003 functional level

    (2) Windows 2008 file servers.

    On Windows 98 Client:

    1. Install IE6 SP1 on Win98.
    2. Install DSClient on Win98.

    On Windows Server 2008:

    1. SET SMB2 to "0"
    2. SET EnableRaw to "0"
    3. Security Policy settings
      Microsoft network client: Digitally sign communications (if server agrees) to "enabled"
      Microsoft network client: Digitally sign communications (always) to "disabled"
      Microsoft network server: Digitally sign communications (if server agrees) to "enabled"
      Microsoft network server: Digitally sign communications (always) to "disabled"
    4. Check the LMcompatibilitylevel on the Windows Server 2008. I set it to "1"

    I've also configured the following reg key

    HKLM\System\CurrentControlSet\Services\lanmanserver\parameters\enableW9xsecuritysignature  (1)

     All issues that I've seen dealing with this have been SMB version issues and Digitally Signed SMB info. I am stumped because the users can access the files but it is slow. Also the Win98 machines can access Win 2003 shares with no problem. This issue is on all 98 clients on all subnets.

     The WinXP machines have no issues.

     

    Do I need to put the following reg key on all 98 machines for it to speed up?

     HKLM\System\CurrentControlSet\Control\LSA
    New DWORD: LMCompatibility   VALUE: 3

     

    Thanks

     

    Bobbie

     

     

    Tuesday, September 28, 2010 5:03 PM