none
Group Policy Delay

    Question

  • Hello Guys,
     
    Im facing a problem with Windows Group Policy Processing Time / Delay.
    Just to explain more, I have a Group Policy with many configurations to apply, including Folder Redirection, Network Drive Mapping and some Citrix components.
     
    When a user Log into a machine, all configuration are applied but just one not, The SSON in the Citrix Store to load the published application.
    But if I run a GPUPDate /Force, logoff and login again, the policy is processed succesfully and my shortcuts are created.
     
    Do you have any idea what I can do?
     
    Thank you.
     
    Regards,
     
    Daniel
    Wednesday, September 9, 2015 9:34 PM

All replies

  • Hi Daniel Felipe,

    Thanks for your post.

    For group policy delay, you could refer to the article blow. It list what we can do that cause large impact to logon speed and group policy processing.

    Group Policy and Logon Impact

    http://blogs.technet.com/b/grouppolicy/archive/2013/05/23/group-policy-and-logon-impact.aspx

    Here is the action we need to consider.

    Avoid synchronous CSEs and don’t force synchronous policy, or if CSE usage is necessary, minimize changes to these policies.
    Avoid costly WMI filters such as LDAP queries.
    Look for costly scripts by running them in isolation, and work to improve the scripts’ performance or avoid these scripts.

    If you need to use security group filters. Please also check the article.

    https://support.microsoft.com/en-us/kb/2561285

    And in your scenairo,  you apply the group policy on SSON in the Citrix Store to load the published application. Do you use Group Policy Software Installation Extension or the policy you add from Citrix? Since I'm not familiar with Citrix, it may be also relate to the setting of Citrix. In addition, I suggest you could post in Citrix Forum.

    Best Regards,

    Mary Dong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 10, 2015 4:51 AM
    Moderator
  • Hi Mary,

    For the Citrix policies, I just added a template into the GPMC and apply the configurations.

    I tried to separate the users and computer configurations but still not applying.

    The most stranger is all others configurations are applied, just the Single Sign On and the desktop image is not applied.

    As I said, the desktop wallpaper I cannot see, but when I open the Start Menu, I can see in the Desktop Title.

    And the single sign on works after the gpupdate /force.

    Any other idea?

    Or how can I check some logs?

    THanks.

    Sunday, September 13, 2015 5:31 PM
  • Also, I dont have any WMI or LDAP filters. I just enabled the loopback processing.
    Sunday, September 13, 2015 5:35 PM