none
App Fabric Caching Service Problem and User Profile Synchronization not starting

    Question

  • Hi,

    I am stuck from long days, when try to start the Cache service using power shell command i got the below error- 

    Start-CacheHost : Error occurred while performing the operation on host
    Myserver:22233 :
    ErrorCode<ERRCAdmin003>:SubStatus<ES0001>:Time-out occurred on
    net.tcp://Myserver:22233.
    At line:1 char:1
    + Start-CacheHost
    + ~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Start-CacheHost], DataCacheEx
       ception
        + FullyQualifiedErrorId : ERRCAdmin003,Microsoft.ApplicationServer.Caching
       .Commands.StartCacheHostCommand

    and also tried to start the User Profile Synchronization Service always stuck on starting.

    I search lot and did various steps according to forms. But still i am stuck and and not able to start these two services in sharepoint 2013.

    Please help me.

    Thanks in advance.

    Monday, April 17, 2017 6:09 AM

All replies

  • In general you should be using the Distributed Cache interface within SharePoint to start/stop Distributed Cache on a SharePoint server. Using the AppFabric cmdlets is not recommended.

    See Manage the Distributed Cache service in SharePoint Server 2013 for instructions for starting a Distributed Cache host.


    • Edited by Jason Warren Monday, April 17, 2017 5:10 PM fixed sentence
    Monday, April 17, 2017 5:09 PM
  • Hi Jason,

    Thanks for reply. I already did all these steps , but still not working.

    Wednesday, April 19, 2017 5:44 AM
  • Hi RAJESH KUMAR RANJAN,

    Please follow the steps to troubleshoot your issue:

    Go to Start -> Run -> services.msc, make sure AppFabric Caching Service is running.

    Make sure  the service account you run distributed cache service is in the local administrator group.        

    Make sure the account which run User profile Synchronization service is in local administrator group.

    Check the ULS log to find more detailed error message, ULS log locates at:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 19, 2017 11:23 AM
  • Hi Grace,

    I checked every thing,user already in Local Admin Group.

    I got Error -

    AppFabric Caching service crashed with exception {Microsoft.ApplicationServer.Caching.DataCacheException: ErrorCode<ERRService0001>:SubStatus<ES0001>:Service initialization failed. No user action required.
       at Microsoft.ApplicationServer.Caching.DistributedObjectManager..ctor(EndpointID[] urisDOM, ServiceConfigurationManager configurationManager, WcfServerChannel channel)
       at Microsoft.ApplicationServer.Caching.DistributedObjectManager.GetInstance(EndpointID[] urisDOM, ServiceConfigurationManager configurationManager, WcfServerChannel channel)
       at Microsoft.ApplicationServer.Caching.ServiceLayer.ServiceStart(Boolean deleteTkt)
       at Microsoft.ApplicationServer.Caching.DataCacheServiceBase.ServiceStart(ServiceConfigurationManager scm, Boolean deleteTkt)
       at Microsoft.ApplicationServer.Caching.VelocityWindowsService.StartService(Boolean deleteTKT)
       at Microsoft.ApplicationServer.Caching.VelocityWindowsService.StartServiceCallback(Object context)
       at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
       at System.Threading.ThreadPoolWorkQueue.Dispatch()}. Check debug log for more information 

    Wednesday, April 19, 2017 12:30 PM
  • Hi RAJESH KUMAR RANJAN,

    According your error message, try to follow the steps in the similar post below to alter the default distributed cache service configuration and manually set a smaller cache size as a workaround:

    http://codebender.denniland.com/sharepoint-server-2013-issue-appfabric-distributed-cache-service-crashes/

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 19, 2017 12:39 PM
  • Hi Grace,

    I following all these steps mention in above url. when we try to run  Start-CacheCluster command, we got the below error - 

    Start-CacheCluster : ErrorCode<ERRCAdmin003>:SubStatus<ES0001>:Time-out
    occurred on net.tcp://server.local:22233.
    At line:1 char:1
    + Start-CacheCluster
    + ~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Start-CacheCluster], DataCach
       eException
        + FullyQualifiedErrorId : ERRCAdmin003,Microsoft.ApplicationServer.Caching
       .Commands.StartCacheClusterCommand

    after that we run the command Get-CacheHost, we got the below output

                                                                         

    HostName : CachePort           Service Name            Service Status Version
                                                                          Info
    --------------------           ------------            -------------- ---------
    server.local:22233 AppFabricCachingService DOWN           3 [3,3][1 ,3]

    Thursday, April 20, 2017 9:32 AM
  • Check this blog for troubleshooting DC. You might need to remove your zombie DC and re-provision again :)

    https://blogs.msdn.microsoft.com/sambetts/2014/03/19/sharepoint-2013-distributed-cache-appfabric-troubleshooting/ 

    Hope this helps.

    Thursday, April 20, 2017 4:27 PM
  • Hi Asfaw,

    Thanks for reply. I checked the blog, but still problem not resolved. My Database server on Clustering.Working on Dev and UAT environment but not on Production server.

    Please help me.we are stuck from long time.

    Tuesday, April 25, 2017 7:47 AM