none
Unable to install R Client RRS feed

  • Question

  • Hi folks,

    I have downloaded R Client and I had the error below, I have already installed the SQL server 2016 with R Service and Microsoft R Open ...

    Please help

    Windows ® Installer. V 5.0.10586.0
    msiexec /Option <Required Parameter> [Optional Parameter]
    Install Options
     </package | /i> <Product.msi>
      Installs or configures a product
     /a <Product.msi>
      Administrative install - Installs a product on the network
     /j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
      Advertises a product - m to all users, u to current user
     </uninstall | /x> <Product.msi | ProductCode>
      Uninstalls the product
    Display Options
     /quiet
      Quiet mode, no user interaction
     /passive
      Unattended mode - progress bar only
     /q[n|b|r|f]
      Sets user interface level
      n - No UI
      b - Basic UI
      r - Reduced UI
      f - Full UI (default)
     /help
      Help information
    Restart Options
     /norestart
      Do not restart after the installation is complete
     /promptrestart
      Prompts the user for restart if necessary
     /forcerestart
      Always restart the computer after installation
    Logging Options
     /l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
      i - Status messages
      w - Nonfatal warnings
      e - All error messages
      a - Start-up of actions
      r - Action-specific records
      u - User requests
      c - Initial UI parameters
      m - Out-of-memory or fatal exit information
      o - Out-of-disk-space messages
      p - Terminal properties
      v - Verbose output
      x - Extra debugging information
      + - Append to existing log file
      ! - Flush each line to the log
      * - Log all information, except for v and x options
     /log <LogFile>
      Equivalent of /l* <LogFile>
    Update Options
     /update <Update1.msp>[;Update2.msp]
      Applies update(s)
     /uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
      Remove update(s) for a product
    Repair Options
     /f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
      Repairs a product
      p - only if file is missing
      o - if file is missing or an older version is installed (default)
      e - if file is missing or an equal or older version is installed
      d - if file is missing or a different version is installed
      c - if file is missing or checksum does not match the calculated value
      a - forces all files to be reinstalled
      u - all required user-specific registry entries (default)
      m - all required computer-specific registry entries (default)
      s - all existing shortcuts (default)
      v - runs from source and recaches local package
    Setting Public Properties
     [PROPERTY=PropertyValue]
    Consult the Windows ® Installer SDK for additional documentation on the
    command line syntax.
    Copyright © Microsoft Corporation. All rights reserved.
    Portions of this software are based in part on the work of the Independent JPEG Group.

    Thursday, June 16, 2016 6:04 AM

Answers

  • I got it working.  I went to the log file which had this:

    2016-07-19T01:50:42 INFO Extracting resource %TEMP%\RClientSetup_Cache\RClient.msi
    2016-07-19T01:50:42 INFO Reading registry value HKLM\SOFTWARE\Microsoft\R Client\ProductCode
    2016-07-19T01:50:42 INFO Registry value:
    2016-07-19T01:50:42 INFO Installing R Client
    2016-07-19T01:50:42 INFO Running command: msiexec /i %TEMP%\RClientSetup_Cache\RClient.msi /log "%TEMP%\RClient_20160718095042.log"
    2016-07-19T01:50:47 ERROR Install failed

    I then went to that %TEMP%\RClientSetup_Cache directory, and clicked on the RClient.msi file, and it ran and installed...

    • Marked as answer by JohnnyKahWang Monday, August 29, 2016 9:47 AM
    Tuesday, July 19, 2016 2:22 AM

All replies

  • looking forward to the answers...
    Saturday, June 18, 2016 7:39 AM
  • I'm encountering the same issue. Any solutions yet?
    Wednesday, July 6, 2016 9:26 AM
  • Hey,

    I have the same issue. I have a fresh win10 installation, only VS2015 Community and same other programmes are installed.

    If I start the installer, only the window from msiexec is opening.

    Thanks for help. 

    Wednesday, July 13, 2016 5:49 PM
  • I got it working.  I went to the log file which had this:

    2016-07-19T01:50:42 INFO Extracting resource %TEMP%\RClientSetup_Cache\RClient.msi
    2016-07-19T01:50:42 INFO Reading registry value HKLM\SOFTWARE\Microsoft\R Client\ProductCode
    2016-07-19T01:50:42 INFO Registry value:
    2016-07-19T01:50:42 INFO Installing R Client
    2016-07-19T01:50:42 INFO Running command: msiexec /i %TEMP%\RClientSetup_Cache\RClient.msi /log "%TEMP%\RClient_20160718095042.log"
    2016-07-19T01:50:47 ERROR Install failed

    I then went to that %TEMP%\RClientSetup_Cache directory, and clicked on the RClient.msi file, and it ran and installed...

    • Marked as answer by JohnnyKahWang Monday, August 29, 2016 9:47 AM
    Tuesday, July 19, 2016 2:22 AM
  • hey Buddy, this works on my side as well, so it is really weird we need to do this. Do you have any idea that anything have the original installation blocked?
    Monday, August 29, 2016 9:47 AM
  • Hi,

    I followed these steps and the installation began. However, it stopped in the middle, when it's done with downloading R files. Does anyone know what causes it? I've already been waiting 2 hours and I don't see any progress. I'm trying to install it on Windows 10.

    Thursday, October 27, 2016 1:02 PM
  • Hi,

    I followed these steps and the installation began. However, it stopped in the middle, when it's done with downloading R files. Does anyone know what causes it? I've already been waiting 2 hours and I don't see any progress. I'm trying to install it on Windows 10.

    I have the same problem, it got stuck in the middle of the process without progressing.

    what should I do now?

    Monday, December 5, 2016 1:00 PM