locked
Redirected Libraries Unsharable in Homegroup RRS feed

  • Question

  • Hello, 

    I'm a long time sysadmin.  I have my standard user libraries on my D drive rather than C.  I used the built in redirection capability in the 'location' tab of each library item (such as My Documents) to move the folders to my second drive.  Here's the problem:

    Since redirecting my libraries, I can't share them over my HomeGroup.  When I go into HomeGroup settings and check Documents (for instance), then select OK, when I go back in to the HomeGroup settings, Documents isn't checked.  (NOTE: I went to another computer that didn't have redirected library folders and performed the same operation successfully, so it's not a matter of education.)  I was able to share my D:\users\me\my documents folder manually to the HomeGroup, but I lose type discovery functionality on other devices, such as my new wonderful Microsoft Surface Pro 128, when I use this method.  Does anyone know a workaround to this bug?

    PLEASE, with all due respect, no cookie cutter responses after half reading this post.  Brainstorming and conversation on the topic would be helpful, but you KNOW I don't need to post my DXDIAG or something else that just gives you a point for posting.  Someone who knows the solution will eventually come along.

    Thanks,

    Shawn


    ShawnBurton

    Wednesday, May 15, 2013 3:40 PM

Answers

  • Since redirecting my libraries, I can't share them over my HomeGroup
    Sorry, sounded like Homegroup was enabled before changing folder locations.

    Out of interest, does your redirected Documents folder have a Location tab in it's right click -> Properties window ?

    As you say, you could try repeating the process but as an alternative you could try:

    1. Disable sharing of folders on the Homegroup.
    2. Restore default folder locations (try option 2 in the link below if location tab not present)
    http://www.sevenforums.com/tutorials/18583-user-folders-restore-default-location.html
    3. Include/add folders to the libraries
    http://www.sevenforums.com/tutorials/585-library-include-folder.html
    4. In the "Change how this library gathers its contents" window (Option 2 in the link above), right click on a folder to choose to set as default save location.
    5. Manually move sub-folders/files into new default save location
    6. Enable sharing of folders on the Homegroup

    • Marked as answer by Cloud_TS Friday, June 7, 2013 1:48 AM
    Friday, May 17, 2013 2:39 AM

All replies

  • Please see Option 2 in this guide for changing user folders location.

    http://www.sevenforums.com/tutorials/18629-user-folders-change-default-location.html

    Note that Step 1 involves disabling sharing of the folder on the homegroup and Step 14 enables sharing of the folder again on the homegroup.
    Wednesday, May 15, 2013 11:06 PM
  • Thank you mystified.. good guide.  Are you suggesting that I redirect my library folders back to the default locations, enable then disable HomeGroup sharing to these libraries, then move the redirection back to the secondary drive?  I didn't have Homegroups enabled at all when I did the redirection..

    ShawnBurton

    Thursday, May 16, 2013 7:23 PM
  • Since redirecting my libraries, I can't share them over my HomeGroup
    Sorry, sounded like Homegroup was enabled before changing folder locations.

    Out of interest, does your redirected Documents folder have a Location tab in it's right click -> Properties window ?

    As you say, you could try repeating the process but as an alternative you could try:

    1. Disable sharing of folders on the Homegroup.
    2. Restore default folder locations (try option 2 in the link below if location tab not present)
    http://www.sevenforums.com/tutorials/18583-user-folders-restore-default-location.html
    3. Include/add folders to the libraries
    http://www.sevenforums.com/tutorials/585-library-include-folder.html
    4. In the "Change how this library gathers its contents" window (Option 2 in the link above), right click on a folder to choose to set as default save location.
    5. Manually move sub-folders/files into new default save location
    6. Enable sharing of folders on the Homegroup

    • Marked as answer by Cloud_TS Friday, June 7, 2013 1:48 AM
    Friday, May 17, 2013 2:39 AM
  • Hi,

    I am just writing to check the status of this thread. Was the information provided in previous reply helpful to you? Do you have any further questions or concerns? Please feel free to let us know.

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, May 20, 2013 1:05 AM
  • Hi,

    Having the exact same issue with both my 8.1 Pro systems. I redirected C:\Users\Public\Documents, ..\Music, ..\Pictures, & ..\Videos to my D: drive and restarted. I enabled Homegroup there after.

    #1 The new locations updated in the Libraries (Explorer) however, Windows Media Player is in a perpetual state of reverting back to the default Public folder locations despite many attempts of manually setting Library (Media Player) paths to D:.

    #2 My other device cannot join this computers Homegroup. It acts like it wants to then prompts an error the Homegroup is no longer available. Very odd...

    Feels like a bug inside Homegroup Sharing and handling of folder redirection. Keeping my fingers crossed this can be fixed else I'll go the recommended solution route. Thanks.

    Tuesday, October 29, 2013 1:49 AM