none
File creation GPO fails with "Access Denied" in event log

    Question

  • I have 3 policies in a GPO - Create/Update/Replace - defined in:

    User Configuration/Preferences/Windows Settings/Files

    Source: \\contoso.com\shares\Creative\stock_art\test\test.potx

    Destination: C:\test

    My test user has full access to C:\test and \\contoso.com\shares\Creative\stock_art\test\test.potx

    No other options are defined in the GPO.

    I have the following error in the event log, repeated once each for Create/Update/Replace, and the file does not appear in C:\test:

    The user 'test' preference item in the 'Test - Template {DA4A568B-952D-40C7-80FF-7FA0484A8B8B}' Group Policy Object did not apply because it failed with error code '0x80070005 Access is denied.' This error was suppressed.

    If I go to the test workstation, log on as that test user, I'm able to run this command successfully:

    C:\user\test> copy \\contoso.com\shares\Creative\stock_art\test\test.potx C:\test

    If I am able to manually copy this file, why does the event log say access denied? 


    • Edited by TC610 Thursday, February 25, 2016 3:53 PM ETA clarity
    Thursday, February 25, 2016 3:53 PM

Answers

  • > Destination: C:\test
     
    AFAIK if the destination is a folder, you need to append a \ - otherwise
    GPP tries to create a file "test", and since a folder with that name
    already exists...
     
    • Marked as answer by TC610 Thursday, February 25, 2016 7:16 PM
    Thursday, February 25, 2016 4:02 PM
  • Hi,
     
    Am 25.02.2016 um 16:53 schrieb TC610:
    > Source: \\contoso.com\shares\Creative\stock_art\test\test.potx
    > Destination: C:\test
     
    Destination: C:\test\test.potx
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    • Marked as answer by TC610 Thursday, February 25, 2016 7:16 PM
    Thursday, February 25, 2016 5:33 PM

All replies

  • > Destination: C:\test
     
    AFAIK if the destination is a folder, you need to append a \ - otherwise
    GPP tries to create a file "test", and since a folder with that name
    already exists...
     
    • Marked as answer by TC610 Thursday, February 25, 2016 7:16 PM
    Thursday, February 25, 2016 4:02 PM
  • I read another article that said I needed to give "Authenticated Users" access to the share.  I did that and followed your advice and added the ending backslash.  I no longer get the access denied errors, but I still don't see the file in C:\test\.
    Thursday, February 25, 2016 4:10 PM
  • Hi,
     
    Am 25.02.2016 um 16:53 schrieb TC610:
    > Source: \\contoso.com\shares\Creative\stock_art\test\test.potx
    > Destination: C:\test
     
    Destination: C:\test\test.potx
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    • Marked as answer by TC610 Thursday, February 25, 2016 7:16 PM
    Thursday, February 25, 2016 5:33 PM
  • Oops, that's what I was missing.  Thanks for the help.
    Thursday, February 25, 2016 7:16 PM
  • Am 25.02.2016 um 20:16 schrieb TC610:
    > Oops, that's what I was missing.  Thanks for the help.
     
    sadly the GPP Files is not that simple and easy to use as copy or xcopy
    :-(
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Friday, February 26, 2016 8:29 AM
  • Hi,

    I am glad to hear that you have solved the problem.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 26, 2016 8:57 AM
    Moderator