locked
Companyweb does not open in IE RRS feed

  • Question

  • I am running SBS2008 and Companyweb is working fine for all users and PC's except for 2 or three home users.

    The PC's are windows 7 with IE 9. The computers used to be in the company office and worked fine. They have now been transferred to the users homes and they use the Cisco SSL VPN client to connect to the office network.If they open IE and browse to http://companyweb they get the following screen.

    Internet explorer cannot display the web page

    If I enter the same address into Chrome, it works, the companyweb page appears and they can browse and download files.

    I can't understand why it works in Chrome and not IE. It's like something in IE is blocking it.

    The pc can resolve the ip for companyweb. I have cleared IE history, cookies, etc and added the companyweb site to the trusted sites zone but still the same result.

    If I use the IE Tab add in for Chrome, it still does not work. This has got me completely baffled. Any ideas would be greatly appreciated.

    John

    Friday, September 6, 2013 7:37 AM

Answers

  • Hi:

    No explanation except for the usual "if then else" settings in IE.   Try compatabilty mode as well as the other settings you have tried.

    Can you confirm the following:

    From the router you must forward port 987 to the IP of the SBS in order to access Company Web.  If the port is correctly forwarded, you should be able to enter the same URL you enter for RWW  ie  https://remote.domainname.com and then add :987 so it looks like  https://remote.domainname.com:987/    

    Do you have a trusted third party SSL cert for this SBS, or a self signed?  If self signed, be sure to install it on the remote computers.


    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.



    • Edited by Larry Struckmeyer Saturday, September 7, 2013 12:44 AM spelling
    • Marked as answer by Andy Qi Sunday, September 22, 2013 6:51 AM
    Saturday, September 7, 2013 12:41 AM
  • If companyweb doesn't work across the VPN then it is something the with VPN not companyweb. I would suggest you need to check the gateway of the VPN and see whether it is using the correct IP address. To allow companyweb resolution it needs to use the DNS of the SBS server where the companyweb records is maintained. if it is using an internet based DNS service then it will never find companyweb.

    You could also over write the DNS with an entry for companyweb in you HOSTS file if that proves easier. What happens if you browse to https://sites:987?

    You may also want to look at dumping all the IE history and cache to see whether than make a difference. Also, what does ping and tracert return? if they return the correct IP of companyweb then IE seems to be the issue. When they use the VPN do they also authenticate to SBS? Can they get to file shares the the like? Maybe the VPN client is mucking up the IE integrated authenication during the process?


    Thanks Robert Crane [MVP-Office365] www.ciaops.com


    • Edited by directorciaMVP Tuesday, September 17, 2013 11:56 PM
    • Marked as answer by Andy Qi Sunday, September 22, 2013 6:51 AM
    Tuesday, September 17, 2013 11:51 PM

All replies

  • Hi:

    No explanation except for the usual "if then else" settings in IE.   Try compatabilty mode as well as the other settings you have tried.

    Can you confirm the following:

    From the router you must forward port 987 to the IP of the SBS in order to access Company Web.  If the port is correctly forwarded, you should be able to enter the same URL you enter for RWW  ie  https://remote.domainname.com and then add :987 so it looks like  https://remote.domainname.com:987/    

    Do you have a trusted third party SSL cert for this SBS, or a self signed?  If self signed, be sure to install it on the remote computers.


    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.



    • Edited by Larry Struckmeyer Saturday, September 7, 2013 12:44 AM spelling
    • Marked as answer by Andy Qi Sunday, September 22, 2013 6:51 AM
    Saturday, September 7, 2013 12:41 AM
  • I would perhaps suggest that IE has an incorrect proxy address. Try checking that in the settings for IE.


    Thanks Robert Crane [MVP-Office365] www.ciaops.com

    Thursday, September 12, 2013 5:02 AM
  • Firstly, sorry for taking so long to respond. Thanks for your answers but I still have the problem.

    There is no proxy and there is no proxy settings in IE.

    I have discovered the following.

    1. the pc was originally located in the same office as where SBS is located

    2. the user logs onto the pc with their domain account and successfully accesses companyweb while the pc is in the office

    3. the pc is then removed from the office to the users home

    4. the user logs onto the pc, connects to the company vpn using the Citrix SSL VPN client 

    5. gets the ie error when trying to access companyweb via ie. Is able to access companyweb via chrome. Unable to access companyweb if running the IE addon in chrome

    6. if user never accessed companyweb while the pc was in the office, they don't get the IE error

    I know, its weird but I can't figure it out.

    John

    Tuesday, September 17, 2013 5:54 AM
  • If companyweb doesn't work across the VPN then it is something the with VPN not companyweb. I would suggest you need to check the gateway of the VPN and see whether it is using the correct IP address. To allow companyweb resolution it needs to use the DNS of the SBS server where the companyweb records is maintained. if it is using an internet based DNS service then it will never find companyweb.

    You could also over write the DNS with an entry for companyweb in you HOSTS file if that proves easier. What happens if you browse to https://sites:987?

    You may also want to look at dumping all the IE history and cache to see whether than make a difference. Also, what does ping and tracert return? if they return the correct IP of companyweb then IE seems to be the issue. When they use the VPN do they also authenticate to SBS? Can they get to file shares the the like? Maybe the VPN client is mucking up the IE integrated authenication during the process?


    Thanks Robert Crane [MVP-Office365] www.ciaops.com


    • Edited by directorciaMVP Tuesday, September 17, 2013 11:56 PM
    • Marked as answer by Andy Qi Sunday, September 22, 2013 6:51 AM
    Tuesday, September 17, 2013 11:51 PM
  • Again sorry for taking so long to reply. The VPN is not the problem. We have 20 other staff using the VPN to connect and they do not get this issue.

    The affected machines can successfully resolve and ping companyweb across the VPN.

    They can access all other resources across the VPN.

    They just cannot get to the companyweb home page from IE. They can get to Companyweb home page using Chrome.

    I have dumped the history and the cache but it hasn't made a difference.

    Looks like I will have to give up on this one.

    Thanks for everyones input.

    John

    Tuesday, September 24, 2013 6:54 AM