locked
Report Parts auto accept changes RRS feed

  • Question

  • Hi all,

    Just a quick question. We plan to utilize report parts fairly significantly as an alternative to Sub-reports as it will let our clients leverage the parts and create their own stuff.

    Is there any way to automate the "check for updates" that happens every time you load report builder? For example if i change a report part and i have used it in 20 reports, i don't want to have to open report builder 20 times, although i could it's rather painful approach.

    Is there any way to automate the updating of this? Our idea was to script something to take the report out of the catalog table, decode the body, find the start and end tags for the report part, replace with the new report part... The idea is sound but it would be a bit of work to implement it.

     

    Thanks!

    Friday, October 14, 2011 4:15 PM

All replies

  • Hi boris37,

    A workaround without complex script:

    1.To turn on and off report part updates

    • Click the Report Builder button, and then click Options.
    • In the Options dialog box, on the Resources tab, select or clear the Show updates to report parts in my reports check box.

    2.The Report element has an AutoRefresh property. Set its value to 30 and the report should auto-refresh every 30 seconds.

    Thanks,
    Lola


    Please remember to mark the replies as answers if they help.
    Monday, October 17, 2011 9:25 AM
  • Hmm nope i tried that and it won't work. Even if i regenerate the report it won't do anything different. If i manually check for updates in report builder though it will update properly.

    I even put &rs:ClearSession=true to make sure the session was cleared but it still didn't want to do anything. The report runs quickly so i can't confirm it was refreshing but regenerating the report should have the same effect right? The changes don't take effect until after i load report builder, check for changes to the parts and save and then go back to reload the report.

    Am i just potentially doing something wrong?

    Thanks,


    • Edited by boris37 Monday, October 17, 2011 4:47 PM
    Monday, October 17, 2011 4:07 PM