locked
Windows 10 thinks .xls files are Adobe Acrobat Documents RRS feed

  • Question

  • I have a new laptop with latest Windows 10 (installed and updated today) and latest Office 365 (installed today). I am trying to open .xls files sent to me in an email. They will not open.  When I save them it says they are Adobe Acrobat Documents. I went to Setting to try to associate Excel with the .xls extension and in the list it has this extension listed as Adobe Acrobat Documents and will not allow Excel to be associated.

    Thursday, March 16, 2017 12:27 AM

All replies

  • Try the old-fashioned way...........

    Search bar, type control panel > Enter > top right, click View by > select either Small or Large > click Default programs > click Associate a file type or protocol with a program > left side, scroll down to .xls > click it > if it says Adobe Acrobat under Current Default, top right, click Change Programs > do you see Microsoft Office Excel listed ?

    If yes, click it and click OK.

    What that does is to make Excel as the default program to open .xls and xlsx files.

    Try to open your xls file again.




    • Edited by david hk129 Thursday, March 16, 2017 12:46 AM
    Thursday, March 16, 2017 12:44 AM
  • I tried that. It will not allow Excel to be associated with .xls. Only Adobe, Internet Explorer, or search for app's in store.
    Thursday, March 16, 2017 1:21 AM
  • Do you have Open With right click context menu installed ?

    If no, use this tutorial. Very simple and quick to do.
    https://www.tenforums.com/tutorials/33975-open-context-menu-add-remove-windows-10-a.html

    If you have it installed > go to your xls file > right click at it > click Open With > is Microsoft Office Excel on the list ?
    If yes, click it .

    If no, at the bottom, click Choose another app > locate Microsoft Office Excel > click it > check the box "Always use this app...." > click OK when done.

    Try open the xls file.





    Thursday, March 16, 2017 1:31 AM
  • Was that xls or xsl - xsl does not give Excel as an option but is the wrong format. Try again with xls
    Wednesday, May 9, 2018 8:27 AM