locked
SpeedTouch 330 Vista driver RRS feed

All replies

  • Thomson SpeedTouch 330 VISTA drivers

    Try the following, it works fine: http://www.btopenworld.com/drivers

    click link 'Latest modem drivers for BT Broadband products'
    then see the 'patches' section

    Unzip the files, connect your modem and run the 'setup.exe' within VISTA.

    Enjoy.

    Thursday, February 8, 2007 7:40 AM
  • Hmm... sounds good Mia Mama... I wonder if it'll work on x64 bit...

    ..be back later...
    Friday, February 9, 2007 7:41 PM
  • Nope. Not for me. Maybe I should sign up for BT Openworld lol.

    Doesn't even look easily configurable if you don't really know what you're doing...
    No green lights on the modem, just the one red light..
    Control Panel, etc, just mentions PPP0E and no sign anywhere of PPP0A...


    At the end of install I got the "The connection to the internet is ready to use" but the BT Desktop icon is very offputting, particularly if you are trying to reach a different ISP, lol.

    Nice to see a Major isp actually creating driver's for it though. Maybe is just a matter of time...



    Friday, February 9, 2007 10:32 PM
  • Same problem with me.  Vista has something against PPPoA connections :)

    It installs fine with me (and hear this, when I try to uninstall, it says I don't have the authority.  I AM THE ONLY USER :D )

    So i get both green lights, and the diagnostic says its working and syncronized.  The problem shows when it tries to create the connection.  It freezes, and windows takes over saying the app is not working.

    Anyone found any solution yet?

    Sunday, February 18, 2007 4:58 PM
  • I'll tell you what, I found a Router on ebay for £1.20 plus £4 postage and I'm sailing on the internet in Vista.

    It's a bit of a learning curve if you don't know anything about Routers but at least I got free of the shackles of SpeedTouch. Tiscali Help Desk told me that Routers don't need the software like the usb modems do and, by jingo, she's right!!
    Wednesday, February 21, 2007 3:32 PM
  • i hooked up my xp machine and downloaded the xp driver (not 64bit, that didn't work) onto disk and installed it on my vista laptop, works fine for me.
    Saturday, February 24, 2007 12:46 PM
  • The UK site now has a beta release that you can order on a CD.  They don't have it posted on their website though.  Does anyone know where to download it from?

    http://www.speedtouch.co.uk/codepages/content3.asp?c=7&ProductID=471

     

     

    Friday, March 9, 2007 11:20 AM
  • i had same problem in vista i troed many solution but ...!!! nothing could work properly :(

    what to do else??

    Tuesday, March 20, 2007 9:44 AM
  • You can download the drivers from here:

    http://jadeallen.com/toms/index.asp?DoAction=ReadDay&ID=386
    Tuesday, March 20, 2007 10:34 AM
  • Hey guys. I have been having the same problem and tried every suggestion on this page (except for buying a router). So here is how I got it working.

     

    Copy and paste everything from the "Drivers" folder on Tiscali's CD into C:\Windows\System32\Drivers on your pc/laptop. Then try installing it via the normal route (i.e. sticking the cd in). It will probably fail; if it does, go to the desktop and right click on "My Computer" then select "Manage". Then select "Device manager" and look for Speedtouch 330 (might be under USB or Modem). Right click and select "Enable". This should then sort it.... (hopefully). Sorry if it doesn't. I thought it would be worth giving one more route to try anyway.

     

    Ed

    Saturday, March 24, 2007 7:19 PM
  • I thought I was the only one having this problem at least there are several of us!

     

    I am just trying to work out who is the dumbo in all this. Is it Microsoft for their obtuse, half baked operating system that is totally obscure, Thomson who can't be bothered to make their drivers readily available, I tried their web site and there was no inkling of the modified driver, or me for falling yet again for a poorly written operating system where  I do the Beta testing for Msoft having paid THEM good money for the 'privilege'?

    I am taking the easy and obvious way out, I am ditching Vista at the very least until it has been sorted and others have lost sleep over it.

    Wednesday, April 4, 2007 11:31 PM