locked
IE 10 Javascript does not work at all. RRS feed

  • Question

  • Hello, 

    IE refuses to execute javascript on my computer: If I go to a page were is simple javascript alert function, messagebox will not show - nothing happens. If I use Chrome on the same page, it work. Then if I click 'Properties' on ANY web page, I get scripting error popup. Javascript debugger tells me that:

    res://ieframe.dll/docppg.ppg : <BODY onload="BodyLoad()" Type MisMatch error. 

    I tried resetting IE Settings to default and I uninstalled and reinstalled IE couple of times

    I think I had this error on IE9 as well, so updating did not help. 

    What could be the problem?? Win7 x64 

    Wednesday, November 6, 2013 1:15 PM

Answers

  • IE refuses to execute javascript on my computer: 

    Other users having this symptom turned out to be Dell owners who had residual McAfee interference.  Apparently the designed uninstall for the built-in product is not sufficient and that makes it necessary to seek out a clean-up program.

    FYI



    Robert Aldwinckle
    ---

    • Marked as answer by Cloud_TS Monday, November 25, 2013 1:35 PM
    Saturday, November 23, 2013 11:14 PM
    Answerer

All replies

  • Hi,

    It would be kind of you to let us konw the problematic website for test.

    Based on you description, I think you can try the following suggestions:

    1. Check the add-ons. Open Internet Explorer, on the Tools menu, click Manage add-ons>Show all add-ons, locate and enable the java RTE add-ons

    2. Deselect the “Automatically Detect Settings” to check how it works.

    And enable the scripting of Java applets settings:

    a. Click "Tools" --> "Internet Options" 

    b. Next, select the Security Tab, and select the "Custom Level" button

    c. Scroll down to "Scripting of Java applets"

    d. Make sure the "Enable" radio button is checked.

    e. Click OK to save your preference.

    3. Check if the java script is enabled or not.

    How to enable JavaScript in a web browser?

    http://support.microsoft.com/gp/howtoscript

    4. Reinstall Java machine

    http://www.java.com/en/download/win8.jsp

    Please Note: This response contains a reference to a third party World Wide Web site. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    5. Uninstall the older version of Java and install the latest version by follow the steps in the below link and let us know the status of the issue.

    Install Java in Internet Explorer:

    http://windows.microsoft.com/en-IN/internet-explorer/install-java#ie=ie-10-win-7

    In addition, I would like to suggest you try to use compatibility mode (go to tools --> Compatibility View Settings) to check the issue.

    Hopefully you could resolve your issue soon.

    Regards,

    Blair Deng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, November 7, 2013 9:55 AM
  • Hello, 

    I did the what you advised, but no success. And I don't see how Java installation would help, it's Javascript which is broken. I even tried to install IE 11.. 

    About problematic sites you asked.. All sites! E.g. http://www.w3schools.com/js/tryit.asp?filename=tryjs_alert

    Nothing happens if I click the button..

    If i select properties to ANY web page, I get :  

    Wednesday, November 13, 2013 11:15 AM
  • Hi leposima,
     
    Thank you for your update.
     
    Based on the current situation, I suggest you to turn off script debugging and notifications in Internet Explorer and check the result.
     
    Follow the steps below to turn off script debugging and notifications in Internet Explorer:
     
    Script error debugging and notifications are turned off by default. If they have been turned on, follow these steps to turn them off again.
     
    1. Open Internet Explorer by clicking the Start button, and then clicking Internet Explorer.
     
    2. Click the Tools button, and then click Internet Options.
     
    3. Click the Advanced tab, select the Disable script debugging (Internet Explorer) and Disable script debugging (Other) check boxes.
     
    4. Clear the Display a notification about every script error check box, and then click OK.
     
    I also would like to share the following link with you:
     
    The Notification “An Error Has Occurred in the Script on This Page” Appears When You Open Internet Explorer.
     
    http://blogs.technet.com/b/win7/archive/2011/04/05/the-notification-an-error-has-occurred-in-the-script-on-this-page-appears-when-you-open-internet-explorer.aspx
     
    Error Message: An Error Has Occurred In the Script on This Page
     
    http://support.microsoft.com/kb/183808
     
    Please follow the steps from the link above to fix the issue.
     
    Meanwhile, I suggest contacting IE development forum to look at this issue as well.
     
    http://social.msdn.microsoft.com/Forums/en/iewebdevelopment/threads
     
    Thank you for your understanding.
     
    Regards,
     
    Blair Deng

    Blair Deng
    TechNet Community Support

    Saturday, November 23, 2013 4:07 PM
  • IE refuses to execute javascript on my computer: 

    Other users having this symptom turned out to be Dell owners who had residual McAfee interference.  Apparently the designed uninstall for the built-in product is not sufficient and that makes it necessary to seek out a clean-up program.

    FYI



    Robert Aldwinckle
    ---

    • Marked as answer by Cloud_TS Monday, November 25, 2013 1:35 PM
    Saturday, November 23, 2013 11:14 PM
    Answerer