locked
False "exceed the current threshold" warning RRS feed

  • Question

  • We have a few users with ProClarity Web Pro 6.3 who frequently get a warning that the query will take a long time to complete and "exceeds the current threshold of 1,000." However, they see this warning when they have a filter applied to show only the top 10 or so rows but are changing a Date parameter with the Date dimension in the background. When they go ahead and proceed, it runs the query quickly and shows only the top rows as it should.

    I've been telling the users to just ignore the warning and proceed, but it is causing confusion and is sometimes a valid warning in cases where they don't have a filter applied. Is there a way to keep this warning from popping up when it is irrelevant?
    Wednesday, December 16, 2009 4:30 PM

All replies

  • Hi Todd,

    You could increase the threshhold or disable the 'query check' feature in ProClarity professional altogether.  The default value of 1,000 is a product of rows x columns.  Even if a top 10 filter is used, it may still be querying a larger result set before filtering those results.  The warning and size settings are controlled in ProClarity Professional options on the browsing experience tab.  Clearing the 'check query result size before executing' box will disable the warnings.

    Hth,
    Sean
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, December 23, 2009 10:44 PM
  • As Sean mentioned, the warning is based on the number of cells a query creates (Rows x Columns).  When ProClarity tries to figure out the size of the query, it does not check to see if you are using a Filter or not.  It only looks at the selections for the attributes on Rows and Columns and checks to see the number of members in the selection.  You will see the same problem if you just turn on the Non Empty filter (Filter Empty Rows/Filter Empty Columns).  Had they written the logic to consider filters, then you would be fine.  Unfortunately that is not the case.  The only other way around this besides disabling the check as Sean mentioned would be to use Named Sets (ProClarity Selector add-in) to create your Top 10 list instead of the Filter dialog.  However, this only works if you are using a single hierarchy.  It may meet your need though.

    -Jason
    Tuesday, December 29, 2009 7:02 PM