Windows 10 1903 getting black screen when logging off or switching users RRS feed

  • Question

  • Hi, I am an IT support technician here in the UK.

    I have an HP 440 i7 laptop with the new 1903 build. When either logging off or switching users, the circle of dots appears for a few seconds and then the screen gore black. Nothing seems to allow you to get out of that state except using the power switch to power cycle the machine.

    I have updated and tested HP graphics drivers, latest Windows updates, the BIOS, removed Cisco Anyconnect, which showed a couple of events in Event Viewer and run Diags on the hardware. Nothing has made any difference. Powering off or restarting works fine, logging in is fine. Everything seems to work fine when logged in, but as soon as you try to switch or log off, bye-bye...

    Any ideas folks?

    • Edited by Seb-G Wednesday, June 5, 2019 10:50 AM
    Wednesday, June 5, 2019 10:48 AM

All replies

  • Hello, 

    Refer following support article: 


    Select a scenario that matches your issue and proceed accordingly. 

    Hope this helps!

    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Wednesday, June 5, 2019 11:28 AM
  • Hi Kapil,

    I saw the Win7 version of this article which looks very similar with the same potential solutions.

    I got up to Action six, noting that I'd done most combinations and drivers for everything I could roll back or update.

    I'm reticent to start the system restore at this stage as there is a rather complicated software install that I do not want to jeopordise at the moment. I have another similar machine arriving in a couple of days and so I am going to do a complete install on that testing at every stage.

    Process of elimination as always... Thanks for your input though, very much appreciated.



    Wednesday, June 5, 2019 12:36 PM
  • A reasonable idea, Seb.

    Since 1903 version release recently, drivers or software compatibility may exist some issue, roll back to previous system for normal work and test on another machine is a proper behavior.

    After some updates, 1903 should be more stable, then upgrade to this version on your current machine.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 6, 2019 6:17 AM
  • Thanks Teemo, I'm just installing my vanilla 1903 build now.

    I'll post my findings when complete.

    Have a great weekend all!


    Friday, June 7, 2019 2:03 PM
  • I've had 5 (two Lenovo Carbon X1s and two Dell XPS systems and one Surface Pro 4) computers tested with 1903.  4 in a local domain, the 5th a Surface Pro 4 was in a domain now stand alone (was stand alone when I updated to 1903), all when you log off the screen goes black. Doing a hard reset fixes the problem till you log off again.

    also three I tested get black screen when I RDP to them 

    the surface pro 4, I removed the intel driver rebooted and re-installed, this didn't fix the issue.

    I did the update on most of them, I also wiped the systems and did a clean install on a couple.
    I noticed that the systems could log off no problem before I added them to the local domain. after that they would black screen when logging off (the SPpro4 unit didn't do a clean install but it used to be in a local domain just not when I did the update through WU)

    Monday, June 24, 2019 11:30 AM
  • Teemo,

    Sorry to piggyback here. Just want to check in if there's a fix addressing this particular issue. We have upgraded many Windows 10 from 1803 to 1903 and have been experiencing this issue on all even all the drivers are up-to-date! Reverting to the previous version is no longer available.



    Monday, June 24, 2019 3:46 PM
  • Hi,

    Did you find a solution for this?



    Thursday, July 4, 2019 2:31 PM
  • We are having the same problem at our business. Win 10 Enterprise 1903

    Sign-Off,  get a black screen - have to hard boot to get the os back.

    Never fails to fail. My associate has a ticket open with Denial-soft Support now, glad to see we aren't the only folks running into this.

    Tried disabling Startup items, updating drivers per MS - no change.

    If they come up with a working fix, I will post it here.

    Tuesday, July 9, 2019 8:38 PM
  • Me too! 

    Any possible fixes?



    Wednesday, July 10, 2019 12:14 PM
  • Awesome, please keep us posted.


    Wednesday, July 10, 2019 12:14 PM
  • This is what is causing the issue on my side:


    Maybe this will help you guys?



    • Proposed as answer by Maelito Thursday, July 18, 2019 4:30 PM
    Wednesday, July 10, 2019 4:28 PM
  • Ok we use Carbon Black Antivirus - uninstall - Signoff - All good. I can Sign Off again.

    So it's an incompatibility with some 3rd party AVs. We'll be trying it with Bitdefender tomorrow. I'll keep you posted.

    Thanks Maelito for picking up the Sophos tip.

    Everybody try it with your Antivirus and post the name/version/results.

    Yay Teamwork.

    Thursday, July 11, 2019 8:35 PM
  • Update: 1903 works with Bitdefender. We were able to get Sign Off correctly with it installed/updated.
    Friday, July 12, 2019 3:15 PM
  • We have similar issue, Some PC running on Windows 10 1903 , carbon black installed. 

    Will try to uninstall CB and see how it goes. 


    • Edited by Vish-WIZ Saturday, July 13, 2019 9:53 AM
    Saturday, July 13, 2019 9:43 AM
  • Way to go Loegrus, I didn't even think to question CarbonBlack's compatibility. I had the same logout issue, completely fixed by removing CB.

    I have version, on Win10 Enterprise 1903.

    I'm waiting on a call back from CB as of now to see how we can proceed to fix this.

    Monday, July 15, 2019 2:58 PM
  • Excellent ChanceP!

    Let us know what CB says :-) 



    Monday, July 15, 2019 7:32 PM
  • Clever guy I work with suggested our RDP black screen problems were due to Carbon Black.  Uninstalled it and all seems fine now.  Glad I found this thead.  Before we were having endless problems - connecting, after disconnecting, after a reboot.
    Wednesday, July 17, 2019 7:58 PM
  • Cb defense released version of the Sensor yesterday that should fix this and I can confirm that this is the case!

    • Proposed as answer by Skeb1ns Thursday, July 18, 2019 1:23 PM
    Thursday, July 18, 2019 1:22 PM
  • My case is also Carbon Black related. Sensor version, has addressed this issue.



    • Proposed as answer by mojoc Monday, July 22, 2019 2:10 PM
    Monday, July 22, 2019 2:09 PM
  • Just wanted to chime in & say I was also having the same issue. Uninstalling the Carbon Black sensor resolved for me. Downloaded the new version and installed it, issue has not returned.
    Wednesday, August 7, 2019 1:46 PM
  • Carbon Black is a disaster witht that Black screen issue. We've had it occuring in our large business for so many versions it's become RIDICULOUS. I did not choose this product but now have to deal with it as my siloed region was pulled into a global service, prior we had McAfee which was fantastic. Ahhh what a dream that was.....now the CB nightmare...

    The only thing to do is uninstall in safe mode, if you can't get to that use system restore, if that is not possible fix then reinstall Win10 as an upgrade if possible. Re-install CB preferably always moving up to latest version. You will encounter the problem again though on some other system in your org.

    • Proposed as answer by MorpheusX0 Wednesday, January 8, 2020 10:56 AM
    • Edited by MorpheusX0 Wednesday, January 8, 2020 10:59 AM
    Wednesday, January 8, 2020 10:54 AM
  • Thank you Loegrus, you just solved something bugging us for a long time. Carbon Black was causing it for us. So I suggest people check their security software. We are going to test with the latest version of CB because I believe we are running a slightly out of date copy. Thanks again!
    Monday, January 13, 2020 4:33 PM
  • Same problem issue is in CB 3.3; Upgrading to CB 3.4 or higher corrects this.
    Monday, March 16, 2020 9:20 PM
  • We have the same issue of black screen when using Sign Out or Switch User, on both Windows 10 1903 and 1909. We also use Carbon Black. I'll try upgrading the Sensor as recommended and send feedback.
    Thursday, August 6, 2020 12:04 PM