none
My 1TB External USB HD not being recognized RRS feed

  • Question

  • I have an Iomega 1TB Hard drive (less thn 7 months old - bought in August 09) that is not being recognized in WIndows 7 64 bit.  I do NOT have the Nvidia chipset, I have already applied the hot fix from Microsoft, I am not getting "unknown devices" in the device manager.  It shows up has the drive letter I want it to (P:) I double click on it and it eventually shows up in My Computer, double click on the the drive, Window says Window is not responding or it just shows the sub folders as empty and I knwo that I have stuff in there.  Turning off the drive, turning it back on at least gets it back.  Some times Windows tells me that it has found a new device when I go thru the process of turning off/on and reports that it found a USB 2.0 device on an old hub and that it could preform faster... Mind you that the drive is plugged directly into the back of my computer and it is a BRAND NEW Dell Optiplex 780, Windows 7 Pro x64, 8GB RM, 320GB SATA II primary drive, etc.  I have tried different power strips and directly into the wall to rule out dirty power. The mobo is using the Intel ICH10 chipset

    Did I mention that i do not have any problems at all with the same drive plugged into my windows XP home 32bit net book?  this is extremely annoying as i use this drive on a regular basis for storing of images (ISOs) and backup of my data.  I do not have access to a spare 250+GB of free space to copy the data to another drive and go thru the format process.  it is formatted NTFS.

    I have downloaded and installed the latest chipset drivers from dell and WIndows Update.  Any help would be helpful! Thanks

    Monday, March 22, 2010 7:24 PM

All replies

  • Assigning the drive letter is not the issue. this appears to be a Windows 7 x64 wih more than 4GB RAM issue.  The drive is fully functional with other machines that are running the 32bit OSs.  I am an IT admin and know how to manage the drive letters.  I am in the process of moving the data to another external drive via my windows xp 32bit netbook this process will take a couple of hours.  once the 200+GB is transfered, I will delete the partition and recreate the partition, format the drive.  I am very sceptical that this will work but will to give it a try.  I know that this could become a more wide spread problem.... this summer we will be releasing Wndows 7 x64 into one of our brand new computer labs (basically the same specs as I listed above for my machine - just the Dell Optiplex 960).  Some of Our students do use external hard drives instead of flash drives.  For me the deleting of the partion is fine, but we can not so this to the students hard drives.
    Tuesday, March 23, 2010 1:17 PM
  • I do have an nVidia video card but it using the intel ICH10 USB as stated above.  my copy boomed so I am starting it over..... skipping over 1 particular folder that give me the error
    Tuesday, March 23, 2010 3:11 PM
  • Do you have an NVIDIA chipset? If so then there is a hotfix for it, forget the number off hand.

     


    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old


    FYI

    KB976972, but it doesn't apply in this case.


    It's a...jump...to conclusions...mat.
    Tuesday, March 23, 2010 5:05 PM
  • Hi ChrisPedley,

     

    Before transferring the data and reformatting and hard drive, please check the following suggestions:

     

    I would like to suggest you refer to the following link to check if your Iomega 1TB hard drive is compatible with Windows 7:

     

    https://iomega-na-en.custhelp.com/cgi-bin/iomega_na_en.cfg/php/enduser/std_adp.php?p_faqid=22175&p_sid=7Slf3DXj

     

    You may also refer to the following link to search for the firmware update for your Iomega 1TB hard drive:

     

    https://iomega-na-en.custhelp.com/cgi-bin/iomega_na_en.cfg/php/enduser/cci/platform.php?prod_lvl1=3&prod_lvl2=1012&p_prods=3,1012&p_pv=2.1012&p_sid=7Slf3DXj

     

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    In addition, I also would like to suggest you update the BIOS for Dell OptiPlex 780 from the following link:

     

    http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=gen&ServiceTag=&SystemID=PLX_780&os=WLH&osl=en&catid=&impid=

     

    Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    Regards,


    Arthur Li - MSFT
    Wednesday, March 24, 2010 3:15 AM
    Moderator
  • 1. Yes it is compatiable with Windows 7 the drive is eGo™ Desktop Hard Drive USB 2.0

    2. there is no firmware for this drive

    3. Already upgraded the BIOS to version A03 (latest)

    The above 3 steps were completed prior to the initial post.

    Update to my previous posts.  I was unable to delete the partition via my Windows 7 x64 box (just got the spinning circle and it would eventually throw an error). even if I force it to continue Windows 7 would say that the drive is not initialized. Try to inialize the drive and it throws an error. turn off the drive and back on the structure is still there.

    Put the drive on my WIndows XP Home 32 bit netbook, deleted the partition.  Plugged the drive back into my Windows 7 x64 machine, created a partition, formated the drive.  Reconnected to my Windows XP Home netbook and transfered back my data (left that running last night when I left the office).  This morning I plugged in the Iomega drive to my Windows 7 x64 machine.  It took about 45 seconds for the machine to recognize it.  Opened up Windows Explorer, saw the drive with the correct drive letter, opened it, saw the 2 folders within, tried open both folders with the same result (this folder is empty)

    I have checked the permissions and everything is the way it should be... I am in the administrators group and administrators have Full Control (on the drive itself and the both subfolders)

    I also placed a couple of exe files in the root of the drive during the transfer of my data back onto this drive. The error I get is P:\xxxxxx.exe is not a valid Win32 application. when I double click on it as of right now.  There are so many other threads out there on the internet about this same problem and I have yet to find a resolution.  So far in my research I have yet to find another Dell with the problem... a lot of HP, ASUS and home made machines with specific motherboards.

    This appears to be a WIndows 7 64Bit issue.  I can use this hard drive any other computer without problem. My next test will be to put this drive onto one of our servers running Windows 2008R2 64bit and see if I get the same result.  I will report my findings when I get a chance ot take the drive to our server room.

    If any one else has any suggestions, please let me know.  Please read the itial post as it tells all the steps that I had initially take along with my hardware specs (NO NVIDIA CHIPSET!)

    Wednesday, March 24, 2010 1:05 PM
  • I found a Belkin 2 port USB 2.0 PCI card and installed it.  I now have the drive on that card.  I will need to go thru a little bit of testing but as of right now it is working.  I will follow up tomorrow

    Wednesday, March 24, 2010 8:45 PM
  • Please unmark the anwer... it did not solve the issue.  I am now back to seeing the drive and the 2 subfolders but does not show the contents.  Any other suggestions out there?
    Friday, March 26, 2010 4:13 PM
  • Hi ChrisPedley,

     

    I would like to confirm what is the current situation?

     

    Regards,


    Arthur Li - MSFT
    Monday, March 29, 2010 7:53 AM
    Moderator
  • This is Still a PROBLEM.  I have used 3 other machines and have NO issues reading/writing to the drive on the other computers.  Any one with suggestions?

    Steps thus far...

    1. Reads/Writes Perfectly via Windows XP, Windows 2003 (3 other computers)

    2. Applied Hot fix from Microsoft (don't remember the article number)

    3. Disabled USB Seletive suspend setting in the Power Controls

    4. Installed a USB Belkin card with the NEC chipset

    5. Deleted the partition (had to be done on my Windows XP netbook) and reformated the drive (completed on my Windows 7 x64 box)

    6. Checked for firmware for the Drive and upgraded to the latest BIOS from Dell

    7. reminder I do NOT have the nVidia chip set

     

    Monday, March 29, 2010 1:15 PM
  • Chris,

    did you resolve this issue? I've had this same problem for the past year and I just keep flicking the power on and off till it works.

    I'm going to go buy a different Hard drive if I can't find a solution.

    Monday, August 15, 2011 4:58 AM
  • Turn the computer off without the external hard drive being plugged in.

    plug the external hard drive in a usb port, power up, the systems post boot up will find the drive and inform windows what hardware is installed.

    When windows boots up, it will look at all the hardware and find the external hard drive, when windows finishes booting up you should be able to see the drive in my computer.

    If it helps, please vote for me!


    And also, by the time you finish reading this you will realize that this is just my signature.

    Monday, March 12, 2012 4:18 AM