locked
Skype for Business - Custom State URL not working RRS feed

  • Question

  • Hi,

    I'm trying to deploy an xml file to add custom states in Skype for Business.

    Our servers are Lync Server 2013, and clients Skype for Business 2016. I followed technet and created an xml file :

    <?xml version="1.0"?>
    <customStates xmlns="http://schemas.microsoft.com/09/2009/communicator/customStates">
    <customState ID="1" availability="online">
    <activity LCID="1036">blablabla</activity>
    </customState>
    <customState ID="2" availability="busy">
    <activity LCID="1036">blabla</activity>
    </customState>
    <customState ID="3" availability="do-not-disturb">
    <activity LCID="1036">bla</activity>
    </customState>
    </customStates>

    I saved this file in a folder on the frontend server. And I can access it in web browser using the url : https://nameserver.domain.dom/ClientConfigFolder/CustomStates.xml

    I created a new CsClientPolicy with the url above for CustomStateURL argument, and granted the policy to my user.

    The issue is that no custom states appear, even after restarting Skype client or even reboot computer. And I don't get why.

    How can I troubleshoot this issue ?

    I can see that the new policy is applied, because if I changed others parameters, like DisableEmoticons or other, it works, but the Custom State never apply.

    Can somebody help me on this ?

    Thanks.

    Tuesday, December 10, 2019 10:46 AM

Answers

  • Here I will provide a brief and temporary summary of this post.

      

    <Issue Symptom>:

    User environment: Lync server 2013, client SFB 2016

    Add custom state URL as the official document:

    https://docs.microsoft.com/en-us/lyncserver/lync-server-2013-configuring-custom-presence-states

    The issue is that no custom states appear, even after restarting Skype client or even reboot computer.

        

    <Cause>:

    The most frequent root cause of this situation is the fact that Microsoft is using different registry hives for different versions of its Office software components.

     

    <Solution>:

    Create a new REG_DWORD value named EnableSIPHighSecurityMode in the Lync software policies key.

     

    <Reference Links>:

    http://blog.schertz.name/2010/11/adding-custom-presence-to-lync/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Monday, December 30, 2019 6:17 AM

All replies

  • Hi Alex Lekel,

    Do you test your configuration file by using the EnableSIPHighSecurityMode regidtry setting to disable SIP high security mode on client?

    The LCID 1036 you mentioned points to France. Please check if the LCID meets your condition.

    Moreover, there is blog elaborating the process of adding custom presence for your reference.

    http://blog.schertz.name/2010/11/adding-custom-presence-to-lync/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Wednesday, December 11, 2019 3:17 AM
  • Hi Sharon,

    Yes, I tested the file using registry keys and it works well.

    In fact I tested it using a different computer and it works fine (with the CsClientPolicy). So my problem now is to find why it works on some computers and not on others (with the same user account).

    Some computers are using Office 2016 and others are using Office 2019. The proble seems to appear only with Office 2019. Is the custom state URL not working with Office 2019 ?

    And yes, LCID 1036 is France, so we're good :)


    Alex




    Friday, December 13, 2019 10:08 AM
  • Hi Alex Lekel,

    In my research, the most frequent root cause of this situation is the fact that Microsoft is using different registry hives for different versions of its Office software components.

    Meanwhile, if there is no issue, please remember to mark helpful reply as answer to close the thread. Your action would be helpful to other users who encounter the same issue and read this thread.

    Thanks for your understanding.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 18, 2019 8:52 AM
  • Thank you Sharon for your feedback.

    But we do have an issue. The CustomStateURL when applying via CsClientPolicy, is not working for Office 2019.

    So, do you think is there any solution ? Or it's just not possible by design ?

    Regards,


    Alex

    Wednesday, December 18, 2019 4:19 PM
  • Hi Alex Lekel,

    Do you have any further issue on this topic?

    Meanwhile, if there is no issue, please remember to mark helpful reply as answer to close the thread. Your action would be helpful to other users who encounter the same issue and read this thread.

    Thanks for your understanding.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 23, 2019 9:42 AM
  • Here I will provide a brief and temporary summary of this post.

      

    <Issue Symptom>:

    User environment: Lync server 2013, client SFB 2016

    Add custom state URL as the official document:

    https://docs.microsoft.com/en-us/lyncserver/lync-server-2013-configuring-custom-presence-states

    The issue is that no custom states appear, even after restarting Skype client or even reboot computer.

        

    <Cause>:

    The most frequent root cause of this situation is the fact that Microsoft is using different registry hives for different versions of its Office software components.

     

    <Solution>:

    Create a new REG_DWORD value named EnableSIPHighSecurityMode in the Lync software policies key.

     

    <Reference Links>:

    http://blog.schertz.name/2010/11/adding-custom-presence-to-lync/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Monday, December 30, 2019 6:17 AM
  • Hi,

    Yes, I understand there's no other way than disable SIPHighSecurityMode, but unfortunatly it's not a good practice for us in a company context. That's too bad….I hope this will be resolved one day ! :)

    Monday, December 30, 2019 1:23 PM