locked
Enabling IRM for Exchange 2010 RRS feed

  • Question

  • Exchange 2010 Enterprise

    RMS on 2012

    Crypto version 1

    I have RMS installed in environment and basic template of Do not Forward works well

    To enable OWA functionality we are trying to enable interLicensing and get following error

    SCP is properly published, any thoughts on next steps?

    [PS] C:\>Set-IRMConfiguration -InternalLicensingEnabled $true
    No RMS server was found. This setting requires an RMS server to be configured to communicate with Hub Transport server.
     Please ensure this is setup correclty to enable IRM features.
        + CategoryInfo          : InvalidOperation: (:) [Set-IRMConfiguration], NoRMSServersFoundException
        + FullyQualifiedErrorId : 3FAE2DB7,Microsoft.Exchange.Management.RightsManagement.SetIRMConfiguration

    Friday, February 21, 2014 4:17 AM

Answers

  • Issue resolved It was tracked down to the SCP itself having only domain users and system as read Added authenticated users as read /read execute on the SCP Exchange servers are now able to read it and command succeeded Thanks all for providing feed backs
    • Marked as answer by SanTal1900 Saturday, March 1, 2014 12:37 PM
    Saturday, March 1, 2014 12:37 PM

All replies

  • Hi,

    This issue may occur when missing appropriate permissions for AD RMS Service Group on ServerCertification.asmx file. Try checking whether the Read&Execute and Read permission is present on:

    C:\Inetpub\wwwroot\_wmcs\Certification\ServerCertification.asmx

    Thanks,

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Simon Wu
    TechNet Community Support

    Monday, February 24, 2014 2:54 AM
    Moderator
  • We have provided permissions to the service group and exchange server group to the mentioned files. Identical setup in the lab worked as expected, the error seem to indicate that it could not find a RMS installation in the domain or find the server name to look for. SCP seems to be properly published too
    Monday, February 24, 2014 3:28 PM
  • Hi,

    Have we configured the super-user rights for Exchange server correctly? Please add the Federated Delivery Mailbox user account to a group in the same forest as the AD RMS installation and enable the super users group on the AD RMS cluster, then see if there is any update.

    For more details, you can refer to the below articles:

    Configuring AD RMS to Integrate with Exchange Server 2010 in a Single Forest

     

    Wednesday, February 26, 2014 8:12 AM
  • Hi,

    How are things going? We appreciate an update on the status of the issue.

    Thanks,

    Jessie

    Friday, February 28, 2014 12:35 PM
  • Hi,

    Can you send the output of the following command?

    Test-IRMConfiguration -Sender user@domain.com

    All of the steps in here should be PASS. You may be having an issue with the certificate. The output would tell though.

    ecsword

    Friday, February 28, 2014 5:34 PM
  • Issue resolved It was tracked down to the SCP itself having only domain users and system as read Added authenticated users as read /read execute on the SCP Exchange servers are now able to read it and command succeeded Thanks all for providing feed backs
    • Marked as answer by SanTal1900 Saturday, March 1, 2014 12:37 PM
    Saturday, March 1, 2014 12:37 PM