locked
Server 2019 Remote Desktop Licensing mode is not configured? RRS feed

  • Question

  • I have server 2019 standard and installed the RD licensing manager and my User CALs.  In License Manager  it shows my licensed CALs look fine.     I am getting a warning message about my Remote Desktop licensing mode is not configured.  It mentions using the RD connection broker server to specify the remote desktop mode.  I'm not sure what they mean by this?
    Saturday, January 18, 2020 4:27 PM

Answers

  • Hi,

    First, your server must be joined to an Active Directory domain for Per User mode to work properly.  Second, you can set the licensing mode and specify the FQDN (itself) of your RD Licensing server via group policy (e.g. gpedit.msc):

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Licensing\

    Use the specified Remote Desktop license servers     Enabled

    Set the Remote Desktop licensing mode     Enabled

    -TP

    • Proposed as answer by Tom Billet Sunday, January 26, 2020 4:15 PM
    • Unproposed as answer by Tom Billet Sunday, January 26, 2020 4:15 PM
    • Proposed as answer by Tom Billet Sunday, January 26, 2020 4:15 PM
    • Marked as answer by TP []MVP Wednesday, April 1, 2020 12:12 AM
    Saturday, January 18, 2020 4:57 PM
  • HI
    "It mentions using the RD connection broker server to specify the remote desktop mode.  I'm not sure what they mean by this?"
    It means if there is RDCB in your RDS environment and you add RDSH servers to RDCB server pool ,we can select task-->edit deployment properties-->RD licensing 
    select "per device" mode for RDS per device cal or "per user"mode for RDS per user cal ,and specify RD Licensing server  for your RDSH servers. like picture.
    Of course,we can also use Mr TP suggestions. the result is same.
    Note RDCB server also need to use in AD environment.


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, January 20, 2020 2:57 AM

All replies

  • Hi,

    First, your server must be joined to an Active Directory domain for Per User mode to work properly.  Second, you can set the licensing mode and specify the FQDN (itself) of your RD Licensing server via group policy (e.g. gpedit.msc):

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Licensing\

    Use the specified Remote Desktop license servers     Enabled

    Set the Remote Desktop licensing mode     Enabled

    -TP

    • Proposed as answer by Tom Billet Sunday, January 26, 2020 4:15 PM
    • Unproposed as answer by Tom Billet Sunday, January 26, 2020 4:15 PM
    • Proposed as answer by Tom Billet Sunday, January 26, 2020 4:15 PM
    • Marked as answer by TP []MVP Wednesday, April 1, 2020 12:12 AM
    Saturday, January 18, 2020 4:57 PM
  • Thank you.  I will give it a try this week.
    Saturday, January 18, 2020 7:50 PM
  • HI
    "It mentions using the RD connection broker server to specify the remote desktop mode.  I'm not sure what they mean by this?"
    It means if there is RDCB in your RDS environment and you add RDSH servers to RDCB server pool ,we can select task-->edit deployment properties-->RD licensing 
    select "per device" mode for RDS per device cal or "per user"mode for RDS per user cal ,and specify RD Licensing server  for your RDSH servers. like picture.
    Of course,we can also use Mr TP suggestions. the result is same.
    Note RDCB server also need to use in AD environment.


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, January 20, 2020 2:57 AM
  • HI
    Is there any progress on your question?

    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 22, 2020 1:25 AM
  • HI
    Is there any progress on your question?

    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, January 26, 2020 2:11 PM
  • HI

    If you find any reply that helps, could you help mark it as an answer so that other community members could find the helpful reply quickly please ? Your contribution is highly appreciated.

    Thanks for your support and understanding.

    Have a nice day!


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 28, 2020 2:27 PM