locked
Exchange O365 Hybrid | Mail Flow vs. Outlook Client Rule RRS feed

  • Question

  • I am relatively new Exchange, and Server Management Generally, so be gentle as I've only taken MTA Server (which doesn't cover Exchange at all).

    We've just installed a new small format MFP device (replacing our old), and I've already setup incoming fax forwarding to SMB.

    I'm now trying to instead modify the incoming fax forwarding to be moved to Public Folder\Faxes directory, where both our two Admin staff have access, etc. The printers admin software is the easy part, to my mind.

    Where I need some guidance is in properly configuring Exchange (I believe)... How do I configure the preexisting Public Folder/Faxes folder to 'receive' emails set to Faxes@<domainName>.com?

    The environment I initially inherited earlier this year was 32-bit Server 2003 SBS, Exchange 2003, Windows XP, and we've since upgraded to 64-bit Server 2012 R2, Exchange 2013, Windows 8.1 + O365 Midsize Business (with on-premise Exchange, obviously).

    Cheers


    &quot;Potential has a shelf life&quot; - Margaret Atwood

    Saturday, September 20, 2014 3:00 PM

Answers

  • As an update....

    At this point, all incoming faxes are correctly delivered to our ..\Faxes\ public folder.

    To solve this, I used Exchange Admin Console (EAC), Public Folders tab, enabled Mail Settings for the Faxes folder, selected Edit (pencil), Email Address tab, and used the SMTP listing for the destination of our new printer's fax forwarding mechanism.

    At this point I noticed that the SMTP address assigned to my Faxes public folder was Faxes1 and not Faxes as I originally assumed... I could stop here, as once this has been set, I can pretty much forget it, but I am new to Exchange Management, and am interested to learn more.

    In an effort to try and resolve the alias assignment (i.e., make it Faxes instead of Faxes1), I've renamed the Faxes folder as Faxes_old, and created a new Faxes folder. The former retains both the Faxes, and Faxes1@<domainName>.com alias, whereas the latter is given Faxes2@<domainNaim>.com.

    I then deleted both the Faxes and Faxes_old folders, and created yet another new Faxes folder, which is again assigned Faxes1@<domainName>.com alias automagically.

    Non-priority issue at this point, but I'd very much appreciate someone (even Ed) educating me as to how, and why Faxes@<domainName>.com is not used from the outset.

    Cheers



    Potential has a shelf life - Margaret Atwood

    • Marked as answer by BlackBox_ Tuesday, September 23, 2014 4:10 PM
    Tuesday, September 23, 2014 4:10 PM

All replies

  • You're really asking in the wrong place.  My best guess would be that you should mail-enable the public folder, which gives it an SMTP address, and then configure your fax server to send the faxes to that address.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, September 21, 2014 6:18 AM
    Moderator
  • You're really asking in the wrong place.  My best guess would be that you should mail-enable the public folder, which gives it an SMTP address, and then configure your fax server to send the faxes to that address.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    You've neglected to inform me of the correct place to pose my question - as you can see, I'm new here.

    While the Public Folder\Faxes folder was mail disabled initially, I have since enabled it, and still seems to fail when MFP forwards incoming faxes to Faxes@<domainName>.com.

    Cheers


    Potential has a shelf life - Margaret Atwood

    Sunday, September 21, 2014 5:30 PM
  • A better place would be a forum for your fax server.

    You can enable SMTP protocol logging on the receive connector to which the fax server would be connecting and see if you can see what's going on.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, September 21, 2014 8:17 PM
    Moderator
  • A better place would be a forum for your fax server.

    You can enable SMTP protocol logging on the receive connector to which the fax server would be connecting and see if you can see what's going on.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    A better place to ask how to properly configure a Public Folder to receive email in Exchange Server 2013, is 'some other forum for my fax server' that shall not be named, when the latter is the only part that is working properly?

    Given that both forwarding incoming faxes to SMB, and forwarding to my email address are working properly when tested, perhaps we can focus on what I felt I made clear was the issue... Particularly as I am new to this aspect... Properly configuring Exchange Server 2013, no?

    Cheers


    Potential has a shelf life - Margaret Atwood

    Sunday, September 21, 2014 10:50 PM
  • It's easy enough to see whether a public folder is receiving mail--send it a message.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Sunday, September 21, 2014 11:03 PM
    Moderator
  • It's easy enough to see whether a public folder is receiving mail--send it a message.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Hi Ed,

    Perhaps you've overlooked this, but I've already stated above that the Public Folder\Faxes folder has been enabled... Again, my issue is with an existing Public Folder in Exchange not being configured properly.

    In Outlook Client, I can send an email to the Faxes folder, using the To... button, and selecting Faxes folder. However, sending emails to Faxes@<domainName>.com are unsuccessful.

    Checking the properties of Faxes folder in EAC this morning, I see now that Faxes1@<domainName>.com was originally configured (by another well before I was hired on)... However, any attempt to change Faxes1 alias to Faxes results in an SMTP error, as supposedly Faxes alias is already in use (so I must have a duplicate to resolve).

    Using LDAP query in AD of "proxyaddresses=smtp:Faxes@<domainName>.com", yields one result... <domainName>/Microsoft Exchange/System Objects/Faxes which makes sense, but I do not understand why the folder's name (Faxes) is not able to be used?

    Cheers


    Potential has a shelf life - Margaret Atwood

    Monday, September 22, 2014 1:37 PM
  • Did you mail enable that public folder?  I asked you that in my first post and you said that you did.

    http://technet.microsoft.com/en-us/library/aa998824(v=exchg.150).aspx


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, September 22, 2014 3:00 PM
    Moderator
  • Did you mail enable that public folder?  I asked you that in my first post and you said that you did.

    http://technet.microsoft.com/en-us/library/aa998824(v=exchg.150).aspx


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    *blink* *blink*

    I'm not sure if we're having a language barrier issue here, or what... Yes, for the third? time, I've enabled the public folder, and can email successfully when selecting the Faxes folder from the To... button's selection dialog in Outlook Client.

    To reiterate what I've just described above....

    Having learned more this morning, I _am_ receiving fax forwarding now using Faxes1@<domainName>.com from my new MFP... However, I _am unable_ to modify the alias to be Faxes@<domainName>.com, as I receive an SMTP error in EAC.

    I've used an LDAP query in AD and confirmed that only one Object exists that uses the Faxes alias, and that is the PF\Faxes folder... So how do I modify Faxes folder alias to _not_ use Faxes1@<domainName>.com?

    Cheers


    Potential has a shelf life - Margaret Atwood

    Monday, September 22, 2014 4:15 PM
  • You didn't specify what "SMTP error" you are getting, so I'm flying blind.  When quoting error messages, you should post the complete unadulterated message.  If you're being told that the address is in use, I would use LDP to search for that e-mail address.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, September 22, 2014 4:49 PM
    Moderator
  • You didn't specify what "SMTP error" you are getting, so I'm flying blind.  When quoting error messages, you should post the complete unadulterated message.  If you're being told that the address is in use, I would use LDP to search for that e-mail address.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    *blink* *blink*

    Ummm... _You're_ flying blind? 

    Imagine how I feel, when the majority of your posts simply restate what I've already stated, and you're the 'MVP' here. 

    As it happens, I have already described the SMTP error received (cannot rename Faxes1@<domainName>.com to Faxes@<domainName.com) in EAC.

    Further, as stated previously _twice_, I've already used an LDAP query in AD (what the hell is LDP?), and determined that there is only one Object with Faxes@<domainName>.com assigned, and that Object is the Faxes folder (a subfolder of Public Folders).

    In the event you can offer something useful, that I have not already stated one or more times, here's the explicit SMTP error received from EAC (which stands for Exchange Admin Center):

    [quote]

    error
    <domainName>.local/Microsoft Exchange System Objects/Faxes 38506417
    The proxy address "smtp:Faxes@<domainName>.com" is already being used by "<domainName>.local/Microsoft Exchange System Objects/Faxes". Please choose another proxy address.

    [/quote]

    Cheers


    Potential has a shelf life - Margaret Atwood

    Monday, September 22, 2014 7:30 PM
  • Hi Blackbox,

    if you mail-enabled the public Folder, you can send mail from the Address book to your recipient folder. As we saw above that worked.

    Your object "<domainName>.local/Microsoft Exchange System Objects/Faxes 38506417" is something non-Standard, so it may be something like another public Folder (your faxes folder?). As Long as that recipient has the address assigned, you cannot re-assign.
    From your description I'm not sure if that is already your Faxes Folder  ; please use Powershell to verify: http://technet.microsoft.com/en-us/library/jj984289(v=exchg.150).aspx
    use the get-publicfolder cmdlet to do that.

    Unfortunately you still did not post the error (exactly the text that was written in your mail bounce) that Comes from the SMTP message sent to you public folder. Maybe you should send some test mail from a Google acocunt to post the result - so you can see if the error happened on your Exchange or on your MFP.

    At a first glance, without having the SMTP bounce, you should check that:
    1. mail-enable the public Folder : http://technet.microsoft.com/en-us/library/aa997560(v=exchg.150).aspx
    2. use get-publicfolder yourfolder | fl to check the proxyaddresses Attribute for your faxes@somewhat.com address -> is it present?
    3. please also check the AcceptMessagesOnlyFrom  attribute at that list.

    If that did not work, please post your mails bounce.

    Let us know, if it helped.

    Regards,
    Martin


    Monday, September 22, 2014 7:58 PM
  • Hi Blackbox,

    if you mail-enabled the public Folder, you can send mail from the Address book to your recipient folder. As we saw above that worked.

    Your object "<domainName>.local/Microsoft Exchange System Objects/Faxes 38506417" is something non-Standard, so it may be something like another public Folder (your faxes folder?). As Long as that recipient has the address assigned, you cannot re-assign.

    Unfortunately you still did not post the error (exactly the text that was written in your mail bounce) that Comes from the SMTP message sent to you public folder. Maybe you should send some test mail from a Google acocunt to post the result - so you can see if the error happened on your Exchange or on your MFP.

    At a first glance, without having the SMTP bounce, you should check that:
    1. mail-enable the public Folder : http://technet.microsoft.com/en-us/library/aa997560(v=exchg.150).aspx
    2. use get-publicfolder yourfolder | fl to check the proxyaddresses Attribute for your faxes@somewhat.com address -> is it present?
    3. please also check the AcceptMessagesOnlyFrom  attribute at that list.

    If that did not work, please post your mails bounce.

    Let us know, if it helped.

    Regards,
    Martin

    Hi Martin,

    Correct; I am able to receive fax forwards, and direct emails to Faxes1@<domainName>.com as noted above.

    I agree that ../Faxes 38506417 is a non-standard configuration for Exchange Server, hence my seeking assistance. As mentioned, the LDAP query in AD yielded a single result; the Faxes folder in Public Folders.

    I have not received any email bounce when attempting to email Faxes@<domainName>.com... I have tried email from both internal (domain), and external (Gmail) accounts... Neither received any response at all. I have copied the entirety of the error received when attempting to rename Faxes1 as Faxes in EAC.

    1. \Public Folders\Faxes\ is mail-enabled.
    2. Done, here is the result:

    ... As you can see, there is no ProxyAddress, nor AcceptMessagesOnlyFrom Attributes.

    However, I did make this setting adjustment in Outlook Client (where I am one of the Object Owners), in order to get Faxes1@<domainName>.com to accept emails.

    Right click Faxes folder, Properties:

    Cheers


    Potential has a shelf life - Margaret Atwood

    Monday, September 22, 2014 8:27 PM
  • That error message is not an SMTP error.

    And again you post with incomplete information, such as what the query is you used.

    I'm not particularly fond of your tone, so I'm leaving this thread.

    Good luck.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, September 23, 2014 1:50 AM
    Moderator
  • That error message is not an SMTP error.

    And again you post with incomplete information, such as what the query is you used.

    I'm not particularly fond of your tone, so I'm leaving this thread.

    Good luck.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Ed,

    It's an EAC error due to an SMTP address in use, hence the summation of 'SMTP error'.

    Failure to read another's posts, does not 'incomplete information' make... I've already posted the LDAP query used in AD above.

    I'm sorry you'd rather leave than offer something, anything constructive; this isn't personal.

    Cheers



    Potential has a shelf life - Margaret Atwood

    Tuesday, September 23, 2014 12:23 PM
  • As an update....

    At this point, all incoming faxes are correctly delivered to our ..\Faxes\ public folder.

    To solve this, I used Exchange Admin Console (EAC), Public Folders tab, enabled Mail Settings for the Faxes folder, selected Edit (pencil), Email Address tab, and used the SMTP listing for the destination of our new printer's fax forwarding mechanism.

    At this point I noticed that the SMTP address assigned to my Faxes public folder was Faxes1 and not Faxes as I originally assumed... I could stop here, as once this has been set, I can pretty much forget it, but I am new to Exchange Management, and am interested to learn more.

    In an effort to try and resolve the alias assignment (i.e., make it Faxes instead of Faxes1), I've renamed the Faxes folder as Faxes_old, and created a new Faxes folder. The former retains both the Faxes, and Faxes1@<domainName>.com alias, whereas the latter is given Faxes2@<domainNaim>.com.

    I then deleted both the Faxes and Faxes_old folders, and created yet another new Faxes folder, which is again assigned Faxes1@<domainName>.com alias automagically.

    Non-priority issue at this point, but I'd very much appreciate someone (even Ed) educating me as to how, and why Faxes@<domainName>.com is not used from the outset.

    Cheers



    Potential has a shelf life - Margaret Atwood

    • Marked as answer by BlackBox_ Tuesday, September 23, 2014 4:10 PM
    Tuesday, September 23, 2014 4:10 PM
  • If the administrative tool finds the address it would use (faxes@ in this case) is already in use, it will append a number to it.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, September 23, 2014 7:29 PM
    Moderator
  • Hi Blackbox,

    as you described there was no error bounce when you sent to faxes@yourdomain , so it has been accepted, while it was not delivered to a place you already found in your Investigation.

    As you are unable to tell us what is configured, I suggest you do a message tracking now. Please see some basics on http://technet.microsoft.com/en-us/library/bb124375(v=exchg.150).aspx

    From my view you should start running

    Get-MessageTrackingLog  -sender yoursender@gmail.com -recipient faxes@yourdomain | sort-object timestamp

    from the Output you can see which recipient received it. So you can continue to check your recipients.
    (the sort-object timestamp is just to have the Output in the right order)

    Look for the DELIVER STORE events, so you know the recipient.  ( You may also consider to run Get-MessageTrackingLog  -sender yoursender@gmail.com -recipient faxes@yourdomain | fl to get more details)

    If you know that recipient you will need to check that object.

    Regards,
    Martin

    Tuesday, September 23, 2014 8:02 PM
  • If the administrative tool finds the address it would use (faxes@ in this case) is already in use, it will append a number to it.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Thanks for the reply, Ed.

    I understand how and why subsequent Objects are given the next available allocation; I'm confused as to why Faxes1 is used at all, given there is only one Faxes Object... Perhaps I am simply too new to get it, but it seems logical that if I create a 'BlackBox' Public Folder Object the email address would be BlackBox@ and not BlackBox1@, no?


    Potential has a shelf life - Margaret Atwood

    Tuesday, September 23, 2014 8:28 PM
  • Hi Blackbox,

    as you described there was no error bounce when you sent to faxes@yourdomain , so it has been accepted, while it was not delivered to a place you already found in your Investigation.

    As you are unable to tell us what is configured, I suggest you do a message tracking now. Please see some basics on http://technet.microsoft.com/en-us/library/bb124375(v=exchg.150).aspx

    From my view you should start running

    Get-MessageTrackingLog  -sender yoursender@gmail.com -recipient faxes@yourdomain | sort-object timestamp

    from the Output you can see which recipient received it. So you can continue to check your recipients.
    (the sort-object timestamp is just to have the Output in the right order)

    Look for the DELIVER STORE events, so you know the recipient.  ( You may also consider to run Get-MessageTrackingLog  -sender yoursender@gmail.com -recipient faxes@yourdomain | fl to get more details)

    If you know that recipient you will need to check that object.

    Regards,
    Martin

    Thank you, Martin.

    I'm happy to tell you what is configured, and thought I had done so - if not, then please walk me though what specifically would help you to help me, and I'll comply (within reason).

    I've checked the message tracking log as your advise, and there is not a single instance of "DELIVER STORE" (in any case, or concatenation)... I am also unable to determine where the messages went after being received.

    As example, here is one entry following the * | fl adaptation of the Get-MessageTrackingLog call:

    [code]

    RunspaceId              : 9e5b02a0-f767-4672-9212-1086d07cbd10
    Timestamp               : 9/22/2014 4:09:55 PM
    ClientIp                : fe80::80ea:af67:fd7d:49
    ClientHostname          : EX01.SomeDomainName.local
    ServerIp                : fe80::80ea:af67:fd7d:49%12
    ServerHostname          : EX01
    SourceContext           : 08D19E7C5CD6A6AC
    ConnectorId             :
    Source                  : STOREDRIVER
    EventId                 : RECEIVE
    InternalMessageId       : 0
    MessageId               : <05551d19344c462195f93f7d7df86a8d@EX01.SomeDomainName.local>
    Recipients              : {faxes@SomeDomainName.com}
    RecipientStatus         : {To}
    TotalBytes              : 8544
    RecipientCount          : 1
    RelatedRecipientAddress :
    Reference               :
    MessageSubject          : Test
    Sender                  : BlackBox@SomeDomainName.com
    ReturnPath              : BlackBox@SomeDomainName.com
    Directionality          : Originating
    TenantId                :
    OriginalClientIp        : SomeIPAddress
    MessageInfo             : 03I:
    MessageLatency          :
    MessageLatencyType      : None
    EventData               : {[MailboxDatabaseGuid, a4fd8618-4274-4588-8af1-17b62b83658e], [ItemEntryId, 00-00-00-00-F6-15
                              -74-2B-C0-FE-4E-45-90-D4-E4-A2-CD-60-EF-49-07-00-7F-EC-EA-F5-9A-04-5A-43-81-3F-94-33-8E-92-51
                              -60-00-00-00-DE-36-D2-00-00-00-A4-89-02-B0-A7-B7-4B-A7-C1-1C-1E-B8-47-30-16-00-00-45-CE-83-ED
                              -00-00], [DeliveryPriority, Normal]}

    [/code]

    Cheers


    Potential has a shelf life - Margaret Atwood

    Tuesday, September 23, 2014 8:40 PM
  • I can't answer your question based because I don't have access to your environment to run the LDP queries.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, September 23, 2014 10:25 PM
    Moderator
  • Hi Blackbox,

    what does that mean exactly:

    I've checked the message tracking log as your advise, and there is not a single instance of "DELIVER STORE" (in any case, or concatenation)... I am also unable to determine where the messages went after being received.

    Did you find any results for your Sender xxx@gmail.com and recipient faxes@yourdomain ?

    If not, the message was not delivered to your system.

    Btw, your Output does not look like from Exchange Online but from your local instance. Did you run it on your Exchange Online as instructed in the earlier post ?

    Regards,
    Martin

    Wednesday, September 24, 2014 5:57 AM
  • Hi Blackbox,

    what does that mean exactly:

    I've checked the message tracking log as your advise, and there is not a single instance of "DELIVER STORE" (in any case, or concatenation)... I am also unable to determine where the messages went after being received.

    Did you find any results for your Sender xxx@gmail.com and recipient faxes@yourdomain ?

    If not, the message was not delivered to your system.

    Btw, your Output does not look like from Exchange Online but from your local instance. Did you run it on your Exchange Online as instructed in the earlier post ?

    Regards,
    Martin

    Hi Martin,

    In reverse order....

    On-premise Exchange only; we're not using Exchange Online. To my mind, that means a 'hybrid' deployment, but I see now that there is actually a 'hybrid' built into EAC which is not enabled. We're just using O365 for Office and Lync at this time.

    I did find several messages in my call to Get-MessageTrackingLog in Exchange Management Shell, from which I posted one above... You did not specify Exchange Online above (only in the post I quote here), thus the On-Premise Exchange query output.

    My statement is explicit in meaning... In the resultant output from Exchange Management Shell, where I called the Get-MessageTrackingLog Cmdlet as you suggested, there is no instance of "DELIVER STORE" entry.

    Since no 'bounce' message was returned, the message was delivered, but does not show in target.

    Cheers


    Potential has a shelf life - Margaret Atwood

    Wednesday, September 24, 2014 12:29 PM

  • as you described there was no error bounce when you sent to faxes@yourdomain , so it has been accepted, while it was not delivered to a place you already found in your Investigation.

    Well hell's bells... I just received my first bounce:

    Delivery has failed to these recipients or groups:
    faxes@SomeDomain.com (faxes@SomeDomain.com)
    The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk.
    
    
    
    
    
    Diagnostic information for administrators:
    Generating server: EX01.SomeDomain.local
    faxes@SomeDomain.com
    Remote Server returned '550 4.4.7 QUEUE.Expired; message expired in unreachable destination queue. Reason: There is currently no route to the mailbox database.'
    Original message headers:
    Received: from EX01.SomeDomain.local (SomeIPAddress) by
     EX01.SomeDomain.local (SomeIPAddress) with Microsoft SMTP Server (TLS)
     id 15.0.847.32; Mon, 22 Sep 2014 08:48:02 -0400
    Received: from EX01.SomeDomain.local ([fe80::80ea:af67:fd7d:49]) by
     EX01.SomeDomain.local ([fe80::80ea:af67:fd7d:49%12]) with mapi id
     15.00.0847.030; Mon, 22 Sep 2014 08:47:55 -0400
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: Some User <SomeUser@SomeDomain.com>
    To: Faxes <faxes@SomeDomain.com>
    Subject: Test
    Thread-Topic: Test
    Thread-Index: Ac/WY2tGi4bHciVCSZecjTB47A77LQ==
    Date: Mon, 22 Sep 2014 08:47:55 -0400
    Message-ID: <8f25a2e9c7364952ab69f44ae71695fb@EX01.SomeDomain.local>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach:
    X-MS-TNEF-Correlator: <8f25a2e9c7364952ab69f44ae71695fb@EX01.SomeDomain.local>
    MIME-Version: 1.0
    X-Originating-IP: [192.168.120.61]
    Return-Path: SomeUser@SomeDomain.com



    Potential has a shelf life - Margaret Atwood

    Wednesday, September 24, 2014 1:09 PM