locked
Can not install IE9 on Windows 7 RRS feed

  • Question

  • Hi !

    We are deploying IE9 via SUP in SCCM 2007 and it keeps failing on almost 50% of the computers in our environment. We are deploying this to Windows 7 computers.

    I've tried most solutions I've found on when googling.
    This is my notes from my testing.

    Solution web link Result Comment
    KB2482017 N/A Only applicable on XP
    KB2483185 N/A Only applicable on XP
    KB2485376 N/A Only applicable on XP
    KB2496930 N/A Only applicable on XP
    KB2393802 N/A Only applicable on XP
    KB2479628 N/A Only applicable on XP
    MicrosoftFixit50531.msi Fail Tested by SWD team
    MicrosoftFixit50202.msi Fail Tested by SWD team
    KB2399238 http://support.microsoft.com/kb/2399238 Fail This patch is not needed at all our environment
    KB2454826-v2-x86.msu Fail "This patch is not needed at all on our env. 
    Webreports says 0 required"
    KB2328240 http://support.microsoft.com/kb/2328240
    KB947821 http://www.microsoft.com/en-us/download/details.aspx?id=3132 Fail "This is System Readines Update Patch from Microsoft.
    Tested by Poland"
    KB2720211 "Server Fix, not applicable. 
    Failing and Succeeded installations use the same Server
    And all client versions are the same"

    ***This is Log file from en failed Installation***

    00:00.000: ====================================================================
    00:00.031: Started: 2013/07/22 (Y/M/D) 12:29:23.615 (local)
    00:00.062: Time Format in this log: MM:ss.mmm (minutes:seconds.milliseconds)
    00:00.093: Command line: "C:\Windows\SoftwareDistribution\Download\Install\WU-IE9-Windows7-x86.exe" /WSUS 
    00:00.109: INFO:    Setup installer for Internet Explorer: 9.0.8112.16421
    00:00.140: INFO:    Previous version of Internet Explorer: 8.0.7601.18126
    00:00.171: INFO:    Checking if iexplore.exe's current version is between 9.0.6001.0...
    00:00.187: INFO:    ...and 9.1.0.0...
    00:00.296: INFO:    Maximum version on which to run IEAK branding is: 9.1.0.0...
    00:00.421: INFO:    iexplore.exe version check success. Install can proceed.
    00:00.483: INFO:    Trying to extract ID: 6006 (0) as "IE9-neutral.Extracted.cab"
    00:00.639: ERROR:   Failed to extract a language pack for a non-english OS.

    00:00.764: INFO:    This is an English only package, so installation will continue on this non-English OS.
    00:00.858: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-csy.cab
    00:00.936: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-dan.cab
    00:01.014: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-bgr.cab
    00:01.092: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-nld.cab
    00:01.107: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-fin.cab
    00:01.154: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-fra.cab
    00:01.185: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-deu.cab
    00:01.232: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-hun.cab
    00:01.279: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-ita.cab
    00:01.341: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-nor.cab
    00:01.404: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-plk.cab
    00:01.466: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-ptg.cab
    00:01.544: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-rom.cab
    00:01.575: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-rus.cab
    00:01.607: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-slv.cab
    00:01.622: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-sve.cab
    00:01.669: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-eti.cab
    00:01.685: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-lvi.cab
    00:01.716: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-lth.cab
    00:01.747: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-srl.cab
    00:01.778: INFO:    IE Setup Language pack included: C:\Windows\TEMP\IE9B168.tmp\ieLangPack-sky.cab
    00:01.809: INFO:    Trying to extract ID: 5006 (0) as "IE9-support.cab"
    00:02.402: INFO:    Operating System: Windows Workstation: 6.1.7601 (Service Pack 1)
    00:02.449: INFO:    Windows 7 operating system detected.
    00:02.465: INFO:    Service pack major: 1
    00:02.480: INFO:    Service pack minor: 0
    00:02.511: INFO:    Service pack name:  Service Pack 1
    00:02.558: INFO:    The neutral pack was not successfully downloaded from the internet. Installation will continue using the extracted package.
    00:02.917: INFO:    No reboot logic message NrApiStart(0), lParam=0x001328a8 returned 0x00000000.
    00:03.978: INFO:    No reboot logic message NrApiScan(1), lParam=0x00000001 returned 0x00000000.
    00:03.993: INFO:    No reboot logic message NrApiStartInstall(4), lParam=0x00000001 returned 0x00000014.
    00:04.009: INFO:    Installing with the extracted package. C:\Windows\TEMP\IE9B168.tmp\IE9-neutral.Extracted.cab
    00:04.118: INFO:    Launched package installation: C:\Windows\system32\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE9B168.tmp\IE9-neutral.Extracted.cab /quiet /norestart
    00:24.352: INFO:    Process exit code 0x800B0101 (-2146762495) [A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file. ]
    00:24.383: ERROR:   Neutral MSU installation failed (exit code = 0x800b0101 (2148204801)).
    00:24.398: INFO:    Launched package installation: C:\Windows\system32\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE9B168.tmp\ieLangPack-csy.cab /quiet /norestart
    00:28.158: INFO:    Process 'C:\Windows\system32\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE9B168.tmp\ieLangPack-csy.cab /quiet /norestart' exited with exit code 0x800F081E (-2146498530)
    00:28.189: ERROR:   Language package installation failed (exit code = 0x800f081e (2148468766)).
    00:28.220: INFO:    No reboot logic message NrApiInstallDone(7), lParam=0x800f081e returned 0x00000000.
    00:28.236: INFO:    No reboot logic message NrApiStartFinish(11), lParam=0x00000000 returned 0x00000000.
    00:28.252: INFO:    No reboot logic message NrApiFinish(12), lParam=0x00000000 returned 0x00000016.
    00:28.283: INFO:    An unknown error occurred. Check the return value online as a Windows Error Value for more information.  Setup exit code 0x800F081E (-2146498530)
    00:28.330: INFO:    Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
    00:49.421: ERROR:   SQM Upload failed while uploading "C:\Windows\system32\config\systemprofile\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup0.sqm" with error: 2147500036
    00:49.452: INFO:    Cleaning up temporary files in: C:\Windows\TEMP\IE9B168.tmp
    00:50.092: INFO:    Unable to remove directory C:\Windows\TEMP\IE9B168.tmp, marking for deletion on reboot.
    00:50.154: INFO:    Released Internet Explorer Installer Mutex

    **************************

    I'm happy for any suggestions, I have almost 18.000 that needs this update, and 50% failure is not really something I want to deal with.



    // Kristian


    • Edited by D.U.C.K Friday, August 9, 2013 11:38 AM
    Friday, August 9, 2013 11:22 AM

All replies

  • ***This is Log file from en failed Installation***

    00:00.031: Started: 2013/07/22 (Y/M/D) 12:29:23.615 (local)

    00:24.352: INFO:    Process exit code 0x800B0101 (-2146762495) [A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file. ]
    00:24.383: ERROR:   Neutral MSU installation failed (exit code = 0x800b0101 (2148204801)).


    I suspect that is the most significant message from your log.  When was this supposed to have been done?   ; )

     
    HTH



    Robert Aldwinckle
    ---

    Friday, August 9, 2013 3:43 PM
    Answerer
  • Hi Robert !

    Thanks for Answering.
    I did see that one too. Although I have not been able to figure out which certificate I'm supported to look at. So I really do not know what to do.

    I did try this solution "certutil -urlcache * delete" without success.


    // Kristian

    Friday, August 9, 2013 4:44 PM
  • maybe you can check the validity dates on the packages, they might have expired if they were downloaded more than 6 months ago, so you might need to download a fresh set?

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Saturday, August 10, 2013 9:03 AM
  • Maybe the root certificate is out of date, try update them.

    http://catalog.update.microsoft.com/v7/site/Search.aspx?q=root%20certificate%20xp


    • Edited by Samus-Aran Saturday, August 10, 2013 9:15 AM
    Saturday, August 10, 2013 9:15 AM
  • Hi Don, Thanks for replying. But I do not believe it is a package problem, if it were, shouldn't all installations fail then? Now only about 50% fails.

    // Kristian

    Saturday, August 10, 2013 9:28 AM
  • ah. I was not sure if you had successfully deployed to %50 over some time, and were now trying to diagnose why the remainder would not deploy.

    if some succeed and some fail, within a present/current deployment, then I would look to those failed client, and check if they are having successful or failed conversations with other packages that are signed with the same certificate chain.
    MS did revoke and renew certificate chains for update package signature about 6 months ago, and maybe your mixed success is due to some clients are updated with the new WUAgent and root certs, and some clients are not updated?

    I would start by examining the signature and certificate chain on the IE9 package, and then examine the certificate store of a failing client machine. do this on a failing client, if that client cannot validate the certificate chain of that package, this should reveal the revoked or expired cert in the chain. Then you just need to work out how to acquire and deploy the updated intermediate or root certs.


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Saturday, August 10, 2013 11:49 AM
  • 00:00.031: Started: 2013/07/22 (Y/M/D) 12:29:23.615 (local)

    When was this supposed to have been done?   ; )

    I really do not know what to do.

    I didn't think my hint was that obscure.  If the log was supposed to be from a few days ago (from yesterday), the date shown might be enough to invalidate a certificate.  So I was implying that it might be necessary to fix the date on the machine involved.

     



    Robert Aldwinckle
    ---

    Saturday, August 10, 2013 1:11 PM
    Answerer
  • Hi Kristian,

    The problem is likely incompatible editions. In other words, you probably tried to add an Enterprise or Ultimate language pack to a Professional image of Windows 7. You must add language packs of the same edition as the image you are building.

    Troubleshooting error 0x800f081e

    http://social.technet.microsoft.com/wiki/contents/articles/15348.troubleshooting-error-0x800f081e.aspx

    You can try these steps to check the results:

    Piloting in Windows 7

    http://technet.microsoft.com/en-us/library/ff986260.aspx

    Hope these could be helpful and keep post.


    Kate Li

    TechNet Community Support

    Monday, August 12, 2013 2:42 AM
  • Hi !

    Thnx for answering agan, but I never mentioned that the log would be only a few days old. I just took one of them and uploaded it here, the date is correct.
    The dates is something I already checked before posting the issue here.


    // Kristian

    Monday, August 12, 2013 10:03 PM
  • Hi Kate.

    We only use Windows7 Enterprise in our environment.
    We have built all out computers via SCCM, and there's only one production deployment.

    But, to make sure, I'll check if there are any nonstandard Windows installations out there.
    Thnx.


    // Kristian

    Monday, August 12, 2013 10:10 PM
  • Hi Kristian, 

    I am not sure if you are still facing the same issues and also not sure whether the fix I am going to suggest applies due to the fact that it is not affecting all of your clients. 

    But from my experience the error code exit code = 0x800b0101 (2148204801) is due to a badly signed binary released from MS and KB2749655 might help with this issue. 

    I have also written the following article about it: http://theplatformadmin.blogspot.co.uk/2013/09/fix-windows-features-showing-blank-and.html

    Hope this helps, 

    Manuel


    Manuel Toussaint

    Monday, September 23, 2013 11:59 AM