none
Group Policy Preference Registry not applying instantly

    Question

  • Hi,

    I created a Group Policy that adds a registry key. This GPO applies to computers.  The problem is that I noticed that some computers receives this specific GPO faster than others.  

    This is what I exactly have to do to make it faster... I have to login locally to the computer and gpupdate /force it, reboot then wait more/less 15 minutes.  

    But I can't do this for all machines on the network.  What should I do to force this or apply faster without logging in locally to computers? I did GPResult using GPMC and the Registry GPO I created is not listed in the "Applied Group Policy".  However, if I gpupdate locally and do the above steps, it will eventually show up.

    Pls. advice. Thanks!

    Tuesday, September 27, 2016 6:05 PM

Answers

  • Hi,

    Some registry settings will read the value at boot. Please make sure these problematic computers have restarted.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by DoBongSoon Thursday, September 29, 2016 4:53 PM
    Thursday, September 29, 2016 9:34 AM
    Moderator

All replies

  • By default, clients run background refresh of policy every 90+-30 minutes. So it can take up to two hours before the change is applied. You can use  "Group Policy refresh interval for computers" policy (under Computer Configuration\Administrative Templates\System\Group Policy) to change update rate (You'll still have to wait up to two hours before clients are updated with the new refresh interval though).

    Also, check that registry policy is processed during background refresh - this is controlled by "Do not apply during periodic background processing"  policy.


    Gleb.

    Wednesday, September 28, 2016 8:03 AM
  • I forgot to say that it is over 48 hours and the GPUpdate does not still apply automatically.  But again only if I have to login locally to the computer and gpupdate /force it, reboot then wait more/less 15-30 minutes it shows up. So I know that my settings work.  Unless because I am an admin and it only applies if an admin logs in??

    Wednesday, September 28, 2016 3:55 PM
  • Hi,

    Some registry settings will read the value at boot. Please make sure these problematic computers have restarted.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by DoBongSoon Thursday, September 29, 2016 4:53 PM
    Thursday, September 29, 2016 9:34 AM
    Moderator
  • Hi,

    I feel so stupid on this.  Of course I know it had to reboot my computers and used my "SCCM" to reboot the machines.  However, the problematic machines did not reboot properly because the reboot was not forced (meaning they have open files causing the pending of reboot) therefore, no reboot happened.

    Thank you so much. I have always relied on my SCCM for reboot and I should've looked at that first.

    Thursday, September 29, 2016 4:56 PM
  • Hi,

    I am glad to hear that the information is helpful to you. If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 30, 2016 1:54 AM
    Moderator