locked
SharePoint Designer disabled when going to edit a page using sharepoint designer RRS feed

  • Question

  • hi all,

     I'm very new in share point 2010..i'm facing a problem that when i'm going to  design a page by clicking "Edit With SharePoint Designer" (from site action tab), Share Point Designer is not being enabled..i checked general application settings--> configure share point designer settings as  well

    site collection  administrator-->share point designer settings..they all are checked..still m not being able to edit my page with sharepoint designer..

    i also checked ONET.xml file and  Central administration” > Security > Specify authentication provider...still it is not working...pls help...
    Monday, January 9, 2012 10:57 AM

Answers

  • Hi ,

     

    What do mean by ‘SharePoint Designer is not enabled ‘? The ‘Edit in SharePoint Designer ’ option is not there or it is greyed out?

     

    If the ‘Edit in SharePoint Designer ’ is not there ,then you don’t have the permission  to edit the page in SharePoint designer .You must be in the Designer , Hierarchy Manager ,or Site Owner group in order to open the site in SharePoint Designer .

     

    When you click on ‘Edit in SharePoint Designer ’,does it prompt to download designer ?If so ,you should make sure that the SharePoint OpenDocument Class add on is enabled in IE .

     

    For more information about the OpenDocument Class add on ,please refer to this site:

    If the Open command doesn’t work, download your document : http://office.microsoft.com/en-us/web-apps-help/system-requirements-for-opening-files-from-office-web-apps-in-office-desktop-applications-HA010378334.aspx

     

    Thanks

    Entan Ming

    TechNet Community Support

    • Marked as answer by Entan Ming Friday, January 20, 2012 3:25 AM
    Tuesday, January 10, 2012 7:36 AM

All replies

  • is Sharepoint Designer installed on your machine? If yes are you able to open your site in designer?
    Ujwal Seli
    • Edited by Ujwal Seli Monday, January 9, 2012 11:13 AM
    Monday, January 9, 2012 11:13 AM
  • yes it is 2010
    Monday, January 9, 2012 11:14 AM
  • i mean Sharepoint Designer 2010
    Monday, January 9, 2012 11:14 AM
  • Hi ,

     

    What do mean by ‘SharePoint Designer is not enabled ‘? The ‘Edit in SharePoint Designer ’ option is not there or it is greyed out?

     

    If the ‘Edit in SharePoint Designer ’ is not there ,then you don’t have the permission  to edit the page in SharePoint designer .You must be in the Designer , Hierarchy Manager ,or Site Owner group in order to open the site in SharePoint Designer .

     

    When you click on ‘Edit in SharePoint Designer ’,does it prompt to download designer ?If so ,you should make sure that the SharePoint OpenDocument Class add on is enabled in IE .

     

    For more information about the OpenDocument Class add on ,please refer to this site:

    If the Open command doesn’t work, download your document : http://office.microsoft.com/en-us/web-apps-help/system-requirements-for-opening-files-from-office-web-apps-in-office-desktop-applications-HA010378334.aspx

     

    Thanks

    Entan Ming

    TechNet Community Support

    • Marked as answer by Entan Ming Friday, January 20, 2012 3:25 AM
    Tuesday, January 10, 2012 7:36 AM