locked
Cannot login after sleep, Win7 B.7100. Have a way around... RRS feed

  • Question

  • I let my ASUS H2500 go into sleep. I got no battery so I don't let it shut of my display in powersettings e.t.c.
    After waking, ex. tuching "space"-key, I cannot login. "Wrong password..."
    I have tried several ways of letting components load or just wait a few minutes. Nothing halps. Then!
    I just loaded the alternatet login to change user and a new screen let me choose one of my managed users.
    The same apperance meets me for another try at the login screen. This time it is ok and my password is "get" from correct place...
    Is is a bug? Have some one else reported this? I made a breaf sweep at the forum but didn't see a simular problem.

    I'm a advanced user with long experience but no license or MS education though I have some knowledge working as a super administrator and supervisor/manager at a Highschool aprox 250 computers and relevant servers, all MS.

    Now I have tested Win7 Beta and  this evaluation copy 7100 of RC1. It's nice and work fine. I still try to battle out between Ubuntu and Win as many times as I can but now Win7 have an advantage. Ubuntu 9x is still free for me as a small company CEO.

    I hope you will take this in consideration of free this Bug of the system... :-)

    Best Regards
    -------------- Pioter Janeling, Sweden Percointor.se Information & Utredning
    Monday, August 31, 2009 8:11 AM

Answers

  • Some features need to be reset. Don't ask me why.
    Just try:

    uncheck the require login after wake from sleep in power config - save it - return and recheck it - save that

    You've got a fair chance this works.

    Regards

    Rem
    • Marked as answer by Nicholas Li Monday, November 30, 2009 2:03 AM
    Tuesday, September 8, 2009 12:34 PM

All replies

  • I have a similar issue. I'm running Windows 7 Professional (courtesy of MSDNAA through my university) which I installed 2 days ago. Twice in this time, I've woken my laptop from sleep and it's decided to reject my password. I haven't forgotten it, and I'm not mistyping it - I try it again slowly about 10 times, but it still rejects it. I'm the only user profile, so clicking 'Switch User' just ends up asking me for my password again, which will still be rejected.

    Rebooting fixes it, and it accepts my password first time after the reboot. But rebooting is not an adequate solution for this because I regularly keep a lot of windows open and have work in progress open, and rebooting will lose all my windows and anything I haven't saved.

    This never happened in the 1.5 years that I ran Vista Home Premium on my laptop before loading Win7.
    Wednesday, September 2, 2009 2:49 PM
  • Wierd. My laptop have been put into sleep many times but have not encountered this problem at all.

    Also using 7 Pro courtesy MSDNAA.

    Rgds
    Thursday, September 3, 2009 1:52 PM
  • Hi,

     

    When you are touching “Space” key, please ensure that you have not input “Space” to the password box.


    Nicholas Li - MSFT
    Friday, September 4, 2009 11:52 AM
  • What?

    I already said that the password is right. I'm not mistyping it. I wouldn't be posting here if it was just an issue of "whoops, I typed it wrong".

    My password is a combination of lower case, upper case, numbers and symbols, so I quite like it and think it's pretty strong. Apparently it's too strong for Windows 7 and it decides to reject it after waking from sleep. This has happened another 4 times since my last post, and each time has required me to reboot to get it to stop being silly and accept my password.

    I've now had to remove my password from my user account. I'm not happy with having to do this, and I'm sure that if this bug happens to someone else, then rebooting or going without a password won't be an acceptable solution.
    Tuesday, September 8, 2009 12:07 PM
  • Some features need to be reset. Don't ask me why.
    Just try:

    uncheck the require login after wake from sleep in power config - save it - return and recheck it - save that

    You've got a fair chance this works.

    Regards

    Rem
    • Marked as answer by Nicholas Li Monday, November 30, 2009 2:03 AM
    Tuesday, September 8, 2009 12:34 PM
  • I've run into the same problem running windows 7 home on my HP 5101 netbook.  Problem was an issue with the RC but I thought it would be fixed in the final version but after a few days after reinstalling win7 the same problem returned.  Reseting the login after wake feature as suggested above didn't help.  However I can click the switch user button and then login to the same account (the only one I have) with the same password that it was just rejecting.  So at least I don't have to reboot.  
    Saturday, December 5, 2009 5:58 AM
  • I will certainly agree with you Apopc.  I have a HP 5101, with exactly the same problem.  I freshly installed the system with Windows 7 Professional, and have it fully up & running with all drivers.  After I added the system to the company Domain, I started having this problem when I woke it from sleep.  I found it didn't like the Domain Admin account or my own User Account (on domain.)  If I selected switch users, and used a 'Local' account on the system, it logged in fine - and then I could log out and back in as my own account.
    I have gone in and removed all power conservation settings on the network adapter, thinking it may be that - but this does not fix the issue.  In hindsight I realized the system was caching the credentials also.

    Now, a strange thing that did occur is that if the HP 5101 is not connected to any network, at the time, it then does allow me to log in okay.  So it seems like it wakes from sleep, polls the network when you try and login - and it has dumped the connection.  Then it refuses to use cached logins.

    If it's detached however, it appears to check for a network connection, finds nothing and then looks up cached credentials.

    Totally got me on this one - will be getting the system 'not' to prompt for credentials on waking up - as seeing that appears to be the only workaround.

    Anyone else got thoughts as well on this?
    Wednesday, December 9, 2009 11:55 AM
  • Was this ever resolved?

    Im having the same issue almost a year later on Windows 7 Enterprise.

    When waking up from sleep, my domain user account gets locked out after typing the right password 3 times.

     

    Friday, July 30, 2010 4:58 AM
  • Yes, I resolved my issue at least.  And I'm a bit ashamed about it to tell the truth.

    I was using my netbook with an external display and keyboard a lot.  Well, I'd turn the numlock on to use the 10 key on the keyboard.  When I disconnected, the numlock would stay on, but my machine has no light to indicate this.  The 10 key on my netbook overlays with some of the letters, so when I typed in my password, some of the letters were actually being inputted as numbers, and thus I was not able to log in.   Clicking the switch user button appears to reset the numlock to off so then I was able to sign in.

    So my simple advice, don't be an idiot like me and check your numlock.

    Friday, July 30, 2010 5:08 AM
  • Apopc, you are not an idiot nor did you fix the problem. It will be back, I guarantee it. The problem has been long standing and is still not resolved. I am taking all 25 Windows 7 machines back from testing and not moving forward with my Windows 7 rollout until Microsoft does something about it. Support costs have skyrocketed because of this problem.

    FYI I have done everthing suggested that makes sense. The latest thing I found was that the Windows Firewall was blocking NetLogon and forcing cached credential use. That must have come out in an update because it was not previously set. Brilliant!!!! tells me Microsoft is grasping at straws.... Again! Here we go Visat all over again.  I'm taking my users back to XP SP2... the last version that required the least amount of support.

    There is one thing that does fix it. A full re-install and then turning off Automatic updates. Do not install any updates and you'll be fine.

    Yes, I am extremely unhappy. Why? Because I should not have to modify each and every workstation I build and I should not have to visit user desktops every hour so they can go back to work.

    I also should never be able perform a search on this subject and find this many posts and related subjects with such lame responses for fixes. Am I not signed into Technet?

    Monday, December 20, 2010 4:34 PM
  • Im having the same problem only Im not getting the option to sign in under another user. What should I do now?
    Thursday, February 10, 2011 6:08 AM
  • I should have responded to this earlier when I found the problem. The problem is with improperly setup DNS and overloaded RPC calls, (simplest way to say it.)

    1. Run dcdiag /v /d /e /c > c:\diagtest.txt. from your primary DC. Open up the file diagtest.txt and look for high latency and problems about forwarders. The high latency is probably because of network cards on DC's that have the offloading enabled and don't have current drivers. The forwarder problem is a common one when external DNS servers are used to compliment the internal DNS servers. Get rid of the forwarders and use root hints or put them on the furthest out firewall, gateway or proxy server.

    If W7 doesn't get a response from a DNS server that tells it where the nearest GC is because of heavy RPC traffic (outdated NIC drivers) then it will keep looking and if it trys a DNS server outside the company it will obviously fail. This in turn will cause your local credentials to not be refreshed and that will cause you to get a logon failure. It's a lot more complex than that but I'd rather not detail it all out, you can read about all that in the docs.

    This process will begin with the notices about your local credentials needing to be updated.

    I scrubbed my entire ifrastructure and fixed all the DNS and WINS problems. It's a lot of work on a large network but I can now safely proceed with my W7 rollout. I think W2K3 Pro was a little lax about the importance of current credentials.


    Steve Schefer
    Thursday, February 10, 2011 6:55 AM