locked
Cannot upgrade Client from 2007 to 2012 R2 RRS feed

  • Question

  • Hello,

    We've migrated from SCCM 2007 to SCCM 2012 R2, however there are still a few Workstations that cannot get the new Client.

    I was told (because I was not the one setting it up), that launching the setup for the new Client should automatically uninstall the old one. This didn't work, so I'm trying to manually uninstall the old Client first. This is what's happening:

    <![LOG[Uninstalling product '{2609EDF1-34C4-4B03-B634-55F3B3BC4931}'.]LOG]!><time="09:04:18.428+00" date="11-16-2015" component="ccmsetup" context="" type="1" thread="3256" file="msiutil.cpp:1168">
    <![LOG[Running installation package
      Product:     {2609EDF1-34C4-4B03-B634-55F3B3BC4931}
      Log:         C:\Windows\ccmsetup\Logs\client.msi_uninstall.log
      Properties:  ]LOG]!><time="09:04:18.428+00" date="11-16-2015" component="ccmsetup" context="" type="1" thread="3256" file="msiutil.cpp:1085">
    <![LOG[Installation failed with error code 1612]LOG]!><time="09:04:19.873+00" date="11-16-2015" component="ccmsetup" context="" type="3" thread="3256" file="msiutil.cpp:1127">
    <![LOG[Failed to read assigned site code from registry. Error code = 0x80070002]LOG]!><time="09:04:19.877+00" date="11-16-2015" component="ccmsetup" context="" type="2" thread="3256" file="util.cpp:345">
    <![LOG[Params to send '5.0.8239.1001 Deployment Error: 0x8007064c, ']LOG]!><time="09:04:19.877+00" date="11-16-2015" component="ccmsetup" context="" type="0" thread="3256" file="state.cpp:215">
    <![LOG[Sending message with STATEID='301' via the existing client.]LOG]!><time="09:04:19.877+00" date="11-16-2015" component="ccmsetup" context="" type="1" thread="3256" file="state.cpp:363">
    <![LOG[Adding client deployment state message.]LOG]!><time="09:04:19.890+00" date="11-16-2015" component="ccmsetup" context="" type="1" thread="3256" file="state.cpp:375">
    <![LOG[Failed to send state message via the existing client. Error 0x80041002]LOG]!><time="09:04:19.891+00" date="11-16-2015" component="ccmsetup" context="" type="2" thread="3256" file="state.cpp:411">
    <![LOG[Failed to send status 301. Error (80041002)]LOG]!><time="09:04:19.891+00" date="11-16-2015" component="ccmsetup" context="" type="3" thread="3256" file="state.cpp:242">
    <![LOG[CcmSetup failed with error code 0x8007064c]LOG]!><time="09:04:19.891+00" date="11-16-2015" component="ccmsetup" context="" type="1" thread="3256" file="ccmsetup.cpp:10802">

    Does anyone have any ideas how to deal with this?

    Kind regards,

    Wojciech

    Monday, November 16, 2015 10:00 AM

Answers

  • Have you looked at C:\Windows\ccmsetup\Logs\client.msi_uninstall.log?

    The error is not coming from the new client install but from the uninstall of the old client. You may need to locate the client install files for the 2007 client and manually perform the uninstall from them first.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    • Proposed as answer by Frank Dong Monday, December 7, 2015 1:42 AM
    • Marked as answer by Frank Dong Tuesday, December 8, 2015 8:11 AM
    Tuesday, November 17, 2015 3:20 PM

All replies

  • net helpmsg 1612 -> will tell you details about the error. Make sure that the sources are still available. 

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, November 16, 2015 10:21 AM
  • How exactly are you initiating the uninstall?


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Monday, November 16, 2015 2:40 PM
  • Hi,

    Adding to Jason point, is it failed only to specific OS version ?


    Kannan.CS | http://kannancs.wix.com/blog | Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members reading the thread.

    Monday, November 16, 2015 3:24 PM
  • <![LOG[Installation failed with error code 1612]LOG]!>

    "The installation source for this product is not available. Verify that the source exists and that you can access it."

    As its calling the CCMSetup application, can you confirm this exists in C:\Windows\CCMSetup ?

    It is correct that running the 2012 installation will remove the old 2007 version.  Do you know how this update is being done?  GPO install etc?

    I'd advise finding the SCCM2012 Client installation from the SCCM server and running it on this machine.

    Monday, November 16, 2015 3:46 PM
  • Hi All,

    Thank you for your replies. Here are my comments:

    1) I have the 2012 Client I've used successfully on other machines.

    2) After the installation failed, I tried uninstalling it by ccmsetup.exe /uninstall

    3) All the files are in place, but there seems to be some product ID mismatch:

    SI (s) (D0:F0) [12:29:31:776]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (D0:F0) [12:29:31:777]: Warning: Local cached package 'C:\Windows\Installer\384c.msi' is missing.
    MSI (s) (D0:F0) [12:29:31:777]: User policy value 'SearchOrder' is 'nmu'
    MSI (s) (D0:F0) [12:29:31:777]: User policy value 'DisableMedia' is 0
    MSI (s) (D0:F0) [12:29:31:777]: Machine policy value 'AllowLockdownMedia' is 0
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Media enabled only if package is safe.
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Looking for sourcelist for product {2609EDF1-34C4-4B03-B634-55F3B3BC4931}
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Adding {2609EDF1-34C4-4B03-B634-55F3B3BC4931}; to potential sourcelist list (pcode;disk;relpath).
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Now checking product {2609EDF1-34C4-4B03-B634-55F3B3BC4931}
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Media is enabled for product.
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
    MSI (s) (D0:F0) [12:29:31:777]: SOURCEMGMT: Trying source C:\Windows\ccmsetup\{4CD82FBB-0AFC-4864-A089-15364DF5F14B}\.
    MSI (s) (D0:F0) [12:29:31:783]: SOURCEMGMT: Source is invalid due to invalid package code (product code doesn't match).
    MSI (s) (D0:F0) [12:29:31:783]: Note: 1: 1706 2: -2147483646 3: client.msi
    MSI (s) (D0:F0) [12:29:31:783]: SOURCEMGMT: Processing net source list.
    MSI (s) (D0:F0) [12:29:31:783]: Note: 1: 1706 2: -2147483647 3: client.msi
    MSI (s) (D0:F0) [12:29:31:783]: SOURCEMGMT: Processing media source list.
    MSI (s) (D0:F0) [12:29:32:792]: Note: 1: 2203 2:  3: -2147287037
    MSI (s) (D0:F0) [12:29:32:792]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
    MSI (s) (D0:F0) [12:29:32:792]: Note: 1: 1706 2: -2147483647 3: client.msi
    MSI (s) (D0:F0) [12:29:32:792]: SOURCEMGMT: Processing URL source list.
    MSI (s) (D0:F0) [12:29:32:792]: Note: 1: 1402 2: UNKNOWN\URL 3: 2
    MSI (s) (D0:F0) [12:29:32:792]: Note: 1: 1706 2: -2147483647 3: client.msi
    MSI (s) (D0:F0) [12:29:32:792]: Note: 1: 1706 2:  3: client.msi
    MSI (s) (D0:F0) [12:29:32:792]: SOURCEMGMT: Failed to resolve source
    MSI (s) (D0:F0) [12:29:32:792]: MainEngineThread is returning 1612
    MSI (s) (D0:20) [12:29:32:793]: User policy value 'DisableRollback' is 0
    MSI (s) (D0:20) [12:29:32:793]: Machine policy value 'DisableRollback' is 0
    MSI (s) (D0:20) [12:29:32:793]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (D0:20) [12:29:32:793]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (D0:20) [12:29:32:793]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (D0:20) [12:29:32:793]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (D0:20) [12:29:32:793]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (D0:20) [12:29:32:793]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (s) (D0:20) [12:29:32:793]: Restoring environment variables
    MSI (c) (88:94) [12:29:32:794]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (88:94) [12:29:32:795]: MainEngineThread is returning 1612

    Kind regards,

    Wojciech

    Monday, November 16, 2015 4:06 PM
  • Again, that's suggesting the your install source is corrupt/incomplete etc.

    As per my first message, I'd advise finding the SCCM2012 Client installation from the SCCM server and running it on this machine.

    Then once complete, can you upload the ccmsetup log file.

    Monday, November 16, 2015 6:24 PM
  • Hello Rich,

    Below are the last few lines of ccmsetup.log after running the SCCM 2012 Client Installation:

    <![LOG[Starting BITS download for client deployment files.]LOG]!><time="09:17:01.343+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="ccmsetup.cpp:6626">
    <![LOG[Download Update: Connecting to the server.]LOG]!><time="09:17:02.343+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="ccmsetup.cpp:6725">
    <![LOG[Successfully completed BITS download for client deployment files.]LOG]!><time="09:18:59.349+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="ccmsetup.cpp:6675">
    <![LOG[Retrieved client version '5.00.8239.1000' and minimum assignable site version '5.00.8200.1000' from client package]LOG]!><time="09:18:59.366+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="3176" file="siteinfo.cpp:704">
    <![LOG[Checking compatibility of site version '5.00.8239.1000', expect newer than '5.00.8200.1000']LOG]!><time="09:18:59.366+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="siteinfo.cpp:729">
    <![LOG[Site version '5.00.8239.1000' is compatible. Client deployment will continue.]LOG]!><time="09:18:59.366+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="siteinfo.cpp:754">
    <![LOG[Successfully downloaded client files via BITS.]LOG]!><time="09:18:59.366+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="ccmsetup.cpp:1353">
    <![LOG[An MP does not exist on this machine.]LOG]!><time="09:18:59.373+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="msiutil.cpp:596">
    <![LOG[Ccmsetup is instructed to always uninstall old client before installing new client.]LOG]!><time="09:18:59.373+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="msiutil.cpp:646">
    <![LOG[Source location is not under software distrubtion cache folder. No need to back up source.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="3176" file="preuninstallcopysource.cpp:51">
    <![LOG[No current reboot settings to backup.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="3176" file="uninstallpreservereboot.cpp:69">
    <![LOG[Start to uninstall wakeup proxy server]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="uninstallwakeupserver.cpp:35">
    <![LOG[wakeup proxy server is NOT installed]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="uninstallwakeupserver.cpp:51">
    <![LOG[CBackupClientState::PreUninstall: Start.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="preuninstallbackupclientstate.cpp:43">
    <![LOG[Error while calculating path to state file.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3176" file="clientstate.cpp:666">
    <![LOG[Loading the client state failed.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3176" file="clientstate.cpp:64">
    <![LOG[CBackupClientState::PreUninstall: Unable to establish if we are in maintenance mode. Probably because this is either a new installation, running with /forceinstall option OR an upgrade from a version that doesn't have a state file. Doing nothing.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="preuninstallbackupclientstate.cpp:48">
    <![LOG[A newer version client is being installed over an old client and uninstalling old client is necessary.  Uninstalling the old client.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="ccmsetup.cpp:8688">
    <![LOG[Uninstalling product '{2609EDF1-34C4-4B03-B634-55F3B3BC4931}'.]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="msiutil.cpp:1168">
    <![LOG[Running installation package
      Product:     {2609EDF1-34C4-4B03-B634-55F3B3BC4931}
      Log:         C:\Windows\ccmsetup\Logs\client.msi_uninstall.log
      Properties:  ]LOG]!><time="09:18:59.425+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="msiutil.cpp:1085">
    <![LOG[Installation failed with error code 1612]LOG]!><time="09:19:00.449+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3176" file="msiutil.cpp:1127">
    <![LOG[InstallFromManifest failed 0x8007064c]LOG]!><time="09:19:00.450+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3176" file="ccmsetup.cpp:7345">
    <![LOG[Params to send '5.0.8239.1001 Deployment Error 0x8007064c.']LOG]!><time="09:19:00.450+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="3176" file="state.cpp:215">
    <![LOG[Sending message with STATEID='313' via the existing client.]LOG]!><time="09:19:00.450+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="state.cpp:363">
    <![LOG[Adding client deployment state message.]LOG]!><time="09:19:00.463+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3176" file="state.cpp:375">
    <![LOG[Failed to send state message via the existing client. Error 0x80041002]LOG]!><time="09:19:00.464+00" date="11-17-2015" component="ccmsetup" context="" type="2" thread="3176" file="state.cpp:411">
    <![LOG[Failed to send status 313. Error (80041002)]LOG]!><time="09:19:00.464+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3176" file="state.cpp:242">
    <![LOG['Configuration Manager Client Retry Task' is scheduled to run at 11/17/2015 02:19:00 PM (local) 11/17/2015 02:19:00 PM (UTC) time with arguments ' "/FORCEINSTALL" "/mp:xxx.xxx.xx.xx " "SMSSITECODE=xxx" "CCMLOGLEVEL-0" "SMSCACHESIZE=10240" /RetryWinTask:1'.]LOG]!><time="09:19:00.465+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3064" file="wintask.cpp:327">
    <![LOG[ITaskService::GetFolder failed with 0x80070003]LOG]!><time="09:19:00.465+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3064" file="wintask.cpp:636">
    <![LOG[CcmSetup failed with error code 0x8007064c]LOG]!><time="09:19:00.564+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3064" file="ccmsetup.cpp:10802">

    Kind regards,

    Wojciech

    Tuesday, November 17, 2015 9:25 AM
  • Hi Wojciech,

    Can you confirm the install command line you are using please.

    I wonder if you are using the /source ? 

    Rich

    Tuesday, November 17, 2015 9:54 AM
  • Hi Rich,

    I'm using the following script:

    @ECHO OFF
    "\\wawvmfs01\Installs\Software\SCCM\2012\ccmsetup.exe" /FORCEINSTALL /mp:mpname.mycompany.net SMSSITECODE=STH CCMLOGLEVEL-0 SMSCACHESIZE=10240
    EXIT

    Kind regards,

    Wojciech

    Tuesday, November 17, 2015 10:38 AM
  • Ok, lets take it for what it's saying still, that it can't find some necessary files.

    Can you copy the whole ConfigMgr\Client folder (from your site server, either progfiles or off the Client Share) onto the local machine, say C:\Temp\Client

    Then lets tell the installer to use the local copy of those files by adding the below switch to you install line (also call ccmsetup.exe from local)

    /Source:C:\Temp\Client

    As a side note, I assume it was a typo in you last post..  CCMLOGLEVEL-0 ..  Should be = not -.

    Rich

    Tuesday, November 17, 2015 1:09 PM
  • Hi Rich,

    I have done as suggested and modified the script:

    @ECHO OFF
    "C:\Temp\2012\ccmsetup.exe" /SOURCE:C:\Temp\2012 /FORCEINSTALL /mp:mpname.mycompany.net  SMSSITECODE=STH CCMLOGLEVEL=0 SMSCACHESIZE=10240
    EXIT

    Just to make sure I copied the correct files, this is the content of C:\Temp\2012

    Unfortunately this did not help much:

    <![LOG[Site version '5.00.8239.1000' is compatible. Client deployment will continue.]LOG]!><time="13:50:37.874+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="siteinfo.cpp:754">
    <![LOG[Successfully downloaded client files via BITS.]LOG]!><time="13:50:37.880+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="ccmsetup.cpp:1353">
    <![LOG[An MP does not exist on this machine.]LOG]!><time="13:50:37.899+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="msiutil.cpp:596">
    <![LOG[Ccmsetup is instructed to always uninstall old client before installing new client.]LOG]!><time="13:50:37.900+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="msiutil.cpp:646">
    <![LOG[Source location is not under software distrubtion cache folder. No need to back up source.]LOG]!><time="13:50:38.021+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="2928" file="preuninstallcopysource.cpp:51">
    <![LOG[No current reboot settings to backup.]LOG]!><time="13:50:38.021+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="2928" file="uninstallpreservereboot.cpp:69">
    <![LOG[Start to uninstall wakeup proxy server]LOG]!><time="13:50:38.021+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="uninstallwakeupserver.cpp:35">
    <![LOG[wakeup proxy server is NOT installed]LOG]!><time="13:50:38.022+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="uninstallwakeupserver.cpp:51">
    <![LOG[CBackupClientState::PreUninstall: Start.]LOG]!><time="13:50:38.022+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="preuninstallbackupclientstate.cpp:43">
    <![LOG[Error while calculating path to state file.]LOG]!><time="13:50:38.022+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="2928" file="clientstate.cpp:666">
    <![LOG[Loading the client state failed.]LOG]!><time="13:50:38.022+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="2928" file="clientstate.cpp:64">
    <![LOG[CBackupClientState::PreUninstall: Unable to establish if we are in maintenance mode. Probably because this is either a new installation, running with /forceinstall option OR an upgrade from a version that doesn't have a state file. Doing nothing.]LOG]!><time="13:50:38.022+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="preuninstallbackupclientstate.cpp:48">
    <![LOG[A newer version client is being installed over an old client and uninstalling old client is necessary.  Uninstalling the old client.]LOG]!><time="13:50:38.022+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="ccmsetup.cpp:8688">
    <![LOG[Uninstalling product '{2609EDF1-34C4-4B03-B634-55F3B3BC4931}'.]LOG]!><time="13:50:38.023+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="msiutil.cpp:1168">
    <![LOG[Running installation package
      Product:     {2609EDF1-34C4-4B03-B634-55F3B3BC4931}
      Log:         C:\Windows\ccmsetup\Logs\client.msi_uninstall.log
      Properties:  ]LOG]!><time="13:50:38.023+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="msiutil.cpp:1085">
    <![LOG[Installation failed with error code 1612]LOG]!><time="13:50:39.451+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="2928" file="msiutil.cpp:1127">
    <![LOG[InstallFromManifest failed 0x8007064c]LOG]!><time="13:50:39.452+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="2928" file="ccmsetup.cpp:7345">
    <![LOG[Params to send '5.0.8239.1001 Deployment Error 0x8007064c.']LOG]!><time="13:50:39.453+00" date="11-17-2015" component="ccmsetup" context="" type="0" thread="2928" file="state.cpp:215">
    <![LOG[Sending message with STATEID='313' via the existing client.]LOG]!><time="13:50:39.454+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="state.cpp:363">
    <![LOG[Adding client deployment state message.]LOG]!><time="13:50:39.491+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="2928" file="state.cpp:375">
    <![LOG[Failed to send state message via the existing client. Error 0x80041002]LOG]!><time="13:50:39.492+00" date="11-17-2015" component="ccmsetup" context="" type="2" thread="2928" file="state.cpp:411">
    <![LOG[Failed to send status 313. Error (80041002)]LOG]!><time="13:50:39.492+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="2928" file="state.cpp:242">
    <![LOG['Configuration Manager Client Retry Task' is scheduled to run at 11/17/2015 06:50:39 PM (local) 11/17/2015 06:50:39 PM (UTC) time with arguments ' "/SOURCE:C:\Temp\2012" "/FORCEINSTALL" "/mp:mpname.mycompany.net" "SMSSITECODE=LKM" "CCMLOGLEVEL=0" "SMSCACHESIZE=10240" /RetryWinTask:1'.]LOG]!><time="13:50:39.497+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3688" file="wintask.cpp:327">
    <![LOG[ITaskService::GetFolder failed with 0x80070003]LOG]!><time="13:50:39.499+00" date="11-17-2015" component="ccmsetup" context="" type="3" thread="3688" file="wintask.cpp:636">
    <![LOG[CcmSetup failed with error code 0x8007064c]LOG]!><time="13:50:39.673+00" date="11-17-2015" component="ccmsetup" context="" type="1" thread="3688" file="ccmsetup.cpp:10802">

    Kind regards,

    Wojciech

    Tuesday, November 17, 2015 2:40 PM
  • Have you looked at C:\Windows\ccmsetup\Logs\client.msi_uninstall.log?

    The error is not coming from the new client install but from the uninstall of the old client. You may need to locate the client install files for the 2007 client and manually perform the uninstall from them first.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    • Proposed as answer by Frank Dong Monday, December 7, 2015 1:42 AM
    • Marked as answer by Frank Dong Tuesday, December 8, 2015 8:11 AM
    Tuesday, November 17, 2015 3:20 PM
  • Hi Jason,

    This is what I tired to do today:

    1) Open CMD in C:\Windows\ccmsetup and use ccmsetup.exe /uninstall

    2) Open CMD in C:\Windows\ccmsetup\{2609EDF1-34C4-4B03-B634-52F3B3BC4931} and use

        msiexec /x client.msi

    None of those methods do anything and, surprisingly, there is nothing being written to the log files.

    Kind regards,

    Wojciech

    Wednesday, November 18, 2015 12:27 PM
  • As Jason has suggested, perhaps now focus on removing the old client first as SCCM2012 install clearly install working.

    Does the old Configuration Manager still show in Control Panel?

    Try running the uninstall directly.

    ccmsetup.exe /uninstall

    Should that fail then check the Uninstall log for details.

    You can also try the msi uninstall after..

    msiexec /x client.msi /qb

    If neither work, get the content from the SCCM2007 server Client folder and try running the uninstall from there.

    Rich

    Wednesday, November 18, 2015 12:28 PM