locked
Welcome not updating after Name Change RRS feed

  • Question

  • We have:

    1. Changed the user name in AD.
    2. Let the profile run. 
    3. Search for old profile and non found.  (only finds new name)
    4. MYSite is updated with the new name but welcome is not
    Wednesday, January 4, 2012 3:50 PM

All replies

  • The welcome menu pulls the name from the UserInfo table, not from the Profile.  There are two timer jobs that synchronize the user Info table with the Profile.  The common problem is that those jobs only synchronize changes for users who are marked as active.  If a user gets their permissions from membership in an AD group and they have never "Contributed" something to the site collection then they will be marked as Inactive.  The fix is to have the user go to the site collection where the Welcome menu displays incorrectly and add an item to one of the lists or upload a document.  Then wait for the next round of Profile synchronization jobs to run.
    Paul Stork SharePoint Server MVP Chief SharePoint
    Architect: Sharesquared Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.
    Wednesday, January 4, 2012 3:59 PM
  • Hi,

    I agree with Paul ad Rashu. I suggest that you follow their advice to check your settings.

    If you have any questions, drop me a note freely.

    Thanks,

    Rock Wang

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

     


    Rock Wang TechNet Community Support
    Thursday, January 5, 2012 2:46 AM