locked
Office 2013 ODT The operating system is not presently configured to run this application RRS feed

  • Question

  • hi!

    We have RDS 2012 R2 setup up and running with session host, connection broker, rd gateway and rd web. AS office 2013 can be deployed using APP-V 5 SP2, we have created .appv pkg using ODT as mentioned in this guide . It was working fine for 2 days and then suddenly we started to get error popup window saying "The operating system is not presently configured to run this application" . We are receiving this error on Session host server(win 2k12 r2) which is App-V 5 sp2 client, when we try to open any office 2013 app.

    And If check on App-v server which is also a publishing server. In event viewer i see this log entry.

    Log Name:      Microsoft-AppV-Server-Publishing/Admin
    Source:        Microsoft-AppV-Server-Publishing
    Event ID:      215
    Level:         Error
    Description:
    The request URL doesn't contain the query string for the client OS.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-AppV-Server-Publishing" Guid="{825C7963-9E32-4E3B-B74A-DF2CC3B6822B}" />
        <Execution ProcessID="3092" ThreadID="5176" />
        <Channel>Microsoft-AppV-Server-Publishing/Admin</Channel>
     </Event>


    SaM



    • Edited by SonaJK Monday, January 13, 2014 1:37 PM added log
    Monday, January 13, 2014 1:27 PM

Answers

All replies

  • Hello,

    What happens if you repair the package - does that resolve the issue?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, January 13, 2014 10:35 PM
  • Hi,I tried repairing that didn't helped.

    SaM

    Tuesday, January 14, 2014 4:49 AM
  • Hello,

    Are there any changes, such as Windows updates, scheduled tasks executing, installed software, that has happened the last two days?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, January 14, 2014 8:06 AM
  • No, changes, But we were applying few local group policies, which we removed as we felt that might be the issue

    SaM

    Tuesday, January 14, 2014 8:08 AM
  • Hello,

    If you remove and add the package again, does the error disappear?

    Are you opening the applications through shortcuts or through file-type associations?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, January 14, 2014 9:08 AM
  • The issue is that AppV 5 SP2 doesn't include a new server that supports 2012 R2 and Windows 8.1. Microsoft has a hotfix that adds the necessary support

    Download Hotfix Here

    Wednesday, January 15, 2014 1:55 PM
  • hi! I have installed that update. Also i have sequenced Teamviewer 9, which is not giving any issues. So i am suspecting that its ODT which has done something in that package. Cant we sequence office 2013 also usingg sequencer ? Its really annoying issue.

    And i tried to remove and add package again, same issue.


    SaM

    Friday, January 17, 2014 8:04 AM
  • We have the same issue. All other applications seem to work fine.

    App-V 5.0 SP1 with hotfix package 2 installed on the App-V Management/Publishing server. We only use Windows Server 2012 RDS instead of R2. On the RDS servers, App-V 5.0 SP2 is installed. We use User Profile Disks and also used the ODT for Office 2013.

    I our case it worked for a few hours. We didn't change anything (no updates of other things) other than having a few users try to login with different accounts to test the application. Reinstalling the client doesn't work and we also tried to removed all AppVClientPackages and then clear the cache from locations like:

    %LOCALAPPDATA%\Microsoft\AppV\Client\VFS
    %APPDATA%\Microsoft\AppV\Client\VFS
    C:\ProgramData\App-V

    I'll post a solution if I find one.

    Friday, January 17, 2014 1:46 PM
  • Hi thanks for confirming issue, even i am trying from my side, if i find any solution i'll post it here.


    SaM

    Friday, January 17, 2014 1:59 PM
  • hi, i have posted issue in partner support as well here to see if i get good response. Else i might go for MS support in a week or so.

    SaM

    Thursday, January 23, 2014 12:06 PM
  • I created a Premier Support ticket last week with Microsoft and we are currently working on it. I'll keep you posted.
    Monday, January 27, 2014 9:35 AM
  • hi!, did MS support helped? any update?


    SaM

    Wednesday, February 5, 2014 1:47 PM
  • We are still working on it. So far no luck. They have not been able to reproduce the issue.

    I have a conference call scheduled later today. I'll keep you posted.

    Friday, February 7, 2014 10:34 AM
  • hi, any update?

    SaM

    Thursday, February 13, 2014 12:22 PM
  • I have been working through similar problems. I fixed them by disabling user profile disks in my RDS environment. Some apps worked without any issues. Some, Office in particular, would work fine on a client OS with AppV 5, but fail on on the RDS servers with UPDs enabled. Disabling UPDs solved the issue.
    Monday, February 17, 2014 1:58 PM
  • Hello,
    There is a new release of ODT;

    http://www.microsoft.com/en-us/download/details.aspx?id=36778

    You can try creating packages using that version


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, February 25, 2014 11:24 PM
  • Hi,

    I have same issue after creating appv package with new ODT and also applied some Microsoft hot-fix from

    http://support.microsoft.com/kb/2956985/en-us

    http://support.microsoft.com/kb/2940354/en-us

    but not helped me.

    Saturday, May 17, 2014 5:30 AM